Chdk for SX130 IS ? - page 17 - CHDK Releases - CHDK Forum  

Chdk for SX130 IS ?

  • 1094 Replies
  • 251276 Views
*

Offline achillies

  • ***
  • 227
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #160 on: 01 / February / 2011, 17:05:22 »
Advertisements
Hey Crew.. I've been reading this forum for over a month in anticipation of getting my new sx130 from Marlboro (a free prize).  Literally, the only reason I got the camera was the existance of CHDK and the ability to run (and WRITE) scripts.  I currently have a 4G card, formatted to approx 3.8G.  The camera is running 1.01C (I didn't need to update the Canon firmware). I used cardtricks to format the card, and on the card itsself created a directory called bootfiles to hold the different versions of bootdisk, etc.. for the different builds here. I tried the builds from #82, #86 and #101, and all worked fine booting the camera in review mode, and then switching to capture taking both pictures and video.  I have not used too many CHDK setting changes, but using #82 I can successfully load and use the Fast Motion detection script without any problems (except the battery.. I gotta get a power adapter).

I really have to say thanks to quid and everybody else who has helped get this so far (so fast!)

Yo Quid.. you need a donation button!

EDIT -- Well, I did speak a little too quickly.  Once I've loaded certain scripts, I have to remove/rename the CCHDK.CFG file to unload them.  I've also noticed some other little quirks, but I'll try to be more descriptive once I figure out how. :-[
« Last Edit: 02 / February / 2011, 23:19:02 by achillies »
Don't let the sands of time get in your lunch.

Re: Chdk for SX130 IS ?
« Reply #161 on: 01 / February / 2011, 18:47:19 »
I don't use german.lng but polish.lng. However I had the crash a few minutes ago. I tried to run camera with CHDK a few times, sometimes it ran, but often the crash occured. As I promised, I have removed SD from camera and copied config file.

You can find it here: http://umiej.pl/CCHDK.CFG

This is cfg, as it was the after crash. I hope it's helpfull. More strange is, that after put SD back into the camera no crash was observed. I've restarted maybe 10 times and everything is ok. I haven't done any changes to SD on computer (only cfg file, the last raw and the last jpg were copied, without modification to files on SD).

==EDIT==

Some additional info: the crash come back:/ Almost every time i put the SD on computer, event without doing anything, the crash dissapear. I can then run CHDK. But after turn off camera another and try to boot CHDK another time - it crashes.

Removing SD from camera without putting in computer doesn't change anything. I've removed las raw and last jpg, but it doesn't solve the problem. But since I've shot new photo, the crash didn't back.
« Last Edit: 01 / February / 2011, 19:11:07 by outslider »
if (2*b || !2*b) {
    cout<<question
}

Compile error: poor Yorick

*

Offline quid

  • **
  • 67
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #162 on: 02 / February / 2011, 14:15:59 »
It's a bug in CHDK, not in SX130 port. Text buffer is too small (64 bytes) for memory info message in Polish and German language. I've attached a source code patch for CHDK.

*

Offline Anton

  • *
  • 13
Re: Chdk for SX130 IS ?
« Reply #163 on: 03 / February / 2011, 03:45:55 »
@quid
Thank you very much.
Will patch be implemented in (any? next?) sx130is-101c-x.x.x.zip?
I,m too stupid to use gui_c-rev1054.patch as it is.
On the other side:
What steps are to do, to it by myself?
My last attempt to learn programming was in the early 1980's....
« Last Edit: 03 / February / 2011, 04:20:54 by Anton »


*

Offline quid

  • **
  • 67
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #164 on: 03 / February / 2011, 07:17:53 »
This patch will be included in my next build. I'm going to do it this weekend. I suggest to use English language until then.

*

Offline whim

  • ******
  • 2013
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: Chdk for SX130 IS ?
« Reply #165 on: 03 / February / 2011, 07:29:17 »
@quid

As a CHDK bug, maybe report this on the bugtracker ?

wim


Re: Chdk for SX130 IS ?
« Reply #166 on: 03 / February / 2011, 11:58:46 »
Sorry to hear about your camera, but I don't think it was because of dual partitions. There was small bug with detection of second partition, but I've had no problems or crashes during testing before and after the fix. Did you use latest version from reply #101 or earlier?


i used the version from #101 but i have a question on the patches do you have to apply the patch yourself or is it just the code used if you do have to apply the patch is there a guide that tells you how?

Re: Chdk for SX130 IS ?
« Reply #167 on: 03 / February / 2011, 13:29:06 »
First of all, thanks to quid and everyone working on this cam's CHDK. With "Video Quality Override" now working, I can use the camera as a sound recorder. Shooting at 320x240 and Video Quality set to "1" takes about 13Mb per minute (11Mb the audio track and just 2Mb the video track). Then you can extract the audio track with Avidemux. Anyways sound quality sucks due to the mikes picking up the continuous and annoying IS system noise. Maybe someday I'll try to add an external mike's jack. Already got the proper screwdriver to set the camera apart but don't have the guts for it yet heh.


*

Offline quid

  • **
  • 67
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #168 on: 03 / February / 2011, 15:57:22 »
@whim: You're right, I will report this.

@Vash11779: This is source code patch. If you don't have any experience with compiling open source software from source code, then I suggest you to wait for next binary. Some basic instructions are available here: http://chdk.wikia.com/wiki/Compiling_CHDK_under_Windows

@elpols: Wow, why do you want to use camera like this for sound recording? I think there are devices much better for this task?

Re: Chdk for SX130 IS ?
« Reply #169 on: 03 / February / 2011, 18:25:13 »
@quid - I understand elpols - since i've got camera I don't have to buy other device to record some sounds - like interviews and so on. I like to perform some interview with my grands, I like to save they stories. Or lectures on the University. I don't need perfect or even good quality. I just want to hear the words:) So - changing camera into sound recorder is great idea.
It would be perfect, if there were a possibility to not even open the lens and do not save image, just to record sound.
Ok, forgive me for this offtopic:) Just for explanation.
if (2*b || !2*b) {
    cout<<question
}

Compile error: poor Yorick

 

Related Topics