Chdk for SX130 IS ? - page 71 - CHDK Releases - CHDK Forum

Chdk for SX130 IS ?

  • 1095 Replies
  • 272998 Views
Re: Chdk for SX130 IS ?
« Reply #700 on: 19 / July / 2011, 06:07:47 »
Advertisements
I'm trying to use ultra intervalometer with my SX130IS, one shot every ten minutes, "endless".  Except after a few hours it stops - most recently, after the 27th shot.  I'm using external power from a UPS.  There is lots of space on the 4Gbyte card.  Quality override is off.  I'm using scene selection foliage and  a tripod.  The native power auto power down setting is "off".

I'm eager for suggestions as to what I might be doing wrong.

Re: Chdk for SX130 IS ?
« Reply #701 on: 19 / July / 2011, 19:10:07 »
How does it work if you use something less, like once every minute or every 10 seconds?
How do you like your UPS?  Will you always be near 110V?
I'm making a battery powered external supply which will convert 6 AA batteries in series to 3.3 volts.
almost done.  Just waiting for a 2.35 x .7 power plug for the side of my camera.
   

Re: Chdk for SX130 IS ?
« Reply #702 on: 20 / July / 2011, 01:22:59 »
I tried again before I left for work today, and it only took 9 shots before stopping this time.

For the purposes of this intended collection, I'll always be near 110V.  The UPS is an APC Back-UPS RS 1500 with a sidecar extra battery and has been working fine for more than a year with my home computer.  I just gave the camera a try with a capture every five seconds, and at 200+ pictures, it's still going strong.

The point to this project is to get me 24 hours from my window at home, which has a view I'm fond of.  At work I'm in a windowless office, and although I'm inundated with digital clocks, they don't give me any visceral sense of of the time of day.  I want my computer screen background to be the view from my window at home.  I don't have disk space for a 24 hour movie, but I do have software that can fade from one photo to another,  I settled on one photo every 10 minutes because that seems to capture the change in light sufficiently when it's changing fastest, at dawn and dusk.

I have two hypotheses for the failures:

1. Even though the camera has external power, the batteries are signalling that they're getting weak and it shuts itself down for that reason.  I'm going to try removing the batteries from the camera and run exclusively on external power.

2. The maximum amount of time I can set before the view screen goes blank after inactivity is three minutes.  Perhaps that transition to screen blanking is botching something.  Once the screen blanks, I get no indication at all that the camera is taking pictures, although for a while it still is.  I'll switch to one photo every 179 seconds to try to prevent the screen blanking.

Neither seems likely to me, but I am very much a newb.

I'm going to try again for another 24 hour run; that should just fit in the the 3.6Gbyte I have free.

Re: Chdk for SX130 IS ?
« Reply #703 on: 20 / July / 2011, 09:02:08 »
My A650 would do time lapse for many hours - until the batteries gave out or the card filled up.  But then I always used short intervals.  The SX130 screen going blank might be the problem.  I think you can pre-blank-out the screen by inserting a plug in the output jack.  My external power pack picture is attached.  Can't figure out how to make image appear in the post text.  Haven't tried the power pack yet.  Waiting for a power plug in the mail.  Where did you get your power plug?  Takes a 235  x .7 which seems to be rare.


Re: Chdk for SX130 IS ?
« Reply #704 on: 21 / July / 2011, 12:47:56 »
I have installed the correct build for my sx130 is, and figured out how  to record images in raw format, but my copy of p.s. elements 9 won't open the cr2 files.  I downloaded something called rawtherapy and installed it, and it will open the files, so I know they're valid files.  But I want to work on them in photoshop.  Any suggestions?  Is this a question I can go to Adobe with?  Thanks

*

Offline achillies

  • ***
  • 227
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #705 on: 21 / July / 2011, 14:42:28 »
Regarding SDM - I had posted these files elsewhere, but it seems like this is a good place to put them for now.

**For Interested Parties - build for firmware 101c only** - Courtesy of Microfunguy (tested by me).

Attached to this message is all you need to run SDM (CHDK's quiet cousin that is geared toward stereo images).

Unzip all of the files from both attachments, and copy them to a bootable SD card (prepared the same way as CHDK).  Lock the card, and when you turn your camera on you will be running SDM.
« Last Edit: 26 / July / 2011, 19:05:20 by achillies »
Don't let the sands of time get in your lunch.

Re: Chdk for SX130 IS ?
« Reply #706 on: 22 / July / 2011, 11:04:32 »
r1bryan: My external power supply is a "Digital Concepts(TM) Digital Camera Universal AC Power Adapter" set to 3 Volts.  It's available from http://www.amazon.com/Digital-Concepts-Universal-Adapter-Cameras/dp/B0002DDZ6G/ref=sr_1_1?s=electronics&ie=UTF8&qid=1311346916&sr=1-1


Re: Chdk for SX130 IS ?
« Reply #707 on: 22 / July / 2011, 14:13:11 »
OK thanks thyrsus.  A great value at that price.  Still working on my dc input device as I'll be away from 110v taking pictures of clouds and other remote stuff.
rb
 


Re: Chdk for SX130 IS ?
« Reply #708 on: 23 / July / 2011, 22:41:20 »
Hello fellow CHDK lovers, especially those who love the ability to use/write scripts!

I think I found a little but nasty bug with the SX130 version of CHDK:

Many scripts that I love have an option to set focus to infinity at the beginning of a shoot session, then lock it there for the rest of the shooting. I think mainly about some nice intervalometers.

Unfortunately, the set_focus command does not seem to have any effect.

So please, try this little test script I wrote, tell me if you experience the same problem as I do.

So maybe some guru will spend few minutes fixing this thing for us, poor humans.  

Thank you all!

Jeff
« Last Edit: 23 / July / 2011, 22:46:57 by NovaJeff »
La parcimonie, c'est bien beau, mais faut pas trop en mettre.

*

Offline philmoz

  • *****
  • 3146
    • Photos
Re: Chdk for SX130 IS ?
« Reply #709 on: 23 / July / 2011, 23:18:29 »
Hello fellow CHDK lovers, especially those who love the ability to use/write scripts!

I think I found a little but nasty bug with the SX130 version of CHDK:

Many scripts that I love have an option to set focus to infinity at the beginning of a shoot session, then lock it there for the rest of the shooting. I think mainly about some nice intervalometers.

Unfortunately, the set_focus command does not seem to have any effect.

So please, try this little test script I wrote, tell me if you experience the same problem as I do.

So maybe some guru will spend few minutes fixing this thing for us, poor humans. 

Thank you all!

Jeff

Try putting the 'set_aflock 1' before the 'set_focus 65535' not after.
I don't have an SX130; but this works on the G12.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)

 

Related Topics