Chdk for SX130 IS ? - page 77 - CHDK Releases - CHDK Forum

Chdk for SX130 IS ?

  • 1095 Replies
  • 355843 Views
Re: Chdk for SX130 IS ?
« Reply #760 on: 16 / August / 2011, 10:27:57 »
Advertisements
hi been using CHDK for sx 120 with ptp interface - now switched to SX130 and have noticed something strange

if i zoom to around 2-4 x around 12 steps out of approx 120 and take a picture with the ptp interface i find heavy pincushion distortion.however if i take the picture normally using the shutter button there is hardly any pincushion distortion.

is the ptpinterface or the LUA shoot function calling some routine other than what is called when the button is pressed. is the lua shoot routine bypassing some correction ?

any help would be welcome

Re: Chdk for SX130 IS ?
« Reply #761 on: 17 / August / 2011, 02:17:57 »
ok tested some more and the pincushion effect is very pronounced in fact it seems to increase with zoom.



the first one is taken with the ptp interface and the second one with a physical button press.

any help from the gurus (philimoz, achillies etc. ) would be highly appreciated as i am in a fix.
for the script i have tried using shoot() and even press("shoot_full") and the pincushion effect is present in both the cases

there is no distortion at 0 zoom



*

Offline philmoz

  • *****
  • 3407
    • Photos
Re: Chdk for SX130 IS ?
« Reply #762 on: 17 / August / 2011, 03:49:32 »
Looks like the camera is not recognising the zoom position and applying the wide angle distortion correction to the image.

Most recent cameras have a lot of distortion at the wide end that quickly reduces as you zoom in. The firmware corrects the distortion in the JPEG image - you can see it if you shoot RAW.

In your case the camera seems to think it is still at the widest zoom so is applying the correction regardless.

Try zooming to full telephoto in the camera then plugging in to the computer and using ptp to zoom and shoot. If my theory is correct  when you zoom back to 0 you should see the opposite as the camera will think it's still at the long end.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

Re: Chdk for SX130 IS ?
« Reply #763 on: 17 / August / 2011, 03:54:57 »
thank you for that quick response. i will immediately report back with what i find


Re: Chdk for SX130 IS ?
« Reply #764 on: 17 / August / 2011, 04:02:54 »

i tried doing what you suggested but the effect remains the same. however imo it is because as soon as i plug in the camera the camera switches to playback mode and the lens is retreated back. so by the time the pc starts talking to the camera it is back at the start.

however i think you are right and that the distortion is because of the jpg correction. i would really be gratefull if you can suggest what steps i may take to solve this problem

*

Offline philmoz

  • *****
  • 3407
    • Photos
Re: Chdk for SX130 IS ?
« Reply #765 on: 17 / August / 2011, 04:13:53 »

i tried doing what you suggested but the effect remains the same. however imo it is because as soon as i plug in the camera the camera switches to playback mode and the lens is retreated back. so by the time the pc starts talking to the camera it is back at the start.

however i think you are right and that the distortion is because of the jpg correction. i would really be gratefull if you can suggest what steps i may take to solve this problem


What firmware version do you have?
I can try building a version using the code from the SX30/G12 version to see if it works better.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

Re: Chdk for SX130 IS ?
« Reply #766 on: 17 / August / 2011, 04:24:25 »
my firmware version is 101f



it really never fails to amaze me to think about the help i have been receiveing on this forum wow !! i am forever gratefull to you and mweerden and all the others for the quick responses

*

Offline philmoz

  • *****
  • 3407
    • Photos
Re: Chdk for SX130 IS ?
« Reply #767 on: 17 / August / 2011, 04:28:56 »
my firmware version is 101f

Try this version.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)


Re: Chdk for SX130 IS ?
« Reply #768 on: 17 / August / 2011, 04:34:45 »
downloading ...
report back to you in a few minuts

Re: Chdk for SX130 IS ?
« Reply #769 on: 17 / August / 2011, 05:05:18 »


that was great !!!
the problem is almost solved - thank you !!
there is an slight opposite effect at the wide side of the zoom - little bit of a barrel distortion - but i think can live with that.

can you tell me how i can patch it to my copy or should i wait for the changes to the trunk ?

actually i am using a kind of a mixture of code i had an excellent working copy of mweerden's patched copy for live preview on CHDK DE trunk 685 for the sx 120 then i migrated to sx 130 and i could get the 101f only in the latest trunk745.
since i had already had a patched trunk i just added the sx 130 from trunk 745 to trunk 685.  ;)

and thank you once again !!!



 

Related Topics