IXUS 105 / SD1300 IS porting thread - page 7 - DryOS Development - CHDK Forum  

IXUS 105 / SD1300 IS porting thread

  • 772 Replies
  • 179859 Views
Re: IXUS 105 / SD1300 IS porting thread
« Reply #60 on: 22 / December / 2010, 06:25:50 »
Advertisements
Hi,

The file is already name diskboot.bin.
Do you have any idea what is actually working?
Do you know if it will be officially port to chdk soon?
Thanks,

*

Offline c10ud

  • ***
  • 245
Re: IXUS 105 / SD1300 IS porting thread
« Reply #61 on: 22 / December / 2010, 07:58:53 »
i don't have the camera anymore, so i don't think i can improve further the port, sorry

Re: IXUS 105 / SD1300 IS porting thread
« Reply #62 on: 22 / December / 2010, 09:16:33 »
Hi,

Is it correct if the download file is a diskboot.bin?
What is working with this build?

Thanks,

Yes just rename it to diskboot.bin
I just compiled c10ud's code.
That will obviously work on 105.
Do you have the uncompile script just because I am curious?

Re: IXUS 105 / SD1300 IS porting thread
« Reply #63 on: 22 / December / 2010, 12:36:04 »
i don't have the camera anymore, so i don't think i can improve further the port, sorry
What is working and what is not?  Is it possible to get the uncompile script?


*

Offline c10ud

  • ***
  • 245
Re: IXUS 105 / SD1300 IS porting thread
« Reply #64 on: 22 / December / 2010, 12:46:55 »
here's my latest post on the topic:
ok, new source available in http://drop.io/ixus105_sd1300 just download ixus105_0.2.zip and have fun.
I added ptp stuff for easier debug of some stuff, since it's in trunk now.. :)

This version has shoot() fixed, zoom fixed, fl should be ok, gui ok, etc.

tested:
- loading, drawing
- some lua stuff
- exp override

current issues/unfeatures:
- load script = camera shutdown
- save raw = camera shutdown (some stub must be wrong)
- no video override
- edge overlay works but disappears soon
- zebra doesn't seem to be working
- some other overrides does not seem to work correctly
however please notice that i built the code with an old chdk svn version, so it may need a bit of refactor for getting this camera running with latest trunk.

as for the "uncompile" script, what exactly do you mean? i used this script for getting the disassembled firmware: http://chdk.wikia.com/wiki/GPL:disassemble.pl and some IDA later

Re: IXUS 105 / SD1300 IS porting thread
« Reply #65 on: 22 / December / 2010, 13:29:04 »
Hi,

I am a newbie but what I understand is if something got compile, it is because you start from something uncompile.  May be a text file, your code.  This is what I mean.  Actually, I have the firmware drop and the bin file.  But not your coding.

Thanks

*

Offline c10ud

  • ***
  • 245
Re: IXUS 105 / SD1300 IS porting thread
« Reply #66 on: 22 / December / 2010, 14:49:01 »

Re: IXUS 105 / SD1300 IS porting thread
« Reply #67 on: 22 / December / 2010, 22:54:42 »
Hi,

I just tried the diskboot.bin

1. With card tricks -->format+make disk bootable
2. Copy the download from here diskboot.bin
3. Create CHDK directory and SCRIPTS subdirectory--> Actually, I have no script but later.
4. WRITE Protect the SDCard
5. Put it inside the camera
6. Press the play button and nothing.  The camera did not power on at all.

There is no PS.FIR file.
Any idea?

Thanks,



*

Offline reyalp

  • ******
  • 13391
Re: IXUS 105 / SD1300 IS porting thread
« Reply #68 on: 22 / December / 2010, 23:35:40 »
6. Press the play button and nothing.  The camera did not power on at all.
This usually means the wrong diskboot for the camera. Are you sure your ixus105 has the same canon firmware version this was built for ?
Don't forget what the H stands for.

Re: IXUS 105 / SD1300 IS porting thread
« Reply #69 on: 23 / December / 2010, 08:15:54 »
Hi,

I used this one.
www.box.net/chdk/6/55272271/536017391  took higher in this thread
1. With Camera version tool, I get  Powershot SD1300 IS/IXUS 105/IXY200F     Version 100D
2. How can I be sure??  Any other suggestion?

Thanks,

 

Related Topics