IXUS 105 / SD1300 IS porting thread - page 76 - DryOS Development - CHDK Forum

IXUS 105 / SD1300 IS porting thread

  • 764 Replies
  • 127383 Views
Re: IXUS 105 / SD1300 IS porting thread
« Reply #750 on: 09 / June / 2016, 03:19:24 »
Advertisements
The difference is  almost certainly related to the method used to set zoom rather than the client. The chdkptp GUI just sends click('zoom_in') or click('zoom_out') for each button press. Using script set_zoom lets you go directly to a specific zoom point, but in some ports the camera doesn't update it's distortion correction settings.

Good Hint! It seems. Using manual zoom, everything is fine, using set_zoom shows those distortions.

It is possible we can adjust the port to make set_zoom behave correctly.

Do you have any hint on how to do that?  CHDK 1.5.0-4626 firmware 100d

*

Offline reyalp

  • ******
  • 12172
Re: IXUS 105 / SD1300 IS porting thread
« Reply #751 on: 09 / June / 2016, 13:10:16 »
Do you have any hint on how to do that?  CHDK 1.5.0-4626 firmware 100d
If you want to try to modify the code yourself, look at ports which use CAM_USE_ALT_SET_ZOOM_POINT and CAM_USE_ALT_PT_MoveOpticalZoomAt in platform_camera.h (ixus140_elph130 is an example)

Note that enabling these may have other side effects, like causing the camera to crash after zoom, possibly depending on focus mode. Some cameras may need CAM_NEED_SET_ZOOM_DELAY to prevent crashes.
Don't forget what the H stands for.

*

Offline reyalp

  • ******
  • 12172
Re: IXUS 105 / SD1300 IS porting thread
« Reply #752 on: 18 / June / 2016, 19:11:57 »
Here's a test build for ixus105_sd1300 100d, with CAM_NEED_SET_ZOOM_DELAY, CAM_USE_ALT_SET_ZOOM_POINT and CAM_USE_ALT_PT_MoveOpticalZoomAt

Please check whether this fixes (or reduces) the distortion problems, and whether it crashes if you use set_zoom to move through the whole zoom range.
Don't forget what the H stands for.

Re: IXUS 105 / SD1300 IS porting thread
« Reply #753 on: 13 / July / 2016, 12:33:38 »
Works great! Played around for 10mins zooming around, no issues so far.

(images are at 90% zoom). Left reyalp modif working, right CHDK 1.5.0 4659.


*

Offline reyalp

  • ******
  • 12172
Re: IXUS 105 / SD1300 IS porting thread
« Reply #754 on: 16 / July / 2016, 15:18:38 »
Works great! Played around for 10mins zooming around, no issues so far.

(images are at 90% zoom). Left reyalp modif working, right CHDK 1.5.0 4659.
@axoin
Thanks, I've checked this in for both 1.4 and 1.5

Can you check
1) Does the camera re-focus after you use set_zoom. If Continuous AF is enabled in the canon menu, please try with it off.
2) If you use AF lock (either set_aflock(1) or using regular Canon keys) and then use set_zoom, does it crash?
Don't forget what the H stands for.

Re: IXUS 105 / SD1300 IS porting thread
« Reply #755 on: 27 / July / 2016, 18:19:07 »
a). There is no setting for Continous AF.
In Auto Mode, it does refocus after set_zoom.
In P Mode it does not. This is the same behaviour as with stock firmware.

b). No it does not. You can zoom while it says AFL in the display and it doesn't crash. Works only in P though (as intended, says handbook). Looks fine :)

*

Offline koshy

  • *****
  • 979
Re: IXUS 105 / SD1300 IS porting thread
« Reply #756 on: 15 / November / 2019, 11:19:56 »
@srsa_4c Little did I know. While things in Rec mode look as if they can be improved upon, Play does not contain anything but grascale and shades of orange, how do I get CHDK Logo like Red into that?

*

Offline koshy

  • *****
  • 979
Re: IXUS 105 / SD1300 IS porting thread
« Reply #757 on: 15 / November / 2019, 11:21:32 »
This is what Rec can be made using what the palette as provided by the Canon FW.

Code: [Select]
// Record mode colors
unsigned char rec_colors[] =
{
        COLOR_TRANSPARENT,          // Placeholder for script colors
        COLOR_BLACK,                // Placeholder for script colors
        0x01,                       // White
        0x66,                       // Red
        0x66,                       // Dark Red --- there is none this is the same red
        0x1E,                       // Light Red --- there is none this is a dark orange
        0x69,                       // Green
        0x6B,                       // Dark Green
        0x5F,                       // Light Green
        0x61,                       // Blue
        0x67,                       // Dark Blue
        0x68,                       // Light Blue / Cyan
        0x12,                       // Grey
        0x16,                       // Dark Grey
        0x0E,                       // Light Grey
        0x60,                       // Yellow
        0x4C,                       // Dark Yellow
        0x6C,                       // Light Yellow
        0xF1,                       // Transparent Dark Grey
        0x41,                       // Magenta --- there is none this is an orange
};
« Last Edit: 15 / November / 2019, 11:24:10 by koshy »


*

Offline koshy

  • *****
  • 979
Re: IXUS 105 / SD1300 IS porting thread
« Reply #758 on: 15 / November / 2019, 11:22:39 »
Ok, what I posted yesterday for i105 in terms of simple Rec mode palette is much better as it actually relates to the camera, no idea where the stuff in the current port comes from. I get a green battery, display overlay and menus are legible. As soon as I press func that breaks as the palette changes, see attached. Can this be detected there seem to be ok colors in that case or will only a custom palette fix this? Where can I read about implementing such a custom palette?

One more thing, I figured I have a red, let's enable a zebra... Zebra floods half the screen with rubbish when it kicks in, can we fix that?

*

Offline srsa_4c

  • ******
  • 4035
Re: IXUS 105 / SD1300 IS porting thread
« Reply #759 on: 15 / November / 2019, 11:41:12 »
While things in Rec mode look as if they can be improved upon, Play does not contain anything but grascale and shades of orange, how do I get CHDK Logo like Red into that?
Not without injecting extra colors into that palette.
Quote
As soon as I press func that breaks as the palette changes, see attached.
If you bring up a Canon "dialog", the palette tends to change. Only a few ports handle that as supporting the plain rec and play mode is usually sufficient.
The simple method can't cope with this, injected colors are needed.

Quote
One more thing, I figured I have a red, let's enable a zebra... Zebra floods half the screen with rubbish when it kicks in, can we fix that?
Try removing these lines from platform/ixus105_sd1300/lib.c:
Code: [Select]
// Y multiplier for cameras with 480 pixel high viewports (CHDK code assumes 240)
int vid_get_viewport_yscale() {
return 2;
}

 

Related Topics