IXUS 1000 HS Porting Thread - page 37 - DryOS Development - CHDK Forum

IXUS 1000 HS Porting Thread

  • 440 Replies
  • 148039 Views
*

Offline nafraf

  • *****
  • 1308
Re: IXUS 1000 HS Porting Thread
« Reply #360 on: 15 / October / 2013, 20:55:51 »
Advertisements
I would like to test if 101a could be available
OK, I sent you a PM with the link to the file.  Thanks for testing.

Re: IXUS 1000 HS Porting Thread
« Reply #361 on: 03 / November / 2013, 01:55:17 »
This works very fine, the only problem we discussed with pm's is this:

"chdkptp has distorted liveview"
http://img4.imageshack.us/img4/3606/femm.jpg

Got these messages from chdkptp

rec-mode:

C:\temp\tp\lua\gui_live.lua:458: failed to create image
stack traceback:
   [C]: in function 'get_viewport_pimg'
   C:\temp\tp\lua\gui_live.lua:458: in function <C:\temp\tp\lua\gui_live.lua:447>
   (tail call): ?
   [C]: in function 'MainLoop'
   C:\temp\tp\lua\gui.lua:630: in function <C:\temp\tp\lua\gui.lua:616>
   (tail call): ?
   C:\temp\tp\lua\main.lua:231: in main chunk
   [C]: in function 'require'
   [string "require('main')"]:1: in main chunk


play-mode:

C:\temp\tp\lua\gui_live.lua:458: failed to create image
stack traceback:
   [C]: in function 'get_viewport_pimg'
   C:\temp\tp\lua\gui_live.lua:458: in function 'action'
   C:\temp\tp\lua\gui_live.lua:403: in function <C:\temp\tp\lua\gui_live.lua:383>
   [C]: in function 'xpcall'
   C:\temp\tp\lua\gui_live.lua:424: in function <C:\temp\tp\lua\gui_live.lua:422>
   (tail call): ?
   [C]: in function 'MainLoop'
   C:\temp\tp\lua\gui.lua:630: in function <C:\temp\tp\lua\gui.lua:616>
   (tail call): ?
   C:\temp\tp\lua\main.lua:231: in main chunk
   [C]: in function 'require'
   [string "require('main')"]:1: in main chunklive timer update error
C:\temp\tp\lua\gui_live.lua:458: failed to create image

*

Offline reyalp

  • ******
  • 13844
Re: IXUS 1000 HS Porting Thread
« Reply #362 on: 01 / January / 2014, 17:18:10 »
I recently noticed that different subs of this port call shooting_expo_param_override differently.

100d and 102b call it twice, while 100f and 101a only call it once.

Given the spread of versions, it's highly unlikely both are correct. 100f and 101a are nafrafs recent ports. If overrides work correctly on this, then I think we can safely modify the others to use the same approach in that area of capt_seq.c. The double call will be mostly ignored anyway, because the put_off flags will be cleared. If it is actually required, there is some other problem that needs to be addressed.

One thing that should be checked is if ISO overrides work, in case this port needs shooting_expo_iso_override
Don't forget what the H stands for.

Re: IXUS 1000 HS Porting Thread
« Reply #363 on: 12 / February / 2015, 05:28:23 »
I've got a (mostly broken) ixus 1000hs with fw 1.02e and managed to get chdk ported to it.
It is based on the fw 1.02b.


My camera is unable to take pictures (no lens, broken mechanics) so i can't test it myself. If you have firmware 102e and you are willing to test it AND give feedback then let me know and i'll give a link to the package.

I have this camera with 102e on it.  I'd love to test.


*

Offline nafraf

  • *****
  • 1308
Re: IXUS 1000 HS Porting Thread
« Reply #364 on: 12 / February / 2015, 06:41:38 »
fw 102e is not part of fw dump repository, please obtain a firmware dump of your camera , upload it to a file share server and post the link here.

Re: IXUS 1000 HS Porting Thread
« Reply #365 on: 12 / February / 2015, 15:27:12 »

*

Offline nafraf

  • *****
  • 1308
Re: IXUS 1000 HS Porting Thread
« Reply #366 on: 13 / February / 2015, 21:22:33 »
Test version valid for 7 days. Please test and report.
EDIT: Wrong attachment, I´ll post the file for 102e later.
« Last Edit: 14 / February / 2015, 09:12:02 by nafraf »

Re: IXUS 1000 HS Porting Thread
« Reply #367 on: 14 / February / 2015, 05:17:35 »
My camera arrived refurbished from Canon with version 1.02e.  Is there an F out already?  I really just want RAW support on this thing.  I am working on porting it myself via chdk-pt and such, but no luck as of yet.  The documentation in the wiki is rather lacking at some parts.


Re: IXUS 1000 HS Porting Thread
« Reply #368 on: 14 / February / 2015, 10:52:58 »
My camera arrived refurbished from Canon with version 1.02e.  Is there an F out already?
I'm confused.  nafraf just posted a test build for the 1.02e.  You state that you have a camera with 1.02e.  Why are you asking about an F version?

Quote
I really just want RAW support on this thing.  I am working on porting it myself via chdk-pt and such, but no luck as of yet.  The documentation in the wiki is rather lacking at some parts.
We are always willing to accept help improving the documentation.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 1000 HS Porting Thread
« Reply #369 on: 14 / February / 2015, 16:33:52 »
Reading comprehension failure on my part.  The one listed above was 1.00f, not 1.02f.

 

Related Topics