IXUS 1000 HS Porting Thread - page 12 - DryOS Development - CHDK Forum supplierdeeply

IXUS 1000 HS Porting Thread

  • 439 Replies
  • 133426 Views
Re: IXUS 1000 HS Porting Thread
« Reply #110 on: 06 / November / 2010, 05:37:28 »
Advertisements
thanks for your file, i use now this file and compile and test without any log output..This that called video button is the button on top backside.

On my camera happen this.As soon i press the button(not release), the camera move out the lens and switch to video record mode but do not record.

only when press the video button then again it record.but no chdk menu come.

but please can you post  2 values (no key press 1 key press )from your camera, so i can see how this messages are on working cameras.

when you get for example values when no key is press, that are higher as values when key is press, then its clear for me wy the IX1000 code not work.IX 1000 uses active high bits, and when press a button the number get higher.

or in other words, when you press a key on your camera, is the number then higher or lower as the number, when you press no key ?

I mean with that test code, you post, and i copy for easy from the keyboard thread you post

static char osd_buf[64];

   int isHeldDisp = 0;

   kbd_prev_state[0] = kbd_new_state[0];
   kbd_prev_state[1] = kbd_new_state[1];
   kbd_prev_state[2] = kbd_new_state[2];
   kbd_fetch_data(kbd_new_state);

  
   sprintf(osd_buf, "1:       %8x  --> %8x", physw_status[0],kbd_new_state[0]);
   draw_txt_string(20, 10, osd_buf, conf.osd_color);

   sprintf(osd_buf, "2:       %8x  --> %8x", physw_status[1],kbd_new_state[1]);
   draw_txt_string(20, 11, osd_buf, conf.osd_color);

   sprintf(osd_buf, "3:       %8x  --> %8x", physw_status[2],kbd_new_state[2]);
   draw_txt_string(20, 12, osd_buf, conf.osd_color);
   msleep(500);
« Last Edit: 06 / November / 2010, 05:39:01 by Bernd R »
Ixus 1000 HS

*

Offline asm1989

  • *****
  • 527
  • SX720, SX260, SX210 & SX200
Re: IXUS 1000 HS Porting Thread
« Reply #111 on: 06 / November / 2010, 06:19:41 »
I think you are looking into the wrong place here my_kbd_read_keys is where the main things happen and also here: kbd_process() at core/kbd.c, the key pressed or released stuff gets latter used by other .c files, I mean If the keys work as expected in normal cam operation we have right the numbers if not we have a problem there.



Quote
On my camera happen this.As soon i press the button(not release),
to get into the chdk menu there must be a quick press on this button not a long press with no release this in my cam  also start to record video, but only in recordmode, since in playback it's used for print, if I long press it , it will also try to print the selected pic in playback mode

anyway If you want me to test anything on sx210, you have the kbc.c of the sx210 in the platform folder, put in that file whatever you need me to test, post the kbc.c file and I will test it.

and the print button dont work could be because we have wrong its code ??
0 -> 0
ef-> 0
418000 -> 0    Video

  1101111 (iddle)
11101111 (video-> Print)
10000000 ->   80

or some of the other keys and so the masks are wrong too.

I dont think is because of the jog dial but I have finished new boot.c with the jogdial enable for you to test.

http://www.4shared.com/file/RA5nuwYE/bootcixus1000v006Jogdial.html
« Last Edit: 06 / November / 2010, 07:19:31 by asm1989 »

Re: IXUS 1000 HS Porting Thread
« Reply #112 on: 06 / November / 2010, 09:39:06 »
>anyway If you want me to test anything on sx210, you have the kbc.c of the sx210 in the >platform folder, put in that file whatever you need me to test, post the kbc.c file and I will test >it.

here i have done a SX210 build and i add the kybd.c source too

http://www.zshare.net/download/82403836455b7f7a/

but you see not so easy what i change.You can also add below code to your own file and test.

Can you also do a ixus 1000 build, maybe there is really something wrong in my compiler options, and your build work ?

the value of video button is correct, i verify that several times.

void my_kbd_read_keys() {
    kbd_prev_state[0] = kbd_new_state[0];
    kbd_prev_state[1] = kbd_new_state[1];
    //kbd_prev_state[2] = kbd_new_state[2];   // nothing to override

now add this code please

static char osd_buf[64];

      sprintf(osd_buf, "1:       %8x  --> %8x", physw_status[0],kbd_new_state[0]);
      draw_txt_string(20, 10, osd_buf, MAKE_COLOR(0xdd,0x6f));

      sprintf(osd_buf, "2:       %8x  --> %8x", physw_status[1],kbd_new_state[1]);
      draw_txt_string(20, 11, osd_buf, MAKE_COLOR(0xdd,0x6f));

      sprintf(osd_buf, "3:       %8x  --> %8x", physw_status[2],kbd_new_state[2]);
      draw_txt_string(20, 12, osd_buf, MAKE_COLOR(0xdd,0x6f));
      msleep(20);

.....



tell me what values you get, when you press no key and what value you get, when you press right key

« Last Edit: 06 / November / 2010, 10:05:10 by Bernd R »
Ixus 1000 HS

*

Offline asm1989

  • *****
  • 527
  • SX720, SX260, SX210 & SX200
Re: IXUS 1000 HS Porting Thread
« Reply #113 on: 06 / November / 2010, 11:12:20 »
Here you have my bin of ixus1000  http://www.4shared.com/file/bWBuq1Zn/bintest-ixus1000v006.html

and testing your code in sx210 I get

no key :
1: 880a19b -->880a19b
2: ffdbf -> ffdbf
3:400000 -> 0

soft right

1: 880a19b -->880a19b
2: fddbf -> fddbf
3:400000 -> 0

almost hard right

1: 880a19b -->880a19b
2: fd5bf -> fd5bf
3:400000 -> 0

hard right

1: 880a19b -->880a19b
2: f95bf -> f95bf
3:400000 -> 0

Hope it helps, anyway I'm using in sx210 only the hard value

Can you get into the chdk menu and enable debug?


Re: IXUS 1000 HS Porting Thread
« Reply #114 on: 06 / November / 2010, 11:37:34 »
>no key :
>1: 880a19b -->880a19b
>2: ffdbf -> ffdbf
>3:400000 -> 0

>soft right

>1: 880a19b -->880a19b
>2: fddbf -> fddbf
>3:400000 -> 0

many thanks for your results.

It is really true that other Canon Camera clear the bit when a key is press.

See here.when no key is press ffdbf is the output of yur camera.its this binary value

%1111 1101 1011 1111

now when you press a key some bits are clear

your result for hard right

>2: f95bf -> f95bf

in binary

%1001 0101 1011 1111

but ixus 1000 work diffrent.

when a key is press, the Bits are set

So i need change all functions in kybd.c to work as opposite

Ixus 1000 HS

*

Offline asm1989

  • *****
  • 527
  • SX720, SX260, SX210 & SX200
Re: IXUS 1000 HS Porting Thread
« Reply #115 on: 06 / November / 2010, 11:48:55 »
Let me know of your advances, maybe checking the others kbc.c for other cams you can get something.
@realyp or some chdk guru do you know it this is happening in any other cam?

Do my bin file works?

Do the jogdial works?

I will start blind porting the capt_seq.c file,  but I will need you to get more values once you can get into de chdk menu and enable debug and memory browser.
« Last Edit: 06 / November / 2010, 11:50:32 by asm1989 »

Re: IXUS 1000 HS Porting Thread
« Reply #116 on: 06 / November / 2010, 12:33:22 »
>Do my bin file works?

it work same as my file, key not work.

so from my compiler option seem all ok.
I compile with OPT_DEBUGGING

the jogdial i dont know how i can test.
I think first i need get the alt button working so chdk menu pop on.
Ixus 1000 HS

*

Offline asm1989

  • *****
  • 527
  • SX720, SX260, SX210 & SX200
Re: IXUS 1000 HS Porting Thread
« Reply #117 on: 06 / November / 2010, 12:40:17 »
This are my compile options


jogdial is turning the dial left or righ

yes the keys are the first step, the print/recordvideo  button is the only not working?

anyway Im a bit puzzled because you were able to see the chdk menu if you change the print codes for other key, so seams that other keys do work??
« Last Edit: 06 / November / 2010, 12:44:20 by asm1989 »


Re: IXUS 1000 HS Porting Thread
« Reply #118 on: 06 / November / 2010, 12:52:51 »
>yes the keys are the first step, the print/recordvideo  button is the only not working?

All keys do not work.

>anyway Im a bit puzzled because you were able to see the chdk menu if you change the print >codes for other key, so seams that other keys do work??

sorry seam you understand me wrong, i never get the chdk menu working, because the IX1000 set a bit on key press.

other camera clear a bit on keypress.

i only want say that i for testing and logging use the right key because the camera go not every press in shoot mode and move out lens, so make the accu live longer.

but this too not work.
« Last Edit: 06 / November / 2010, 12:54:50 by Bernd R »
Ixus 1000 HS

*

Offline asm1989

  • *****
  • 527
  • SX720, SX260, SX210 & SX200
Re: IXUS 1000 HS Porting Thread
« Reply #119 on: 06 / November / 2010, 12:59:39 »
you can try to ! the ifs related to see if it work

 

Related Topics