supplierdeeply

IXUS 1000 HS Porting Thread

  • 418 Replies
  • 48291 Views
*

Offline asm1989

  • *****
  • 527
  • SX720, SX260, SX210 & SX200
  • Publish
    Re: IXUS 1000 HS Porting Thread
    « Reply #260 on: 29 / January / 2011, 13:25:59 »
    Advertisements
    @Bernd R
    I have tested your new raw pattern and its much better now, good work with the findings,

    But Think there is still some issue with the blue channel, it's too blue

    It's the same on your cam?

    Find a better colormatrix

    Code: [Select]
       #define CAM_COLORMATRIX1                               \
             10483, 100000, 47426, 100000, 154560, 100000, \
            -152601,  100000, 673443,  100000, 17846,   100000, \
             549243,   100000, -44625,   100000, -109067,  100000
    #define cam_CalibrationIlluminant1 17 // Standard Light A

    « Last Edit: 29 / January / 2011, 14:04:24 by asm1989 »

  • Publish
    Re: IXUS 1000 HS Porting Thread
    « Reply #261 on: 29 / January / 2011, 14:12:15 »
    @asm1989
    >It's the same on your cam?

    I do a straight show in picasa and colors are near same as in Canon Software.
    I have a blue box photograph, and upload DNG and jpg(is 19:9).was shoot at ISO 1250

    The color is more correct in the RAW to the original

    I see for DNG can define diffrent color matrix, maybe there need some color matrix for diffrent lights add ?
    is it possible in chdk to have more color matrix presets ?

    silky image let choose diffrent from DNG file.

    as you can see both images have a slight blue tint.But i guess that is because of white balance.Raw contain currently no white balance.to get a good raw need always do white balance.

    The light in my room is daylight 6500 Kelvin3(stand on the energy saver light)

    only whats not good in color is the DNG thumbnail, but here can try out the SX30 and G12 code, if thumbnail is better.

    see the upload

    http://www.zshare.net/download/858831424e7a91f5/

    I try your color matrix too, what happen then.

    I test several RAW Konverters, when use lightroom 3(work 30 days as demo) to denoise you can get lots better from jpg too.

    But i like more to see noise as this texture loss and single wrong color pixels that happen by denoiser of canon Camera.

    BTW:

    now boot work ok on my 4 GB card.It was my fault.because of non working boot i activate this line


    //             "BL sub_FF83D2AC\n" // start diskboot.bin

    but with deactivate line only it work.

    A card larger as 4gb i have not prepare, maybe you have a card prepare and can test if boot and swap Partition can work ok
    « Last Edit: 29 / January / 2011, 14:14:38 by Bernd R »
    Ixus 1000 HS

    *

    Offline reyalp

    • ******
    • 9858
  • Publish
    Re: IXUS 1000 HS Porting Thread
    « Reply #262 on: 29 / January / 2011, 17:18:58 »

    //             "BL sub_FF83D2AC\n" // start diskboot.bin

    but with deactivate line only it work.
    That is the canon function to start diskboot.bin. If you un-comment it, then you get an infinite boot loop.
    Don't forget what the H stands for.

  • Publish
    Re: IXUS 1000 HS Porting Thread
    « Reply #263 on: 30 / January / 2011, 04:26:52 »
    @asm1989

    I have test your colormatrix on my testscene, but colors are very wrong.

    http://www.zshare.net/download/859036123d4171cd/

    maybe your pixelformat is diffrent too, can you please do this test

    http://chdk.setepontos.com/index.php?topic=5722.msg60215#msg60215

    I see the capt_seq.c code of your F Firmware is very diffrent to D version.
    seem you have modify it some time ago, can you revert to your first code you do.I thought this is then simular to 100D

    the place where the rawhook is in doesnt matter images are correct.
    I never get a garbage image, so the buffer adress code look too ok.
    Ixus 1000 HS


    *

    Offline asm1989

    • *****
    • 527
    • SX720, SX260, SX210 & SX200
  • Publish
    Re: IXUS 1000 HS Porting Thread
    « Reply #264 on: 30 / January / 2011, 04:50:25 »
    you are right Bernrd ,

    I was using a testing wrong captseq, now the colors are good without the new colormatrix,

    dng4ps dosnt help calculating the matrix due to lack of the new rbg pattern

    What do you have missing now for this port?

  • Publish
    Re: IXUS 1000 HS Porting Thread
    « Reply #265 on: 30 / January / 2011, 09:28:40 »
    >dng4ps dosnt help calculating the matrix due to lack of the new rbg pattern

    yes, to use crw there need compile a new dng4ps or other converter.
    really bad that the IX1000 is the only camera currently that use other color format.
    So only DNG can working now

    >What do you have missing now for this port?

    Have you a Card more than 4 GB that is partionate that chdk can boot ?
    If so, maybe you can test, if IX1000 Port boot on Cards with more than 4 GB

    whats not working currently is
    zebra/Grid/edge overlay is in 4:3 Shoot mode wrong center.

    with ptpcam Camera crash when switch from play mode to record mode.

    ISO overwrite do not work, the address is correct and Canon store here a ISO value.200 for ISO 200 for example.

    #define PROPCASE_ISO_MODE                        149

    but when i activate overwrite ISO, chdk put 0 in this value when i press shutter.and 0 mean automatic

    I find that overwrite shutter speed work.I set 12 sec and the shutter sound is really 12 sec and pic is overexpose alot, so guess it work

    But the badpixel 0.5 sec TV set with command
    shooting_set_tv96_direct(96, SET_LATER);

    do not work.it does not change the value from Canon Firmware

    darframe subtraction on off auto do not work
    The most funny thing i find now today.

    when set darkframe subtraction to on, when call badpixel from raw menu, then badpixels are 86xx.with off they are 83xx.its always same

    and when set to auto, there are when camera is cold 29000 and later when hot, more than 120000 badpixels.

    this is really strange, maybe the address of darkframe subtract or not is wrong.
    the busy display is always show, and more time is need.

    The Aparture overwrite seem too not work.chdk write the correct value in register 23.But register 25 and 26 and some more still contain default Canon values.the values are btw same as other Canon camera, for example 350 is aperture of 3.5

    #define PROPCASE_AV                              23
    #define PROPCASE_MIN_AV                          25
    #define PROPCASE_USER_AV                         26
    « Last Edit: 30 / January / 2011, 10:58:29 by Bernd R »
    Ixus 1000 HS

    *

    Offline whim

    • ******
    • 2013
    • A495/590/620/630 ixus70/115/220/230/300/870 S95
  • Publish
    Re: IXUS 1000 HS Porting Thread
    « Reply #266 on: 30 / January / 2011, 10:15:34 »
    Quote
    Have you a Card more than 4 GB that is partionate that chdk can boot ?
    If so, maybe you can test, if IX1000 Port boot on Cards with more than 4 GB
    Don't forget it is also possible to partition cards of 4 GB or smaller ...
    Useless, but maybe helpful for testing your multi partition code.

    HTH,

    wim

  • Publish
    Re: IXUS 1000 HS Porting Thread
    « Reply #267 on: 22 / February / 2011, 04:52:51 »
    here i have upload the source and binary of Ixus 1000 HS.I change the palette to number 7 (which use SX30 G12).this work good, shooting mode show always transparent menu.

    http://www.zshare.net/download/86928931192d6f57/

    ISO overwrite good work when you set values as
    125
    160  
    200
    320
    400
    640
    800
    1000
    1250
    1600
    2000

    DNG RAW mode work
    script console show output
    random crashes on boot or series shoot never happen with that fixes.
    strrchr work.
    « Last Edit: 22 / February / 2011, 04:58:41 by Bernd R »
    Ixus 1000 HS


  • Publish
    Re: IXUS 1000 HS Porting Thread
    « Reply #268 on: 24 / February / 2011, 16:38:20 »
    is there really no tool or drive handler that can read from windows the data of the second Partition ?

    I test now boot with a small FAT12 partition and a large FAT32 partition.i create the 2 partitions in chdk menu debug.

    It work in Ixus 1000 too.
    I can swap Partitions with sdmins

    But best is when windows can show files
    Ixus 1000 HS

  • Publish
    Re: IXUS 1000 HS Porting Thread
    « Reply #269 on: 07 / March / 2011, 07:25:05 »
    hello,
    thank you for doing such a great job.
    I think of buying a 1000 hs for my first playings with chdk. For me not only the photo capabilities are interesting but also the video ones. I want to have manual exposure control in video mode (not while filming, but setting it before). Is this still possible in chdk or will this be possible at any time? If it isn't possible I have to look for another cam...
    Another feature which would be great is 60fps at a resolution of 720p (maybe without sound). I am not able to program this and I don't want to ask you for doing this, I just wanna know if it is planned to impliment this feature.
    Best
    klangdrang

     

    Related Topics