SD940 (IXUS120) porting thread - page 21 - DryOS Development - CHDK Forum supplierdeeply

SD940 (IXUS120) porting thread

  • 542 Replies
  • 143175 Views
*

Offline waldo

  • ***
  • 238
Re: SD940 (IXUS120) porting thread
« Reply #200 on: 07 / January / 2011, 09:08:18 »
Advertisements
For 102C, the edge overlay and zebra still do not work.  I thought it might be a screen dimension problem in lib.c, but the 102C and 103C code seems to be the same.

Also, the dark frame subtraction does not work.  I spent quite a bit of time on this already but I've got a few more things to try.

Also, the camera usually crashes when I take pictures in raw.

Re: SD940 (IXUS120) porting thread
« Reply #201 on: 07 / January / 2011, 11:44:10 »
For 102C, the edge overlay and zebra still do not work. 
When you sent my your camera.h section for the SD940 the other day,  it did not contain the two additional defines that Bernd  R had give me. 
http://chdk.setepontos.com/index.php?topic=5855.msg58941#msg58941

Are you still using your camera.h or did you switch to the one from the Beta source code release ?
Ported :   A1200    SD940   G10    Powershot N    G16

Re: SD940 (IXUS120) porting thread
« Reply #202 on: 07 / January / 2011, 12:31:53 »
Thanks for the port guys!

Using 103C and it seems to work fine; I get usable dng files, ev bracketing and scripting both work etc.  

Only issues I noticed was that the battery meter is not working (fixed at 0%), and autoISO seemed to use 640 for every shot (might be a user error, haven't used the custom autoISO settings before).
« Last Edit: 07 / January / 2011, 12:34:16 by tidu »

*

Offline waldo

  • ***
  • 238
Re: SD940 (IXUS120) porting thread
« Reply #203 on: 07 / January / 2011, 12:33:06 »

When you sent my your camera.h section for the SD940 the other day,  it did not contain the two additional defines that Bernd  R had give me. 
Are you still using your camera.h or did you switch to the one from the Beta source code release ?

I tested it with your latest build for 102C.  I'll try the changes in camera.h on my build.


Re: SD940 (IXUS120) porting thread
« Reply #204 on: 07 / January / 2011, 14:19:40 »
Only issues I noticed was that the battery meter is not working (fixed at 0%)

Battery meter works properly on my camera if I set the max and min voltage values in the OSD setup menu - try 4.25 and 3.5.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline waldo

  • ***
  • 238
Re: SD940 (IXUS120) porting thread
« Reply #205 on: 07 / January / 2011, 15:11:49 »
Only issues I noticed was that the battery meter is not working (fixed at 0%)

Battery meter works properly on my camera if I set the max and min voltage values in the OSD setup menu - try 4.25 and 3.5.

Yes, that seems to be the problem with the battery display.  For some reason, the values in get_vbatt_min() and get_vbatt_max() are wrong.

*

Offline waldo

  • ***
  • 238
Re: SD940 (IXUS120) porting thread
« Reply #206 on: 07 / January / 2011, 19:23:35 »
I'm running out of ideas for the issue with the dark frame subtract setting not affecting anything.

What I know is that the location of the call to capt_seq_hook_set_nr was wrong.  It was in a location in capt_seq that did not normally get executed.  When I fixed that, the camera would consistently crash when capt_seq_hook_set_nr was called.  I traced this to the call to _time.  The address for this function looks OK.  When I commented that out, it doesn't crash, but changing nrflag has no effect.  I tried a few possible candidates for the nrflag address, one of which seems to be the same variable used in other ports. 

Then again, in a camera with such a small image sensor, most people would probably want the default Canon behavior for lower noise (i.e. the "Auto" setting).

Re: SD940 (IXUS120) porting thread
« Reply #207 on: 07 / January / 2011, 19:59:09 »
Then again, in a camera with such a small image sensor, most people would probably want the default Canon behavior for lower noise (i.e. the "Auto" setting).
I hear you.  Looking at the barrel distortion in my DNG images,  I also wonder why RAW seems attractive on a small camera to people ?  Sure, on a $1500 DSLR with  a good 50mm lens there is something to be said for not having jpeg compression.  But I must be missing something - what does it get me with something like the SD940?
Ported :   A1200    SD940   G10    Powershot N    G16


*

Offline pixeldoc2000

  • ****
  • 356
  • IXUS900Ti 1.00C, IXUS300HS 1.00D
    • pixel::doc homebase
Re: SD940 (IXUS120) porting thread
« Reply #208 on: 07 / January / 2011, 20:01:40 »
Crashing problem in LUA fixed - mykbd_task() was running out of stack space.  Changed 1.03c version to use same startup code as 1.02c as that code created the task with a 4X larger stack.
Thanks for the hint! Had the same problem on SD4000 (hooked mykbd_task() without increased stack size).

Bad idea:
Code: [Select]
void taskHook(context_t **context) {
...
if(!_strcmp(tcb->name, "PhySw"))           tcb->entry = (void*)mykbd_task;    // cause crash with large scripts because we hook task without increased stack size
...
}
« Last Edit: 07 / January / 2011, 20:05:26 by pixeldoc2000 »

Re: SD940 (IXUS120) porting thread
« Reply #209 on: 07 / January / 2011, 20:07:04 »
Thanks for the hint! Had the same problem on SD4000 (hooked mykbd_task() without increased stack size).
This community development thing seems to work.   I know my productivity went way up once I had enough of a port to start this thread and starting getting help from the more senior members of the forum.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics