SD940 (IXUS120) porting thread - page 24 - DryOS Development - CHDK Forum supplierdeeply

SD940 (IXUS120) porting thread

  • 542 Replies
  • 143167 Views
Re: SD940 (IXUS120) porting thread
« Reply #230 on: 11 / January / 2011, 10:37:17 »
Advertisements
Yes, the set_zoom did not work at all and now works as long as you don't go out of range.

Checking stubs_entry_2.S,  there is a routine called SetZoomActuatorSpeedPercent() that right now points to a NULLSUB. Doesn't seems like that should make anything crash but I would understand if the zoom did not move as a result.

Ported :   A1200    SD940   G10    Powershot N    G16

Re: SD940 (IXUS120) porting thread
« Reply #231 on: 12 / January / 2011, 11:38:19 »
Anything new about 103b? =)

Re: SD940 (IXUS120) porting thread
« Reply #232 on: 13 / January / 2011, 00:04:02 »
Posted Beta 5 - primarily a correction to the NHSUB for set_control_event() - change enables zoom control to work and possibly other features.

source ->  http://www.zshare.net/download/85149111cd3e1d48/
1.02c -> http://www.zshare.net/download/851492023e5a84e1/
1.03c -> http://www.zshare.net/download/8514924750cee9eb/
Ported :   A1200    SD940   G10    Powershot N    G16

Re: SD940 (IXUS120) porting thread
« Reply #233 on: 13 / January / 2011, 00:07:07 »
Anything new about 103b? =)
RoninTech was working on the 1.03B version but we have not heard anything in weeks here. 

Ported :   A1200    SD940   G10    Powershot N    G16


Re: SD940 (IXUS120) porting thread
« Reply #234 on: 13 / January / 2011, 09:43:12 »
Weeks?  Wow, time flies...  :D  Yeah, here's my last post.  From the reply I got the impression I was on the wrong track.  Unfortunately my window of lots of free time has closed now that the holidays are over and it's back to the grind.

Great progress on the other versions by the way!  Hopefully someone that knows how this should be done can get 103B taken care of.

Re: SD940 (IXUS120) porting thread
« Reply #235 on: 13 / January / 2011, 19:21:13 »
From the reply I got the impression I was on the wrong track.

Sorry - didn't mean to leave you with the impression you were on the wrong track.  I was trying to point out that perhaps the easiest way to port is to have the disassembly of your new camera open beside the disassembly of a "reference" camera port and use the reference port to figure out what code you are looking for in the new camera.

In your case,  using the 103c would be really close and relatively fast.  I could probably do it in a day - although it might be a long day.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline zebra

  • *
  • 24
Re: SD940 (IXUS120) porting thread
« Reply #236 on: 14 / January / 2011, 23:23:39 »
Hi.

OK. It's been a long time. I created a dump of 1.02c long, long ago for CHDK, with the intention to port - and fell off the face of the planet after that. Back now.

Had a play with the current (beta 5) port a few mins ago - and have found hang on load scenario under the 1.02c version. Had a good look to see if they were resource fork related issues on the SD card (from a Mac OS X host), but it wasn't the case. Tried applying with card-tricks, and same scenario. Crashes shortly after CHDK loading screen.

Do you have any debug flags or "got this far then core dumped" style utilities I could run, then send you outputs of?

Cheers.

z

*

Offline waldo

  • ***
  • 238
Re: SD940 (IXUS120) porting thread
« Reply #237 on: 14 / January / 2011, 23:35:13 »
Hi.

OK. It's been a long time. I created a dump of 1.02c long, long ago for CHDK, with the intention to port - and fell off the face of the planet after that. Back now.

Had a play with the current (beta 5) port a few mins ago - and have found hang on load scenario under the 1.02c version. Had a good look to see if they were resource fork related issues on the SD card (from a Mac OS X host), but it wasn't the case. Tried applying with card-tricks, and same scenario. Crashes shortly after CHDK loading screen.

Do you have any debug flags or "got this far then core dumped" style utilities I could run, then send you outputs of?

Cheers.

z

I just tried the latest 102c version and it seems to boot fine for me.


*

Offline zebra

  • *
  • 24
Re: SD940 (IXUS120) porting thread
« Reply #238 on: 14 / January / 2011, 23:38:05 »
Wonder what I am doing wrong. There is no region dependency or model type dependency, is there?

I.e - I'm running PAL-E region GM1.02C fw, with an IXUS 120IS branded variant - not the _940.

?


z

*

Offline reyalp

  • ******
  • 13290
Re: SD940 (IXUS120) porting thread
« Reply #239 on: 15 / January / 2011, 00:30:40 »
Wonder what I am doing wrong. There is no region dependency or model type dependency, is there?

I.e - I'm running PAL-E region GM1.02C fw, with an IXUS 120IS branded variant - not the _940.
This has not been observed in any of the other models CHDK has supported. I would say it is extremely unlikely.
Don't forget what the H stands for.

 

Related Topics