supplierdeeply

SD940 (IXUS120) porting thread

  • 542 Replies
  • 59821 Views
  • Publish
    Re: SD940 (IXUS120) porting thread
    « Reply #370 on: 27 / March / 2011, 20:19:26 »
    Advertisements
    anything else i could check? trying to make myself as useful as possible...
    From a previous post :
    Quote
    Is the built-in bracketing supposed to work yet? How about zooming during video capture?  They both don't work.

    It would be interesting to know if the manual overrides work - shutter, ISO, aperature (ND filter) etc....

    But what would be really helpful is to work your way throught the online manual and make notes about what works and what doesn't :
    http://chdk.wikia.com/wiki/CHDK_User_Manual

    That has not really been done well for any version of the SD940 so you would be doing our small group a big favor.

    « Last Edit: 27 / March / 2011, 20:33:52 by waterwingz »

  • Publish
    Re: SD940 (IXUS120) porting thread
    « Reply #371 on: 28 / March / 2011, 05:03:33 »
    Waterwings, thanks for your enormous effort on this port !

    I downloaded the latest version for the 1.02 yesterday and gave it a brief try. Most of the functions I have tested so far worked, amongst others;
    - ISO and shutterspeed override,
    - RAW format, both CRW and DNG worked perfect.
     
    The options for turning off the autofocus (setting to fixed infinate) I could however not get to work. It might be related to the camera itself, -or to my competence-level, I don't know. Besides, I have not found any functions for turning off the lcd screen, (might not be in there).

    I did also test the majority of the scripts in the script-folder. The Scriptingmenu appears to be fully operational, but I could not get any of the scripts to run properly. The scripts started ok, then some of them crashed the camera (black screen), and some of them gave no or little response after they were started.

    « Last Edit: 29 / March / 2011, 03:11:02 by brakar »

  • Publish
    Re: SD940 (IXUS120) porting thread
    « Reply #372 on: 29 / March / 2011, 05:58:24 »
    as much as i can see, all photographic extra functions are not working, in 1.03b firm...

    zebra is ok, but NDfilter,flash,ev,overrides are not changing camera's behavior..

    anything I could do to troubleshoot?

    Tommaso

  • Publish
    Re: SD940 (IXUS120) porting thread
    « Reply #373 on: 29 / March / 2011, 07:27:41 »
    I downloaded the latest version for the 1.02 yesterday and gave it a brief try.
    @brakar : do you mean 1.02C ?  Waldo had reported scripting working with that version.  Did you try both LUA and BASIC scripts ?  Some of the default ones actually don't do much - a simple script that take pictures in a loop with a time delay might be an interesting test - I'll post something like that if you can't find / write it yourself.

    zebra is ok, but NDfilter,flash,ev,overrides are not changing camera's behavior..
    I've been comparing the stubs_entry_2.S files between the three firmware versions using a dissassembly utility that I've been working on.  I have found some differences that need to be fixed but need a little more time to understand them.  Should have another release ready later this week / weekend depending on what else I need to get done.



  • Publish
    Re: SD940 (IXUS120) porting thread
    « Reply #374 on: 29 / March / 2011, 08:22:11 »
    @waterwings,
    Yes, the firmware version was 1.02C
    I just tried an time-interval script (BASIC) as you suggested - and had it working nicely.
    The other BASIC-scrips I have bin testing for remote control of the camera (input 5V into the cameras usb), are however still not working. The simplest one looks like this:

    @title Remote button
    :loop
    wait_click 1
    is_key k "remote"
    if k=1 then shoot
    goto "loop"
    end

    The script was working nicely on my SD980.

  • Publish
    Re: SD940 (IXUS120) porting thread
    « Reply #375 on: 29 / March / 2011, 09:49:58 »
    The other BASIC-scrips I have bin testing for remote control of the camera (input 5V into the cameras usb), are however still not working.

    Thanks brakar - always nice to have a clear problem description!  I can look into it - its not something I have tested because I have not taken the time to build a remote switch.  However, its something I have wanted to try out so I'll move it to the top of the priority list - right behind getting the 1.03b firmware working,.


    *

    Offline reyalp

    • ******
    • 9865
  • Publish
    Re: SD940 (IXUS120) porting thread
    « Reply #376 on: 29 / March / 2011, 13:08:28 »
    The other BASIC-scrips I have bin testing for remote control of the camera (input 5V into the cameras usb), are however still not working.

    Thanks brakar - always nice to have a clear problem description!  I can look into it - its not something I have tested because I have not taken the time to build a remote switch.  However, its something I have wanted to try out so I'll move it to the top of the priority list - right behind getting the 1.03b firmware working,.
    I think I've mentioned this before, but you can use your PC usb cable to test the remote code, just plug and unplug it... as long as remote is enabled, the camera won't got into ptp mode.
    Don't forget what the H stands for.

  • Publish
    Re: SD940 (IXUS120) porting thread
    « Reply #377 on: 29 / March / 2011, 16:46:42 »
    I discovered the problem with running my remote.bas script was due to a faulty connection in the remote switch. Now that I have fixed it, the script is running as it's supposed to.
    ----
    PS: I have still not managed to override the cameras autofous by setting focus to "infinate", either directly in chdk - or by the use of scripts. Anyone who knows if this should be possible? (I am a rookie on chdk, so I don't know if I have tried the right things).
    « Last Edit: 30 / March / 2011, 20:38:38 by brakar »


  • Publish
    Re: SD940 (IXUS120) porting thread
    « Reply #378 on: 29 / March / 2011, 21:10:46 »
    Changed a couple of addresses in stub_entry_2.S to match what's in the other two firmware versions. Maybe somebody can try this version and see if we are closer now ?

    http://www.box.net/shared/7sjz17u57p

    My apologies to the 1.03B firmware owners.  This is not a great way to debug software but its all I can do for you as I don't have a camera with that firmware.  

    Update :  rulem reports no improvement with his problems - other things might work better.  These corrections are definitely needed in any case.  Feedback from others would be good.


    « Last Edit: 30 / March / 2011, 07:38:16 by waterwingz »

  • Publish
    Re: SD940 (IXUS120) porting thread
    « Reply #379 on: 31 / March / 2011, 04:43:05 »
    My apologies to the 1.03B firmware owners.  This is not a great way to debug software but its all I can do for you as I don't have a camera with that firmware.
    No problem, I'm thankful for your work.

    Yesterday I used ixus120_sd940-103b-0.9.9-1114-full.zip and it worked quite good for an alpha version. Hardware zoom while taking a video didn't work and battery voltage level for the battery symbol was not predefined.
    Canon Digital IXUS 120 (SD940)
    P-ID:31E6 PAL D
    Firmware Version GM 1.03B

     

    Related Topics