SD940 (IXUS120) porting thread

  • 542 Replies
  • 60487 Views
  • Publish
    Re: SD940 rev 103c porting thread (IXUS120)
    « Reply #70 on: 17 / December / 2010, 22:02:22 »
    Advertisements
    FWIW, I'm working on a fairly complex time lapse script involving exposure overrides, math, timers, and shooting and it all works perfectly on the SD940.

    waldo :  Great news!  Now that I have a spare moment this week,  I'm folding my code into yours so the 1.02c and 1.03c versions work the same.  Do you think we can be brave enough to claim we have reached Beta status ?

    Merge version of the trunk makefile and makefile.inc attached ....
    « Last Edit: 17 / December / 2010, 22:07:15 by waterwingz »

    *

    Offline waldo

    • ***
    • 238
  • Publish
    Re: SD940 rev 103c porting thread (IXUS120)
    « Reply #71 on: 17 / December / 2010, 22:11:32 »
    Now that I have a spare moment this week,  I'm folding my code into yours so the 1.02c and 1.03c versions work the same.  Do you think we can be brave enough to claim we have reached Beta status ?

    I've never really understood the alpha/beta thing with regard to CHDK.  Compared to any commercial software, I would say that the most well-refined version of CHDK is still "alpha".  I would say that 1 week after the last unresolved bug report, you should release it to the trunk for auto-builds.

  • Publish
    Re: SD940 rev 103c porting thread (IXUS120)
    « Reply #72 on: 17 / December / 2010, 22:23:51 »
    I've never really understood the alpha/beta thing with regard to CHDK.  Compared to any commercial software, I would say that the most well-refined version of CHDK is still "alpha".  I would say that 1 week after the last unresolved bug report, you should release it to the trunk for auto-builds.

    From the wiki page called "For Developers",  I kind of assumed that anything that would boot and show the CHDK logo could be considered Alpha.  Getting that far is an accomplishment when you start from scratch and it shows that at least you have some grasp on what to do?  Not much actually works but for owners of your camera model - its a ray of hope that somebody is actually working on the project for their camera.

    Just my opinion,  but being in Beta means you have completed all the porting steps,coded all the required functions, found all the stub addresses and have a release that boots and runs as far as you know.  At that point,  it all becomes testing and understanding why, despite all your brilliance, some things still don't work.

    I hear you about CHDK versus commercial software though.  But I would counter that for what people pay to get CHDK,  they get way more than the pay for.

    *

    Offline waldo

    • ***
    • 238
  • Publish
    Re: SD940 rev 103c porting thread (IXUS120)
    « Reply #73 on: 18 / December / 2010, 10:38:27 »
    I noticed that the edge overlay does not draw properly on 102C.  Possibly a problem with the viewport size functions.


  • Publish
    Re: SD940 (IXUS120) porting thread
    « Reply #74 on: 18 / December / 2010, 18:36:35 »
    Having a problem with capt_set.c.   At first I thought it was not saving images to the SD card.  But when I look at the SD card, images are being stored in the right subdirectories under DCIM.  However, the file names are not prefixed by "IMG_" - they are just stored as (for example)  1234.jpg rather than IMG_1234.jpg .   This means the camera does not see them in playback mode.

    Right now,  I think I have the code stripped so that its an exact copy of the ROM code - no links to CHDK functionality - and I'm still not getting the right file names.  Any ideas ?

    *

    Offline waldo

    • ***
    • 238
  • Publish
    Re: SD940 (IXUS120) porting thread
    « Reply #75 on: 18 / December / 2010, 18:56:24 »
    Having a problem with capt_set.c.   At first I thought it was not saving images to the SD card.  But when I look at the SD card, images are being stored in the right subdirectories under DCIM.  However, the file names are not prefixed by "IMG_" - they are just stored as (for example)  1234.jpg rather than IMG_1234.jpg .   This means the camera does not see them in playback mode.

    Right now,  I think I have the code stripped so that its an exact copy of the ROM code - no links to CHDK functionality - and I'm still not getting the right file names.  Any ideas ?

    I'm not seeing that on my camera.  I have started noticing random hang-ups after taking a picture, tho.

  • Publish
    Re: SD940 (IXUS120) porting thread
    « Reply #76 on: 18 / December / 2010, 20:50:23 »
    Did a line by line comparison between yours & mine - looks identical except for address offsets. Sigh.
    Making a new dissassembly source in case I introduced a subtle typo somewhere.

    Update :  If I start the camera with the play button and then go into shooting mode using a 1/2 push on the shutter button, the camera saves pictures using IMG_nnnn.jpg filenames.   If I start the camera in picture taking mode by holding down the "shoot" button for 2 seconds, the camera saves pictures using nnnn.jpg file names.  This is like chasing ghosts - sometimes the pictures have IMG_ at the start of the filename and some times they don't.  I'm going to put this away for a while now - clearly not thinking straight.
    « Last Edit: 18 / December / 2010, 23:30:31 by waterwingz »

    *

    Offline waldo

    • ***
    • 238
  • Publish
    Re: SD940 (IXUS120) porting thread
    « Reply #77 on: 19 / December / 2010, 11:17:36 »
    I found that my problem related to sometimes hanging up when shooting were related to how fast I pressed the shutter button.  It would hang if I pressed the shutter button too fast.

    If you look at my source for capt_seq.c, there are two lines commented out with the comment: "fixes overrides behavior at short shutter press".  If you put these two lines back in, the hang-up problem goes away.


  • Publish
    Re: SD940 (IXUS120) porting thread
    « Reply #78 on: 19 / December / 2010, 11:57:12 »
    Thanks a lot to you guys for working on this port!

    I will run to the shop and buy a camera. Is it firmversion 1.02c and 1.03c I should be looking for?


    *

    Offline waldo

    • ***
    • 238
  • Publish
    Re: SD940 (IXUS120) porting thread
    « Reply #79 on: 19 / December / 2010, 12:08:34 »
    I will run to the shop and buy a camera. Is it firmversion 1.02c and 1.03c I should be looking for?

    Yes, those are the two versions that have a more-or-less working CHDK port.  There is also apparently a 1.03B firmware but I'm not sure if that has even been dumped so it may be a while before that is supported.

    I don't think they are being made anymore, but you might still find a new one in a shop.
    « Last Edit: 19 / December / 2010, 12:16:22 by waldo »

     

    Related Topics