A530 Chdk port - 0.5 beta

  • 113 Replies
  • 23166 Views
*

Offline bondo

  • *
  • 42
  • Saluti from Italy!
Re: A530 Chdk port - 0.4.1 beta
« Reply #80 on: 13 / March / 2008, 13:08:10 »
Advertisements
hi bondo,

what is the problem with the function you mentioned?

best wishes - image13

the code needs just an adjustment (see the commented part in the code...)
let me know if the values are right  ;)
bye

Re: A530 Chdk port - 0.4.1 beta
« Reply #81 on: 13 / March / 2008, 16:06:10 »
looks like your values are correct: the space left, and
remaining raw images etc. shown looks good (in osd
layout editor)

but it looks like some other things are not correct yet
* if i go to "show parameter data" in the debug options
   the camera shuts down
* if i try to do focus bracketing the camera hangs as
   well (does not shut down, but does not respond any
   more and shows a blank screen) - same applies to
   iso bracketing ... tv bracketing works fine
* the osd behaves a bit strange - in the osd layout
   editor everything is shown properly and the values
   seem to be ok (the misc values look eventually a
   bit strange), but most things do not show up in
   normal mode - i had the raw files reminaing been
   shown, but now it is gone and i have no real idea
   what i did

anyone - maybe from the chdk gurus - have any idea
what exactly is wrong here and how to fix/debug it?

best wishes - image13

Re: A530 Chdk port - 0.4.1 beta
« Reply #82 on: 19 / March / 2008, 14:18:05 »
hi bondo,

are you still working on the a530 port? if yes, could you
please have a look at my other postings named "mode_get"
and "iso and focus bracketing"?

a lot of thanks in advance and best wishes - image13

*

Offline bondo

  • *
  • 42
  • Saluti from Italy!
Re: A530 Chdk port - 0.4.1 beta
« Reply #83 on: 19 / March / 2008, 14:47:10 »
hi image!
I replied to you into the other post - anyways, currently I can't continue developing because my camera is in warranty service

be patience!


Re: A530 Chdk port - 0.4.1 beta
« Reply #84 on: 19 / March / 2008, 15:49:55 »
thanks a lot to ewavr and bondo some more
bugs are fixed now - so what has changed
since the last "official" beta (0.4.1b)?

* file numbering bug fixed
* osd seems to work fine now
* iso and focus overwrite works now
   (exposure bracketing + nd filter on/off
    already worked before)
* file size changed to the usual 2672x1968
   for 5m chips - so the resulting raw files
   should work well with dng4ps2 and dcraw
* sent sample filesfor color calibration to the
   author of dng4ps2 for correct color
   balancing of the resulting dng's

not working yet:

* usb remote - anyone able to help here?
   it is recognized (3: 3fff -> 7fff) but does
   not seem to really work

here is the source code against trunk 334
and a set of compiled binaries

  a530-trunk-334.zip - 0.23MB

most credits go to bondo, ewavr, whoever

best wishes - image13

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: A530 Chdk port - 0.4.1 beta
« Reply #85 on: 19 / March / 2008, 16:09:29 »
But why you undefine in camera.h:

#undef  CAM_HAS_ZOOM_LEVER

All cams, except A460, have it (A530 too).

Re: A530 Chdk port - 0.4.1 beta
« Reply #86 on: 19 / March / 2008, 16:10:50 »
ooops - you are right - thanks for that info!

fixed in my local sources - next version will include
this fix

best wishes - image13

*

Offline bondo

  • *
  • 42
  • Saluti from Italy!
Re: A530 Chdk port - 0.4.1 beta
« Reply #87 on: 20 / March / 2008, 10:07:20 »
okay, I've updated the first post adding download link to image13's version (that can definitly be 0.5b)


*

Offline whoever

  • ****
  • 280
  • IXUS950
Re: A530 Chdk port - 0.5 beta
« Reply #88 on: 20 / March / 2008, 11:53:28 »
not working yet:
* usb remote - anyone able to help here?
   it is recognized (3: 3fff -> 7fff) but does
   not seem to really work
That must be because in your kbd.c you import ../generic/kbd.c, and the latter, let's put it this way, does not do the job exactly right. Do all the necessary processing in platform/<your cam>/kbd.c

Re: A530 Chdk port - 0.5 beta
« Reply #89 on: 20 / March / 2008, 14:25:41 »
hi,

i found the fix for the non working usb-remote in the
a540 0.5b code from niederhammer - now usb-remote
also works on the a530 - you may find a diff against
trunk 336 as well as compile binaries at

  a530-336-usbremote.zip - 0.21MB

best wishes - image13

p.s.: thanks to bondo for the update of the first page btw.

 

Related Topics