supplierdeeply

SX30 IS Release - available on the autobuild server

  • 282 Replies
  • 53132 Views
*

Offline philmoz

  • *****
  • 2936
    • Photos
  • Publish
    Re: SX30 IS Release - available on the autobuild server
    « Reply #240 on: 17 / August / 2011, 19:02:19 »
    Advertisements
    Alright.  So I can't format using windows format (says volume is too big for FAT32).  I'm pretty sure the camera does support exFat because when the camera formats the card itself, that is the format it writes. 

    I just verified I am definitely using exFat, and I definitely applied the scripts right. 

    I think there may be a way to force FAT32 on this card.  There are some utilities, but they didn't work for me (could not recognize my device).  I'll search for other ways of formatting it FAT32. 


    This version removes the LED blink and goes back to the original partition management code; it also enables exFat as the 2nd partition type.
    It works on mine with a 16GB card where the large partition is formatted as exFat.

    Phil.
    CHDK ports:
      sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
      g12 (1.00c, 1.00e, 1.00f & 1.00g)
      sx130is (1.01d & 1.01f)
      ixus310hs (1.00a & 1.01a)
      sx40hs (1.00d, 1.00g & 1.00i)
      g1x (1.00e, 1.00f & 1.00g)

    *

    Offline woot

    • *
    • 12
  • Publish
    Re: SX30 IS Release - available on the autobuild server
    « Reply #241 on: 17 / August / 2011, 21:00:22 »
    This version removes the LED blink and goes back to the original partition management code; it also enables exFat as the 2nd partition type.
    It works on mine with a 16GB card where the large partition is formatted as exFat.

    This seems to work!  I'll test it out some more tonight... I have a slight dilemma.  My work laptop (which I am bringing with me) encrypts any media put into the laptop.  So I am hoping I can plug it in via usb (I assume it has this ability) and the laptop won't try to encrypt.

    Thanks!

    *

    Offline woot

    • *
    • 12
  • Publish
    Re: SX30 IS Release - available on the autobuild server
    « Reply #242 on: 17 / August / 2011, 21:30:13 »
    Just tested it on my work laptop, and it works perfectly (and the encryption is smart enough to know not to do it to the camera).  The picture partition shows up when I plug in the usb... I was worried that the CHDK partition would instead. Awesome!  I'll never need to swap partitions really unless I don't want to run CHDK. 

  • Publish
    Re: SX30 IS Release - available on the autobuild server
    « Reply #243 on: 08 / September / 2011, 18:30:41 »
    Hi,

    I tried CHDK for SX30 firmware 1.00p but it seems very unstable, please see this video I recorded with live histogram and motion detection script running, sorry it's blurry.

    CHDK for SX30 firmware 1.00p

    Can this be fixed?

    Thanks


    *

    Offline philmoz

    • *****
    • 2936
      • Photos
  • Publish
    Re: SX30 IS Release - available on the autobuild server
    « Reply #244 on: 08 / September / 2011, 18:51:39 »
    Hi,

    I tried CHDK for SX30 firmware 1.00p but it seems very unstable, please see this video I recorded with live histogram and motion detection script running, sorry it's blurry.

    CHDK for SX30 firmware 1.00p

    Can this be fixed?

    Thanks

    Please post details of which MD script you are using, and the settings used for the script so I can test it.

    Phil.
    CHDK ports:
      sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
      g12 (1.00c, 1.00e, 1.00f & 1.00g)
      sx130is (1.01d & 1.01f)
      ixus310hs (1.00a & 1.01a)
      sx40hs (1.00d, 1.00g & 1.00i)
      g1x (1.00e, 1.00f & 1.00g)

  • Publish
    Re: SX30 IS Release - available on the autobuild server
    « Reply #245 on: 09 / September / 2011, 04:31:33 »
    Hi Phil,

    I tried both the latest Fast Motion Detection Script MDFB-080914.zip http://chdk.wikia.com/wiki/UBASIC/Scripts and also the Multipurpose Motion Detection http://chdk.wikia.com/wiki/UBASIC/Scripts:_Multipurpose_Motion_Detection
    I used the default settings. When I increase the threshold value, it would stop any shutter trigger at some point rather than become less sensitive.

    Also is it possible to fix the live histogram from showing intermittent peaks at the dark left scale? This could be why all motion detection scripts gives false positives and sets off the trigger when nothing is moving.

    I discussed with another SX30 user with a different firmware and his motion detection scripts works fine, seems like my problem is to do with my firmware version 1.00P

    *

    Offline philmoz

    • *****
    • 2936
      • Photos
  • Publish
    Re: SX30 IS Release - available on the autobuild server
    « Reply #246 on: 09 / September / 2011, 04:50:42 »
    Hi Phil,

    I tried both the latest Fast Motion Detection Script MDFB-080914.zip http://chdk.wikia.com/wiki/UBASIC/Scripts and also the Multipurpose Motion Detection http://chdk.wikia.com/wiki/UBASIC/Scripts:_Multipurpose_Motion_Detection
    I used the default settings. When I increase the threshold value, it would stop any shutter trigger at some point rather than become less sensitive.

    Also is it possible to fix the live histogram from showing intermittent peaks at the dark left scale? This could be why all motion detection scripts gives false positives and sets off the trigger when nothing is moving.

    I discussed with another SX30 user with a different firmware and his motion detection scripts works fine, seems like my problem is to do with my firmware version 1.00P

    Are you using a recent version from the autobuild server?
    It looks like this might have been something I fixed in a recent update.

    Phil.
    CHDK ports:
      sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
      g12 (1.00c, 1.00e, 1.00f & 1.00g)
      sx130is (1.01d & 1.01f)
      ixus310hs (1.00a & 1.01a)
      sx40hs (1.00d, 1.00g & 1.00i)
      g1x (1.00e, 1.00f & 1.00g)

  • Publish
    Re: SX30 IS Release - available on the autobuild server
    « Reply #247 on: 09 / September / 2011, 08:30:40 »

    Are you using a recent version from the autobuild server?
    It looks like this might have been something I fixed in a recent update.

    Phil.

    Great work Phil! I just tried CHDK latest build sx30-100p-0.9.9-1323-full.zip and the live histogram is now stable and motion detection works! Previously I was using the CHDK build from 1 week ago (1311) Thanks for your help and the great work on CHDK!

    Video showing latest CHDK working on my SX30 firmware 1.00p
    CHDK for SX30 firmware 1.00p using latest build sx30-100p-0.9.9-1323-full.zip


  • Publish
    Re: SX30 IS Release - available on the autobuild server
    « Reply #248 on: 17 / September / 2011, 06:21:08 »
     Hi I am New Here Please a version compatible for canon sx 30 is seen. 1.00 J, Thanks

    *

    Offline philmoz

    • *****
    • 2936
      • Photos
  • Publish
    Re: SX30 IS Release - available on the autobuild server
    « Reply #249 on: 17 / September / 2011, 06:54:21 »
    Hi I am New Here Please a version compatible for canon sx 30 is seen. 1.00 J, Thanks

    If you have an SX30IS camera with 1.00j firmware you can use the universal dumper to get the firmware from the camera (http://chdk.wikia.com/wiki/Canon_Basic/Scripts/Dumper).

    Then upload the PRIMARY.BIN file to a file share and post the link here.

    I can then take a look at making a new version.

    Phil.
    CHDK ports:
      sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
      g12 (1.00c, 1.00e, 1.00f & 1.00g)
      sx130is (1.01d & 1.01f)
      ixus310hs (1.00a & 1.01a)
      sx40hs (1.00d, 1.00g & 1.00i)
      g1x (1.00e, 1.00f & 1.00g)

     

    Related Topics