G12 Release - available from the autobuild server - page 11 - CHDK Releases - CHDK Forum supplierdeeply

G12 Release - available from the autobuild server

  • 136 Replies
  • 64966 Views
Re: G12 beta release (now also available from the autobuild server)
« Reply #100 on: 22 / April / 2011, 13:45:29 »
Advertisements
Phil, is it possible to switch to manual focus mode on the G12 from script?

There is no script function to set manual focus; but you can use the 'click' function to simulate pressing the buttons on the camera.

If you are in auto focus mode then:
  click "up"
  click "set"
should set manual focus.

Regards,
Phil.


I must leave ALT mode to change the MF mode (by pressing up), and the click actions failed as well. Is the user (me) broken? Did I miss a menu item, or command. Or is this expected behavior?

Thank you again.

Re: G12 beta release (now also available from the autobuild server)
« Reply #101 on: 28 / May / 2011, 02:44:15 »

*

Offline philmoz

  • *****
  • 3332
    • Photos
Re: G12 beta release (now also available from the autobuild server)
« Reply #102 on: 28 / May / 2011, 02:49:14 »
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

*

Offline adid1

  • *
  • 10
Re: G12 beta release (now also available from the autobuild server)
« Reply #103 on: 29 / May / 2011, 15:44:53 »
Hi Phil, can you spot what R the differences in 1.00F from E or C ?
just my G12


*

Offline philmoz

  • *****
  • 3332
    • Photos
Re: G12 beta release (now also available from the autobuild server)
« Reply #104 on: 29 / May / 2011, 15:56:45 »
Hi Phil, can you spot what R the differences in 1.00F from E or C ?

Only minor differences between 1.00e and 1.00f. 1.00f patch has been submitted, should be on the autobuild server soon. Or you can use CHDK Shell to build it manually.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

*

Offline adid1

  • *
  • 10
Re: G12 beta release (now also available from the autobuild server)
« Reply #105 on: 30 / May / 2011, 06:36:47 »
Tnx, No I have G12 1.0e so I was wondering what Canon twiked for the 1.0f.

As it is very debatable why the do not issue firmware upgrades anymore.

just my G12

*

Offline philmoz

  • *****
  • 3332
    • Photos
Re: G12 beta release (now also available from the autobuild server)
« Reply #106 on: 30 / May / 2011, 07:00:42 »
Tnx, No I have G12 1.0e so I was wondering what Canon twiked for the 1.0f.

As it is very debatable why the do not issue firmware upgrades anymore.



Pretty much impossible to say what was changed. The code changes are buried deep in the firmware and not easily understood.

Canon rarely release firmware updates unless critical problems are found.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

Re: G12 beta release (now also available from the autobuild server)
« Reply #107 on: 14 / July / 2011, 08:13:54 »
Using a G12 with firmware F downloaded from here http://mighty-hoernsche.de/.  I set the custom auto iso on, and max 20 but the camera still uses mainly iso 500 for flash shots on auto iso. Using auto mode or P mode doesn't make any difference. Am I missing another setting somewhere? Any thoughts? Thanks in advance!

Scott


*

Offline philmoz

  • *****
  • 3332
    • Photos
Re: G12 beta release (now also available from the autobuild server)
« Reply #108 on: 14 / July / 2011, 08:42:14 »
Using a G12 with firmware F downloaded from here http://mighty-hoernsche.de/.  I set the custom auto iso on, and max 20 but the camera still uses mainly iso 500 for flash shots on auto iso. Using auto mode or P mode doesn't make any difference. Am I missing another setting somewhere? Any thoughts? Thanks in advance!

Scott

It does work; but...

The ISO values in the Custom Auto ISO overrides aren't equal to the Canon ISO values you see on screen (it's this whole complicated thing about market versus real ISO which I won't go into - partly because I don't understand it all).

A value of 10 in 'Max ISO Auto (x10)' will lock the Canon max ISO to 160, 20 = 320, etc.
Experiment with the values to find what you need.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

Re: G12 beta release (now also available from the autobuild server)
« Reply #109 on: 14 / July / 2011, 16:43:03 »


It does work; but...

The ISO values in the Custom Auto ISO overrides aren't equal to the Canon ISO values you see on screen (it's this whole complicated thing about market versus real ISO which I won't go into - partly because I don't understand it all).

A value of 10 in 'Max ISO Auto (x10)' will lock the Canon max ISO to 160, 20 = 320, etc.
Experiment with the values to find what you need.

Phil.

[/quote]


If max 20=320, then why does it use 500 when I set it to 20?
« Last Edit: 14 / July / 2011, 16:45:10 by Scottydont »

 

Related Topics