500d development - page 171 - DSLR Hack development - CHDK Forum

500d development

  • 2487 Replies
  • 808483 Views
Re: 500d development
« Reply #1700 on: 05 / November / 2011, 08:02:01 »
Advertisements
Hi all.

Long time lurker, first time poster. I finally decided to give ML a try tonight and must say it's quite great even in its alpha stage. Congrats to all involved.

However, I do have a question. Can we change the aperture while shooting video? The ML unified comparison chart says the 500D version can, but when I try to do it, it brings up the interface but doesn't change the value and after a second it goes back to the menu, now with the aperture setting having a red dot next to it.

Would love to have this as I don't like to shoot my 50 wide open and would rather be able to shoot at f2 or other apertures as needed.

Thanks for your work.
No, you can't, yet.
500D is similar to 50D, both can do videos but it's fully automatic.
There should be a way to have manual control over the exposure, we have to wait a bit.
Meanwhile you can lock the exposure for iso and shutter, aperture will remain fully open.
If you want to set it you have to press the dof button and twist the lens a bit just to interrupt the electrical contacts.

Re: 500d development
« Reply #1701 on: 06 / November / 2011, 16:29:05 »
Hi all.

Long time lurker, first time poster. I finally decided to give ML a try tonight and must say it's quite great even in its alpha stage. Congrats to all involved.

However, I do have a question. Can we change the aperture while shooting video? The ML unified comparison chart says the 500D version can, but when I try to do it, it brings up the interface but doesn't change the value and after a second it goes back to the menu, now with the aperture setting having a red dot next to it.

Would love to have this as I don't like to shoot my 50 wide open and would rather be able to shoot at f2 or other apertures as needed.

Thanks for your work.
No, you can't, yet.
500D is similar to 50D, both can do videos but it's fully automatic.
There should be a way to have manual control over the exposure, we have to wait a bit.
Meanwhile you can lock the exposure for iso and shutter, aperture will remain fully open.
If you want to set it you have to press the dof button and twist the lens a bit just to interrupt the electrical contacts.

ah ok. thanks.

Re: 500d development
« Reply #1702 on: 07 / November / 2011, 09:43:01 »
Hi :-)

I've just read an article about the new Canon digital camcorders and I saw an interesting idea in it.

Wouldn't it be great to have a "Pre-record" feature available in EOS DSLRs?

(see http://dancarrphotography.com/blog/2011/11/06/10-things-you-may-not-know-about-the-canon-eos-c300-future-of-cinema-eos/ , paragraph 8 – 3 Second Pre-Record)
Canon EOS 500D, EF-S 17-85mm f/4-5.6 IS USM

Re: 500d development
« Reply #1703 on: 07 / November / 2011, 13:37:40 »
wonder how large the buffer is if you can record 3 seconds of HD video to the internal buffer


*

Offline Coutts

  • *****
  • 538
  • www.flickr.com/couttsphotog
    • Flickr
Re: 500d development
« Reply #1704 on: 07 / November / 2011, 19:34:57 »
wonder how large the buffer is if you can record 3 seconds of HD video to the internal buffer

it's just an area in RAM allocated for the buffer, I'm sure it probably has more free memory than the 500d to accommodate this feature.

Im not going to have much time to work on ML until december. anybody else want to take over in the mean time??
Canon 5d
Canon 50mm f/1.8
Sigma 24mm f/1.8

Flickr

Re: 500d development
« Reply #1705 on: 07 / November / 2011, 22:00:55 »
Im not going to have much time to work on ML until december. anybody else want to take over in the mean time??

Maybe you can share your ML to-do list so anyone with free time or resource can contribute...

Re: 500d development
« Reply #1706 on: 08 / November / 2011, 04:47:11 »
@ Coutts

I am not sure if anyone else has it but video mode is giving me err70 isue and stops recording. I haven't changed any settings of video mode since I installed ML so not sure what could be causing it.
Does anyone else have issues with video mode?

*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1707 on: 08 / November / 2011, 05:23:53 »
Troubleshooting:
- try with globaldraw off
- turn off any features you don't use
- try more versions (including the latest experimental versions from the wiki)

If you can compile the code:
- find a way to reproduce the problem quickly (i.e. start camera in video mode, press REC => err70)
- disable tasks (in boot-hack.c, comment the line with task_create("ml_init"...)
- disable property handlers (property.c, last line)
- disable modules (include "disable-this-module.h") - try disabling audio, zebra, shoot, tweaks, movtweaks, debug, focus...
- do binary search through the code until you can isolate the problem
« Last Edit: 08 / November / 2011, 05:25:28 by a1ex »


*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1708 on: 08 / November / 2011, 09:34:32 »
Question: is focus peaking aligned with this autoexec?
http://dl.dropbox.com/u/4124919/bleeding-edge/autoexec.bin

Can you post a few screenshots?

*

Offline PHrag

  • *
  • 33
    • Flickr
Re: 500d development
« Reply #1709 on: 08 / November / 2011, 10:50:51 »
Can you post a few screenshots?
I'd like to, but as soon as I switch to live view the screenshot countdown just stops. Also can't activate ML menu in LV in any unified build (must help it with going to play mode and back, when switching back press delete, or press zoom in/out button with it, sometimes works). Peaking looks like it's few pixels to right. Is the menu supposed to show only a few of the tabs in top(in this build)? for example i don't see the liveview tab outside of LV, not sure if feature/bug.
Canon 500D (T1i)
EF-S 18-55 (kit)
Flickr

 

Related Topics