500d development - page 175 - DSLR Hack development - CHDK Forum

500d development

  • 2487 Replies
  • 808901 Views
Re: 500d development
« Reply #1740 on: 09 / November / 2011, 04:06:08 »
Advertisements
1739 worked like the Hello one except there was no info this time at bottom, seemed stable but after a record stop then record it would freeze and of coarse was fine if I ran it through a display till I got to canons info again it seemed fine, but in all these tests at least you know the canon full bottom bar crashes it for sure right away, you cant even record a second unless audio is off of coarse then its safe like we noticed. Obviously in still mode its peachy, just while recording video. Maybe the 500d is just a wimp and cant handle to many things at once lol!!!

Re: 500d development
« Reply #1741 on: 09 / November / 2011, 04:16:32 »
Actually I will correct that, that one seems fine without doing the cycle through disp, i noticed if u wait a few seconds before recording the screen does some kinda recycle thing, u see it recycle good with focus peaking on, it seems to do it twice and the after the 2nd one you can record without a crash. I was pressing record to fast on that last autoexec.bin 1739 cause my bat is dieing lol, but seems to record fine, no bottom bar but records fine if you dont rush it.

I went back to try the Hello one to wait for the screen refresh in between recordings and that one crashed.
« Last Edit: 09 / November / 2011, 04:23:21 by mk11174 »

*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1742 on: 09 / November / 2011, 04:19:30 »
Can you test 1720 again?

Re: 500d development
« Reply #1743 on: 09 / November / 2011, 04:23:53 »
Can you test 1720 again?
ok ill retest 1720

ok, i went back to 1720, i was patient waited for the screen refresh thing on the 3rd recording it crashed, i didnt press any buttons while recording just recorded 10 sec each stopped it, waited till it refreshed the screen and started recording again, 3rd one crashed it, ill try 1739 again see how many recording i can get before crash if it crashes soon as my 2nd bat finishes charge.

Ok, went back, 1739 still good, i made it through 10 records with no crash, no going through display cycle, just being patient and waiting for screen to refresh or whatever its doing those 2 times in a row after each recording, and seems fine as long as u dont try pressing the shutter button or disp while recording then it gets flakey will crash every so often if u do that while recording.
« Last Edit: 09 / November / 2011, 04:39:23 by mk11174 »


*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1744 on: 09 / November / 2011, 04:36:51 »
So the problem seems to be somewhere else...

All the LiveView tasks are disabled here. Redraw is also disabled (and replaced with a "clear screen").

Side note: there was a similar problem on 550D a month ago; I was able to reproduce it only by taking pictures while recording, at ISO 6400 RAW+L, and it crashed at the third or fourth movie. Since fixing that, most random ERR70 problems disappeared magically. But it took me a couple of hours just to isolate the problem... and then 5 minutes to fix it :)
« Last Edit: 09 / November / 2011, 04:42:57 by a1ex »

Re: 500d development
« Reply #1745 on: 09 / November / 2011, 04:44:37 »
174
So the problem seems to be somewhere else...

All the LiveView tasks are disabled here. Redraw is also disabled (and replaced with a "clear screen").

Side note: there was a similar problem on 550D a month ago; I was able to reproduce it only by taking pictures while recording, at ISO 6400 RAW+L, and it crashed at the third or fourth movie. Since fixing that, most ERR70 problems disappeared magically. But it took me a couple of hours just to isolate the problem... and then 5 minutes to fix it :)
4 as is turning on cam and pressing record crashes it right away, if it would of been best to reset the config data first, but thats what happened just loading that one, i of coarse saw only audio meter.

*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1746 on: 09 / November / 2011, 04:51:57 »
Hmm.. it runs very well on 550D.

Disabled the audio module.

Re: 500d development
« Reply #1747 on: 09 / November / 2011, 05:16:12 »
Hmm.. it runs very well on 550D.

Disabled the audio module.
On this one I saw I could get into ML menu unlike last one, this one seemed fine at first then crashed after 2 then 3 records 8/ no focus peaking even though it was turned on just plain canon screens and still crash just recording normal, sound i noticed during playback was louder, maybe cause of the agc??? So 1722 still seems to be the winner as long as you dont try to take a picture during recording and cycle through displays before a re-record, 1739 worked without cycling through displays as long as u waited a few seconds before each recording, and of coarse dont press any buttons while recording cause it randomly crashes. Thats for anyone just reading in of coarse, alex already knows all this from working so hard tonight to try to pinpoint this, thanks alex, I am glad u got 1722 out there though, its nice to have all the features enabled and still being able to record in vid with a little trick that seems to work, I myself am hooking myself up with a portable digital recorder next month that will mount on the shoe of the 500d, so I can turn audio off and ML then works awsome on it, so for me, this version is perfect but crossing my fingers for everyone else that dont have a digital audio recorder to take care of the sound.


Re: 500d development
« Reply #1748 on: 09 / November / 2011, 05:23:34 »
Alex, does the follow focus work correctly on the 550, I remember in the old 500d autoexec.bins with the 1st ML the follow focus was nice, you can easily fine tune the focus just by pressing the arrow buttons, on these new versions since the new firmware, you cant finetune it anymore, all 4 buttons seem to just go a set amount, top and bottom are faster then the left and right ones, but you cant fine tune little by little anymore, its just goes back and forth till something that says soft focus was reached? is that how it works on the 550 as of now or does it seem to be just on 500d.

*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1749 on: 09 / November / 2011, 05:25:05 »
Maybe it's easier to go from the other end.. with everything disabled, start enabling stuff.

This one will set the version string in Canon menu and do a tiny bit of initialization.

Follow focus works very well on all other cameras (550d/60d/600d/50d/1100d).

 

Related Topics