500d development - page 183 - DSLR Hack development - CHDK Forum

500d development

  • 2487 Replies
  • 913576 Views
*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1820 on: 18 / November / 2011, 02:09:23 »
Advertisements
The err70 is only when you open the menu while recording? What are the exact steps for reproducing it?

Re: 500d development
« Reply #1821 on: 18 / November / 2011, 02:23:05 »
I don't have the camera right here, but when recording the error70 occures after a couple of seconds in ML menu. If your quick, it might not crash thoug.
Canon EOS 500D
Sigma 17-50mm f/2.8 OS
Canon EF 50mm f/1.8 +++ more

Re: 500d development
« Reply #1822 on: 18 / November / 2011, 02:28:09 »
The err70 is only when you open the menu while recording? What are the exact steps for reproducing it?
Yes, only during recording, you record, if you try to open ML menu you get to play with it for a few seconds it works faster for some reason now so u can actually get a chance to change something before err70, before it would be sluggish while recording and moving through the menu so you really didnt have time to change anything, but it at least seems faster now while recording.

*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1823 on: 18 / November / 2011, 03:56:03 »
Faster... compared to which version?

On my cameras, the menu is always fast.

Can you show me a movie where the slowness in the menu is visible? It may give clues about what's going on.
« Last Edit: 18 / November / 2011, 03:58:54 by a1ex »


Re: 500d development
« Reply #1824 on: 18 / November / 2011, 04:43:20 »
Faster... compared to which version?

On my cameras, the menu is always fast.

Can you show me a movie where the slowness in the menu is visible? It may give clues about what's going on.
Actually I guess it only happens when its about to crash, it was hard to get it to slow down, I dont remember which one it was, it was during the week we tested all the ones in the one night, it happened on the one you just released before the upside down one, when recording, and when u goto ml mode, it only sometimes reacts very slow to ur button presses, it lags when u try to scroll then all of a sudden crashes, but for sure not all the time so prob just depends on what the cam is doing at the moment i guess, but on this version i havent had it do that just crashes, not menu lag, but could just be coincedence, but yet, i really never have a reason to use menu while recording, so i only noticed it when testing those others the other day.

Update: I went all the way back to the first one where u started enabling things and that one worked the same way while recording, it only slows every so often right before it goes to err70, so it seems its just depending on what the cam is doing at the moment, one thing i noticed on this upside down version and the very first version where u just started enabling things for testing from scratch, while in the menu during record, of coarse u only get a few seconds sometimes longer, its never the same amount of time, but one thing i notice that happens is, whatever is highlight, the selection changes right before it chashes, like if your on movie logging for instance, if its set to off, it will switch to on by itself right when it crashes, but the setting is back to off when you restart. Maybe that might help u figure something out, but that always happens.
« Last Edit: 18 / November / 2011, 04:58:44 by mk11174 »

*

Offline vorob

  • *
  • 26
Re: 500d development
« Reply #1825 on: 18 / November / 2011, 09:15:04 »
http://magiclantern.wikia.com/wiki/Canon_EOS_500D/T1i

Not a single word about FPS on 500d, so? Is there 1080h with 30 fps?

*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1826 on: 19 / November / 2011, 12:02:29 »
Here's a binary with all the bells and whistles removed from the menu. Don't be scared about how it looks. Does it fix err70?

Re: 500d development
« Reply #1827 on: 19 / November / 2011, 12:56:44 »
Here's a binary with all the bells and whistles removed from the menu. Don't be scared about how it looks. Does it fix err70?
No, still same results, also still there, also still acts like it presses the select button on the highlighted menu item right as it crashes.


*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1828 on: 19 / November / 2011, 13:17:46 »
Do you have a deterministic method for reproducing the crash? Can you tell me the exact steps?

When it changes the selection, does it do SET, PLAY or Q? On "movie logging" and other boolean items, all 3 do the same thing.

Here's one autoexec with button handling disabled in the menu. You can open and close it, but you can't navigate.

Re: 500d development
« Reply #1829 on: 19 / November / 2011, 14:09:58 »
Do you have a deterministic method for reproducing the crash? Can you tell me the exact steps?

When it changes the selection, does it do SET, PLAY or Q? On "movie logging" and other boolean items, all 3 do the same thing.

Here's one autoexec with button handling disabled in the menu. You can open and close it, but you can't navigate.
Ok, good note about all 3 buttons doing the same thing, I never noticed that, I used zebra and its the record button that is being activated right at crash, the 1826 bin seems to crash without going into menu, its acting like old crash where when the colored bottom bar is on it gets unstable and crashes, but pretty much crashes instantly now when you open ML menu, it works more stable if you flip through the display before recording to only show canons info though, I will try 1828 now

1828 is not crashing when I open the menu, that was the longest I was ever able to record while menu was open, I did 3 records one after another as well to be sure cause sometimes the very 1st record is somewhat stable but once it crashes finally every one after crashes right away. But this one seemed to stay recording.
« Last Edit: 19 / November / 2011, 14:17:26 by mk11174 »

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal