500d development - page 119 - DSLR Hack development - CHDK Forum  

500d development

  • 2487 Replies
  • 914089 Views
*

Offline utnuc

  • **
  • 55
Re: 500d development
« Reply #1180 on: 21 / May / 2011, 13:52:15 »
Advertisements
sbright33: It has happened to me 3-4 times as well, regardless of whether my ML card is in or not.  

One potential solution would be to leave the line:
Code: [Select]
magic.disable_bootdiskf = 1in magic.cfg, and leave magiclantern.fir on your card (along with your autoexec.bin).  That way, when you want to use ML, you flash to set the bootflag and reboot.  When you reboot you'd have one session with ML, and the bootflag will be turned off saving your battery when you switch to OFF again.  A hack/workaround that shouldn't be necessary, but suffices for now.

Ben

ps I don't know the ramifications of repeatedly reflashing the bootflag... anyone have any insight here?
« Last Edit: 21 / May / 2011, 13:53:48 by utnuc »

Re: 500d development
« Reply #1181 on: 21 / May / 2011, 14:22:39 »
isnt it just easier to just simply take the battery out when ur not using it, it helps to avoid natural drain anyway, i always take bat out when im not using it, i do this for all my cameras.

Re: 500d development
« Reply #1182 on: 21 / May / 2011, 15:44:22 »
Yes, that is the best solution.  There is no drain without ML.  It lasts for months.  The problem is it's so difficult for my fingers to open the battery door!  Can we add a garage door opener feature to the next version?

Re: 500d development
« Reply #1183 on: 21 / May / 2011, 17:44:13 »
haha, yea ive posted many times about the battery issue.... just something is really buggy about the bootflag being set. doesnt seem like theres a solution.... i wonder if people using 5D II and the t2i have the same problem.. maybe its just the t1i that has issues..


Re: 500d development
« Reply #1184 on: 21 / May / 2011, 18:29:39 »
This from AJ build for 5d

============   (which *only* runs on 5D2 @ 2.0.4)  *BETA*-TEST-VERSION
> === AJ 5.5 ===
> ============    Download 2.0.4 from
> http://www.moiraobrien.com/magiclantern/


> This version has the following Changes:


> *ML SHUTDOWN:*  Enhancement & Bugfix


> After hearing reports that some ML remnant was sapping power after in
> AJ5.4, added a defence-against-the-dark-arts feature to AJ5.5.  When ML
> shutsdown now, you will see:
> +) Sensor Cleaning
> +) Flashing CF Red LED,
> +) A new flashing* B**l**u**e **LE**D*.  When this Blue light stops
> flashing - ML has shut down completely.


> It works as follows:  I have scattergunned code in every ML tasks loop
> where that increments a counter.   In the shutdown process - It checks every
> 2 seconds until this counter stops increasing.  If it keeps flashing ... you
> Need to take the battery out (and let me know if this is reproducible).
> Using this DATDA measure .. I found and fixed a process that wasn't shutting
> down.  This should solve the Battery Drain issue reported.




haha, yea ive posted many times about the battery issue.... just something is really buggy about the bootflag being set. doesnt seem like theres a solution.... i wonder if people using 5D II and the t2i have the same problem.. maybe its just the t1i that has issues..

*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1185 on: 21 / May / 2011, 18:55:01 »
Early 2010 builds of 550D were affected by this, but now it's no longer an issue.

On 550D, it happened when starting the camera without config file. Trying to open an inexistent file on certain cards caused memory corruption. You could detect easily this bug by trying to start the camera again (it won't restart until you take the battery out).

Now it still happens if ML would emulate half-pressing the shutter a lot of times per second (which was needed for trap focus without having to hold the shutter button). This feature is disabled (for this reason).

Here, when the shutdown event appears, all ML tasks will terminate at the next call to msleep. I'm not sure why AJ has problems with this; could be an autoexec.bin too large (on 550D this would cause problems).

Re: 500d development
« Reply #1186 on: 21 / May / 2011, 23:45:39 »
I have an easier solution to avoid opening the difficult battery door.  Turn off, put in normal memory card.  Turn on, turn off. Go to bed.

Re: 500d development
« Reply #1187 on: 22 / May / 2011, 00:35:32 »
soo as long as we have the memory card with ML inside the camera at the time of turn off then the camera should not drain?


*

Offline Coutts

  • *****
  • 538
  • www.flickr.com/couttsphotog
    • Flickr
Re: 500d development
« Reply #1188 on: 22 / May / 2011, 02:27:19 »
soo as long as we have the memory card with ML inside the camera at the time of turn off then the camera should not drain?
take your battery out and put it back in, no worries of drained battery then :)

remember ML is still beta...
Canon 5d
Canon 50mm f/1.8
Sigma 24mm f/1.8

Flickr

Re: 500d development
« Reply #1189 on: 22 / May / 2011, 03:36:31 »
@aznguy - It was in every time when I turned it off.  I removed it to download the images while it was off.  When I turned it on in the morning it was dead.

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal