500d development - page 173 - DSLR Hack development - CHDK Forum  

500d development

  • 2487 Replies
  • 803808 Views
*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1720 on: 08 / November / 2011, 13:44:15 »
Advertisements
Now it should no longer crash due to clearscreen. I've replaced the functions for disabling bitmap overlay with a softer method (a fake dialog box which clears the screen). It kills all Canon graphics, but ML might still draw something over it (but at first test it seems fine).

This autoexec has disabled top and bottom bar disabled (but everything else enabled). Does it still crash?

*

Offline PHrag

  • *
  • 33
    • Flickr
Re: 500d development
« Reply #1721 on: 08 / November / 2011, 13:59:26 »
This autoexec has disabled top and bottom bar disabled (but everything else enabled). Does it still crash?
Awesome, no more crashes! Even screenshots and ML menu works.

regarding my previous question about only a few tabs displayed in the top of ML menu (it was full in previous builds) is that right?
« Last Edit: 08 / November / 2011, 14:02:21 by PHrag »
Canon 500D (T1i)
EF-S 18-55 (kit)
Flickr

*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1722 on: 08 / November / 2011, 14:03:46 »
Quote
You are supposed to read help texts from the menu ;)
^^^

Now this autoexec has everything enabled (including top and bottom bars). We'll see now if these were causing crashes.
« Last Edit: 08 / November / 2011, 14:07:15 by a1ex »

Re: 500d development
« Reply #1723 on: 08 / November / 2011, 16:33:25 »
Very interesting, that first Autoexec.bin Alex sent that says the ML bars turned off works stable as anything even in movie mode where with the latest Alpha err70 on 1280x720 and 1920x1080 recording, even sound playback works, on the 2nd Autoexec,bin he sent, that one err70's but seems to only happen if you have Canons Audio recording turned On, if you turn Audio recording off it is very stable and I tested with all the cool features on too, weird how the 1st one works stable audio on or off but the 2nd one crashes with audio on but very stable with it off and works fine on all the other features as well till you turn audio on.


*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1724 on: 08 / November / 2011, 16:55:48 »
So, with 1720 is fine and with 1722 is not?

The only difference between these two is top and bottom bars (lens.c).

Re: 500d development
« Reply #1725 on: 08 / November / 2011, 17:00:46 »
So, with 1720 is fine and with 1722 is not?

The only difference between these two is top and bottom bars (lens.c).
Yeah, from those 2 autoexec you sent, the one with the bars disabled works super stable when recording in movie mode in any res and with audio on or off, the last one u sent works just as good as long as audio is set to off in canon menu, once on, it crashes to err70 like in the alpha release, and also audio playback works in these bins unlike in the alpha release. 8]

*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1726 on: 08 / November / 2011, 17:03:35 »
Well.. this one has the top bar disabled.

*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1727 on: 08 / November / 2011, 17:05:14 »
... and this one has the bottom bar disabled.

Which one could be the problem?

Also, on #1722, try to set "ML info bars" to "inside 3:2". Does it fix anything?


Re: 500d development
« Reply #1728 on: 08 / November / 2011, 18:12:59 »
Geez!!! I went back to that 2nd autoexec you uploaded with everything enabled when these 2 new ones err70 on me, and found that it was stable till I pressed the display button and showed the botton ML info bar, then it crashed then when I pulled batt and retried with or without displaying the bottom bar it crashed, but was fine up till the first time i tried to display the bottom bar, so thats weird, but no matter what though, turning Audio off in canon menu makes it work fine, all bars on or off and all fancy features used, it runs perfect if audio is set to off, so obviously the bottom bar makes it less stable on the 500d, but even when off it still eventually crashes. But audio off seems to be the way to go, great if you have a seperate audio recorder.

Re: 500d development
« Reply #1729 on: 08 / November / 2011, 18:30:51 »
Hmmm!!! Another interesting find, Using the 2nd Autoexec.bin u posted that has everything back on, I found to get it to record stable with Canon audio on, is before you record, cycle through the display with the Disp button till you go past the ML bar and only see the canon display at bottom, it will record stable, but you have to first to a cycle at least 1 time when you first turn cam on, while ur recording if you press display to show ML bottom bar it will crash right away and after a bat rest it will still crash even if bottom bar is off untill you do a full cycle through display menus past the ML bottom bar is not on, so the bottom bar is one issue, but even with the Autoexec you sent to disable the bottom it will still crash, but hope this helps in some way, knowing that you can use the everything enabled Autoexec as long as you cycle through your display past the ML bottom bar before u record, seems to be very stable that way 8]. But also remember that you can utilize the ML bottom bar display stable if audio is off in canons menu
« Last Edit: 08 / November / 2011, 19:04:18 by mk11174 »

 

Related Topics