500d development - page 176 - DSLR Hack development - CHDK Forum

500d development

  • 2487 Replies
  • 907276 Views
Re: 500d development
« Reply #1750 on: 09 / November / 2011, 05:53:59 »
Advertisements
Maybe it's easier to go from the other end.. with everything disabled, start enabling stuff.

This one will set the version string in Canon menu and do a tiny bit of initialization.

Follow focus works very well on all other cameras (550d/60d/600d/50d/1100d).
On that one i saw no ML menu at all and from what u said I guess that is correct, it didnt even seem like it was loaded, even at the format menu it didnt show the option to format and save ML, I just went there to check, just letting u know everything i saw to see if this what u expected??? Recording was 100% stable no matter what i messed with during it.

*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1751 on: 09 / November / 2011, 06:05:03 »
That's right, everything was disabled.

After some code cleanup ( http://groups.google.com/group/ml-devel/browse_thread/thread/2fd0bb4dd410a7fc ) I've discovered (and fixed) a potential stability problem. Also, arrow key codes were not defined in 500D, which may explain why follow focus was not working.

So here's a full autoexec.

*

Offline Coutts

  • *****
  • 538
  • www.flickr.com/couttsphotog
    • Flickr
Re: 500d development
« Reply #1752 on: 09 / November / 2011, 06:08:21 »
^ that may fix lcd shortcuts then (they weren't working).
Canon 5d
Canon 50mm f/1.8
Sigma 24mm f/1.8

Flickr

Re: 500d development
« Reply #1753 on: 09 / November / 2011, 06:20:34 »
That's right, everything was disabled.

After some code cleanup ( http://groups.google.com/group/ml-devel/browse_thread/thread/2fd0bb4dd410a7fc ) I've discovered (and fixed) a potential stability problem. Also, arrow key codes were not defined in 500D, which may explain why follow focus was not working.

So here's a full autoexec.
Well, same crashes, no advanced ML menu, just freezes if you try, cam records a few seconds with bottom bar shown but then crashes even if everything turned off from basic menu, follow focus now works like i remember except the left arrow key, that one still scrolls focus to whatever and where it says soft focus reached, but all other 3 work as i remember, so thats a plus 8]


*

Offline PHrag

  • *
  • 33
    • Flickr
Re: 500d development
« Reply #1754 on: 09 / November / 2011, 12:18:28 »
I confirm everything what mk said above, and found out that Magic zoom flickers alot. Wanted to track the problem, but after trying the 1708 my camera won't boot with it anymore. It did yesterday. Even after removing the card it doesn't do anything. I have to remove the battery and boot it without card or with newer autoexec. (<- doesn't matter anyway). Anyway, last build it worked without flickering was 1668 by Coutts. Also the boarders never turn green as said in the help. I'm sorry about the /too few tabs in the top/ thing, I was just blind, found it out today haha.
Canon 500D (T1i)
EF-S 18-55 (kit)
Flickr

*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1755 on: 09 / November / 2011, 12:48:42 »
Let's continue troubleshooting the stability problem.

This time I've disabled most modules.

Follow focus should work.

Re: 500d development
« Reply #1756 on: 09 / November / 2011, 13:42:00 »
Let's continue troubleshooting the stability problem.

This time I've disabled most modules.

Follow focus should work.
Ok, testing and thanks again alex, for all the trouble u r going through for all of us 8]

Test update: I see the ML menu fine, not much in it obviously, can access advanced menu now, all buttons work follow focus perfect and recording is 100% stable 8] no matter what i do during recording.
« Last Edit: 09 / November / 2011, 13:56:07 by mk11174 »

Re: 500d development
« Reply #1757 on: 09 / November / 2011, 14:00:31 »
It works very well. When focus delay "wait + xx ms" is enabled, this happends: Stepsize 2 and 3 are way too large. With the 18-55 IS on focus step 1, there are 37 focus steps from one end to another, which is nice. When using step size 2 or 3 there are just 6 step from one end to the other. When disabling "wait", the problem doesn't occur. Then everything is smooth and functioning as it did on beta 1.5, etc.
Canon EOS 500D
Sigma 17-50mm f/2.8 OS
Canon EF 50mm f/1.8 +++ more


*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1758 on: 09 / November / 2011, 14:01:04 »
Great!

Enabled a bit more (tweaks and movie).

Re: 500d development
« Reply #1759 on: 09 / November / 2011, 14:12:23 »
Great!

Enabled a bit more (tweaks and movie).
That one shows wakeup message the whole time and err70 a few sec after recording, and wakeup flickers as well. menu twitches back and forth to live view screen, seems to be inline with the wakeup message on the screen

Update: it only seems to crash when flipping through with the display button during recording, like right after its blank screen, not every time but most of the time it does it right away, taking pictures seems fine during recording.
« Last Edit: 09 / November / 2011, 14:17:55 by mk11174 »

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal