500d development - page 180 - DSLR Hack development - CHDK Forum supplierdeeply

500d development

  • 2487 Replies
  • 908469 Views
*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1790 on: 10 / November / 2011, 04:41:04 »
Advertisements
Fixed.

Can you take a look at defishing and ghost image? I've changed the graphics engine since Coutts aligned them.

Re: 500d development
« Reply #1791 on: 10 / November / 2011, 05:11:26 »
Thanks Alex,
Clean Compile.
At work without camera.So will have to test once home.

Adam

*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1792 on: 10 / November / 2011, 06:23:33 »
I've tested defishing on the HDMI monitor (there, the screen layout is somewhat similar to 500D's) and should be OK now.

*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1793 on: 10 / November / 2011, 10:05:23 »
Quick question: is the menu still working in this one?


Re: 500d development
« Reply #1794 on: 10 / November / 2011, 10:26:25 »
I've tested defishing on the HDMI monitor (there, the screen layout is somewhat similar to 500D's) and should be OK now.
I dont have a cable to view hdmi, but on cam, difishing still works, its a greyscale preview on here that cant be recorded or taken a picture of if thats how its suppose to work, and ghost image i cant get to work, but never could on any build, i goto play, i select an image, i press record button, it shows the image like it strts doing what it should be doing, the displays go away, then if u try to move it around or whatever it just goes back to regular play mode to select an image. Doesnt crash or anything.

Re: 500d development
« Reply #1795 on: 10 / November / 2011, 10:30:32 »
Quick question: is the menu still working in this one?

yes menu still works, i actually was able to access menu for a little while while recording, it took a few seconds before it crashed, i scrolled through the menus, it was slow, but didnt crash right away, never tried with the last couple before this though, just thought of it this time cause u asked about menus

Update: yeah, i could access menu while recording with the last few before this one, sometimes i got further sometimes it crashed right away. i doubt anyone cares bout accessing it while recording anyway, 8] i love these new builds!!!!!
« Last Edit: 10 / November / 2011, 10:38:07 by mk11174 »

*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1796 on: 10 / November / 2011, 10:35:50 »
It crashed?!

Tell me the number which appears on the screen. Go to play mode and back a few times. There are two possible values, tell me both.

Re: 500d development
« Reply #1797 on: 10 / November / 2011, 10:40:38 »
It crashed?!

Tell me the number which appears on the screen. Go to play mode and back a few times. There are two possible values, tell me both.
ok, ill try now, and yeah, it crashed only while trying to open ML menu while recording, its always done that though but works longer before a crash now, other than that its stable on anything else.

36b8100  the lower case b twitches once in awhile to which looks like an 8, way to fast to read it, it does it when u go back and forth with play or its just a regular debug twitch and it no new number or letter at all, looks like an 8 if anything

update, the b changed to a 3 when i made it crash by going to the ML menu while recording in case u needed to know that tooo

update 2: just to note, i went back and tried 1755 the crash happens on that one to, the highlight menus turn red too if u try to view it while recording, but unless it bugs u wondering y it crashes, i wouldnt stress about that one cause its very stable while recording, u did great and finally having it stable during recording is the more important thing im sure 8]
« Last Edit: 10 / November / 2011, 10:53:33 by mk11174 »


*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: 500d development
« Reply #1798 on: 10 / November / 2011, 10:53:53 »
Sounds good. I went even further and replaced my BMP VRAM copy (allocated dynamically) with Canon's idle buffer for all operations. On 550D, focus peaking is much faster and on HDMI is way better.

So the question is: is this one as stable as previous ones?

Re: 500d development
« Reply #1799 on: 10 / November / 2011, 11:05:25 »
Sounds good. I went even further and replaced my BMP VRAM copy (allocated dynamically) with Canon's idle buffer for all operations. On 550D, focus peaking is much faster and on HDMI is way better.

So the question is: is this one as stable as previous ones?
hmmm, that one actually crashed during recording and trying to do a follow focus, stable otherwise, the bars seem to go away for a second randomly, didnt notice that before ill have to go check, focus peaking looks real fast while not recording, when recording it lags and is off a bit, ill have to go check the other ones to see if thats the case on them now.

update, this one is crashing a few times, not like crazy and doesnt seem to be like the old crash, cause it just randomly does it while recording, bottom bar doesnt sem to make it crash in anyway.
« Last Edit: 10 / November / 2011, 11:17:34 by mk11174 »

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal