Video exposure control, modified to work on Digic 4 camera's - page 4 - Completed and Working Scripts - CHDK Forum

Video exposure control, modified to work on Digic 4 camera's

  • 32 Replies
  • 14727 Views
Re: Video exposure control, modified to work on Digic 4 camera's
« Reply #30 on: 14 / May / 2013, 08:49:55 »
Advertisements
I've got sx240hs, is there a script to use for manual video settings? Let me know please. Thanks.
Do you know if exist a scrpt to use video mode in manual settings (iso, shutter and iris)? Thank you.

These are the only video scripts that I know about : http://chdk.wikia.com/wiki/User_Written_Scripts#Video

If you find more,  please update the wiki (or post links and I'll do it).
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Video exposure control, modified to work on Digic 4 camera's
« Reply #31 on: 19 / June / 2013, 19:19:21 »
I just installed CHDK today for the first time, and this is my first script. I made a good effort at modifying those two registers -- and I think I did it right. But I'm having a more basic problem.

When I try to load the script, I get

"Fail to load lua.flt: File not found."

Here's what I did:
  • I downloaded Videxp.lua from the first post in this thread.
  • I'm using an IXUS115 / ELPH100HS on 101.b, so I went here and found the two registers: https://trac.assembla.com/chdk/browser/trunk/platform/ixus115_elph100hs/sub/101b/stubs_entry.S
  • I substituted those two in the manualexp() and autoexp() functions in Videxp.lua
  • I put Videxp.lua inside ixus115_elph100hs-101b-1.2.0-2881-full_BETA/CHDK/SCRIPTS/
  • I loaded it to the card, enabled LUA Native calls, and then tried to load the script and saw the error message above.

What's wrong? I see lua.flt in my /MODULES directory, so I don't know what's going on. Maybe I'm missing something basic about working with scripts.
----------------------
EDIT: It's a more basic problem, so I started a new thread elsewhere (link below). I think my step-by-step might still help someone out later on down the road, though, so I'm leaving it.
http://chdk.setepontos.com/index.php?topic=10222.new#new
« Last Edit: 19 / June / 2013, 20:03:22 by Dune »

Re: Video exposure control, modified to work on Digic 4 camera's
« Reply #32 on: 02 / July / 2013, 20:25:12 »
if you can add jog-dial for when changing the tv-av-iso during record

maybe also a mode where all of them are combined onto one setting
with max aperture, min iso , etc
« Last Edit: 03 / July / 2013, 20:22:45 by pwcal2 »

 

Related Topics