Newby with Powershot SX30 IS--totally STUCK !! - page 3 - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum supplierdeeply

Newby with Powershot SX30 IS--totally STUCK !!

  • 39 Replies
  • 11262 Views
Re: Newby with Powershot SX30 IS--totally STUCK !!
« Reply #20 on: 19 / February / 2011, 10:48:15 »
Advertisements
OK Phil I reformatted the card ( low level) in the Canon SX30 IS

I restarted in the View mode, chose Menu, then navigated to " Create card with two partitions".

I DID get the warning message, and selected YES

After pressing the Function/Set button, I waited maybe 20 seconds, then re-started the camera.

I DID NOT GET ANY MESSAGE ABOUT A MEMORY CARD ERROR. Took the card out of camera at this point, placed in the card reader--just one 32 gig partition with CHDK etc. ie identical to before I placed card in the camera!

This is the exact spot I was at about 4 days ago. Perhaps you could clarify which button on the SX30 is in actuality the correct button to press to call up thje CHDK menu in the first place as this is very ambiguous--I am currently using the button just to the left of the viewfinder, Canon call it the "Shortcut" button-just a thought?

What am I still doing wrong?

*

Offline zeno

  • *****
  • 889
Re: Newby with Powershot SX30 IS--totally STUCK !!
« Reply #21 on: 19 / February / 2011, 11:56:18 »
If you have access to a Mac you should find it easier to do the partitioning (and install SDM or CHDK). My SDMInst app will handle cards up to 32Gb - it does the fomatting, making bootable and file copying. On a Mac both partitions are visible at the same time - no switching is needed.

See http://www.zenoshrdlu.com/clickpansdm/sdminst.html

Although it's called SDMInst it works just as well installing CHDK.
A570, S100, Ixus 127
Author of ASSIST, STICK, WASP, ACID, SDMInst, LICKS, WICKS, MacBoot, UBDB, CFGEdit

*

Offline philmoz

  • *****
  • 3226
    • Photos
Re: Newby with Powershot SX30 IS--totally STUCK !!
« Reply #22 on: 19 / February / 2011, 16:48:24 »
OK Phil I reformatted the card ( low level) in the Canon SX30 IS

I restarted in the View mode, chose Menu, then navigated to " Create card with two partitions".

I DID get the warning message, and selected YES

After pressing the Function/Set button, I waited maybe 20 seconds, then re-started the camera.

I DID NOT GET ANY MESSAGE ABOUT A MEMORY CARD ERROR. Took the card out of camera at this point, placed in the card reader--just one 32 gig partition with CHDK etc. ie identical to before I placed card in the camera!

This is the exact spot I was at about 4 days ago. Perhaps you could clarify which button on the SX30 is in actuality the correct button to press to call up thje CHDK menu in the first place as this is very ambiguous--I am currently using the button just to the left of the viewfinder, Canon call it the "Shortcut" button-just a thought?

What am I still doing wrong?

You're not doing anything wrong - it's likely there is a still a problem with the startup code in relation to the SD card.
It could be related to the size of the SD card, I've partitioned 16GB cards OK; but I haven't used a 32GB card.

What firmware version do you have? I found a proper fix for a startup problem yesterday (previously had a workaround in the code) and I'm still testing this version. If you let me know your firmware version I will email you a test version with the fix to see if it solves this problem.

Regards,
Phil.

CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

*

Online reyalp

  • ******
  • 12942
Re: Newby with Powershot SX30 IS--totally STUCK !!
« Reply #23 on: 19 / February / 2011, 17:00:56 »
You're not doing anything wrong - it's likely there is a still a problem with the startup code in relation to the SD card.
It could be related to the size of the SD card, I've partitioned 16GB cards OK; but I haven't used a 32GB card.
This really shouldn't matter. Either it works correctly with multiple partitions or it doesn't. You could put two partitions on a 1 gig card and it would be the same.
Don't forget what the H stands for.


*

Offline philmoz

  • *****
  • 3226
    • Photos
Re: Newby with Powershot SX30 IS--totally STUCK !!
« Reply #24 on: 19 / February / 2011, 18:08:32 »
You're not doing anything wrong - it's likely there is a still a problem with the startup code in relation to the SD card.
It could be related to the size of the SD card, I've partitioned 16GB cards OK; but I haven't used a 32GB card.
This really shouldn't matter. Either it works correctly with multiple partitions or it doesn't. You could put two partitions on a 1 gig card and it would be the same.


Hi reyalp,

I was referring to the startup delay kludge I have in taskHook because init_file_modules_task was not getting hooked properly. I found that card speed affected this so it's possible card size could have also. If init_file_modules_task doesn't get called then the MBR isn't read and the code that creates partitions won't do anything (also the code to make a card bootable and swap partitions doesn't work either). This would explain why hulland can run the 'create card with two partitions' command; but nothing happens.

Regards,
Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

Re: Newby with Powershot SX30 IS--totally STUCK !!
« Reply #25 on: 20 / February / 2011, 01:03:28 »
OK Phil, my firmware version is 100l ( one hundred "ell") --It may not be relevant, but I purchased this card with the camera as it was highly recommended as having the highest available transfer speed, to take advantage of the HD video, and rapid data transfer times built in to the XS 30--  and you can use this as my e mail;- ihfroggmann@gmail.com

*

Offline philmoz

  • *****
  • 3226
    • Photos
Re: Newby with Powershot SX30 IS--totally STUCK !!
« Reply #26 on: 20 / February / 2011, 01:52:18 »
OK Phil, my firmware version is 100l ( one hundred "ell") --It may not be relevant, but I purchased this card with the camera as it was highly recommended as having the highest available transfer speed, to take advantage of the HD video, and rapid data transfer times built in to the XS 30--  and you can use this as my e mail;- ihfroggmann@gmail.com

I've emailed you the beta 12 test version for 1.00L firmware - let me know how it goes.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

Re: Newby with Powershot SX30 IS--totally STUCK !!
« Reply #27 on: 20 / February / 2011, 02:22:12 »
Nothing received yet--kindly try ;- hulland@onvol.net   Thanks.


*

Offline SkyWalker9

  • ****
  • 301
  • SX20 IS (fw 1.02b)
Re: Newby with Powershot SX30 IS--totally STUCK !!
« Reply #28 on: 20 / February / 2011, 12:37:28 »
...It may not be relevant, but I purchased this card with the camera as it was highly recommended as having the highest available transfer speed, to take advantage of the HD video, and rapid data transfer times built in to the XS 30...
@hulland

I've been following this thread for awhile and seen what you have tried thus far. After your comment above, I'd recommend you try testing your 32G card using h2testw (http://mympx.org/Downloads/p13_sectionid/2/p13_fileid/13 ) There are "fake 32G cards"  that are causing folks problems. Here is a quote from another blog:

From what I've read the fake 32 GB cards are programmed so that the phone and/or a windows pc will report it as a 32 GB card. The only way to tell for sure is to run a program called h2testw. Also these fakes are either 2 or 4 GB cards to begin with so if you transfer over say 8 GB of music and some of the files are corrupted and won't play then you know its a fake. The card will allow you to transfer over 32 GB of data but since its actually only a 2 GB card it just keeps re-writting over the data corrupting it.

At least this is something easy to try that should ellimnate this as a concern. Good luck!

Re: Newby with Powershot SX30 IS--totally STUCK !!
« Reply #29 on: 20 / February / 2011, 14:50:23 »
Thanks Skywalker9 am running it now, however, I have already videod over 14 Gigs of HD video onto this card and transferred all OK last week, however, as you suggest it won't hurt to try it out.

 

Related Topics