SDM 1.85 Released - page 2 - Microfunguy's Builds - CHDK Forum  

SDM 1.85 Released

  • 38 Replies
  • 15575 Views
Re: SDM 1.85 Released
« Reply #10 on: 23 / April / 2011, 09:16:10 »
Advertisements
I have no idea.

No tester has ever reported that.
Delete the CFG file or even start with a clean card.

Try to develop a procedure that will reproduce the 'fault'.


Re: SDM 1.85 Released
« Reply #11 on: 23 / April / 2011, 14:07:23 »
Hi David,

thanks for reply, but I deleted already the CFG-file but no success :-(.
What means a 'clean card'?
I put the compiled DISKBOOT.BIN into the common_files folder where also sdminst.exe is located. Then I started the sdminst.exe, I choosed '4GB or less' then it formats the card in quickformat.
Then it asked me if I want to format with clustersize of 64KB cluster. I choose 'Y' and then I give the card a name.
Thats all.

Do I miss something?

And what you mean saying: 'Try to develop a procedure that will reproduce the 'fault'.'
Can you give some more hints?

Thanks a lot!
2 x IXUS 860IS 100c
2 x Powershot S110 103a

Re: SDM 1.85 Released
« Reply #12 on: 23 / April / 2011, 14:10:43 »
To confirm this problem, I have to ask someone to test.

So, you have to tell me the steps necessary to demonstrate the problem every time.


David

Re: SDM 1.85 Released
« Reply #13 on: 23 / April / 2011, 16:24:56 »
Hi David,

thanks for reply, the steps I already described in my previous posts, here again in summary:

1. I downloaded the sources from http://stereo.jpn.org/eng/sdm/download.htm
2. I downloaded the trunk (zip archive) from http://tools.assembla.com/chdk/browser/trunk
3. I extracted the zip and copied the tools dir into the source folder from step 1
4. I compiled the source (see compile log in one of my previous posts)
5. The resulting DISKBOOT.BIN I copied into the common_files folder where also sdminst.exe is located
6. I started the sdminst.exe
7. I choosed '4GB or less' then it formats the card in quickformat.
8. When It asked me to format with clustersize of 64KB cluster. I choose 'Y'
9. Then I give the card a name.
10. I switch the card to locked and insert into the cam
11. I switch on the cam I can see the big 1.85
12. I press ALT and then MENU to enter the SDM settings
13 The submenu 'Zebra/Histogram' appears, but not the SDM main menu

If I am inside this 'Zebra/Histogram' submenu and move to one of the subentries e.g. 'Histogram mode' then the value on the right side changes automatically form Linear to Log in certain intervals but I do not touch any key.
So it changes from Linear to Log and back to Linear itself. The interval is random.
This happens also to other entries like 'Histogram layout', there also all values appear in random intervals.

I use the IXUS860 cam, and GCC environment inside Eclipse CDT (www.eclipse.org)
I use a Panasonic 4GB SD HC card class 6.

Thanks for any further help!

« Last Edit: 23 / April / 2011, 16:28:30 by mr.burns »
2 x IXUS 860IS 100c
2 x Powershot S110 103a


Re: SDM 1.85 Released
« Reply #14 on: 23 / April / 2011, 16:35:43 »
Well, a very good German user has created a spreadsheet of the IXUS860 tests and that problem would have been immediately obvious.

Nevertheless, I will ask him to test it.

Try downloading the official IXUS860 SDM build and report back.

Re: SDM 1.85 Released
« Reply #15 on: 24 / April / 2011, 05:48:42 »
2 x IXUS 860IS 100c
2 x Powershot S110 103a

Re: SDM 1.85 Released
« Reply #16 on: 24 / April / 2011, 06:10:06 »
2 x IXUS 860IS 100c
2 x Powershot S110 103a

Re: SDM 1.85 Released
« Reply #17 on: 24 / April / 2011, 06:16:39 »
do you mean W.B.?

Yes, an excellent and very thorough tester.

Quote
did he compile the source by himself

No.

Quote
can it be that the source is different from the one you used to compile the official release?

After uploading 1.85 and source I made very minor changes to my local version, nothing that would cause the problem you describe.

I will download the 1.85 source and CHDK tools directory and compile it.
I will upload the .BIN in ten minutes.


David


Re: SDM 1.85 Released
« Reply #18 on: 24 / April / 2011, 06:28:52 »

Re: SDM 1.85 Released
« Reply #19 on: 24 / April / 2011, 07:06:38 »
Hi David,

thanks for the compiled DISKBOOT.BIN, it works on my IXUS860 IS.
That means if I compile on my environment there must be something different compared to yours.
What can it be? Do you use some special compiler settings?
I am on Windows XP, installed GCC451 and used it out of Eclipse CDT (do you know eclipse?)
Do you have any clue what causes the different result?

Thanks for any further help!
2 x IXUS 860IS 100c
2 x Powershot S110 103a

 

Related Topics