A2200 IS porting thread - page 19 - DryOS Development - CHDK Forum supplierdeeply

A2200 IS porting thread

  • 514 Replies
  • 94081 Views
Re: A2200 IS porting thread
« Reply #180 on: 15 / January / 2012, 01:33:16 »
Advertisements
Tested the 1.00D port and found the ubasic scripts to be working perfectly.

lua scripts are not working though. They just shut the camera down when started.

Anything special needs to be done to enable lua scripting support?

All the misc items such as games, calendar, file browser work but the palette needs fixing as the selections display the colours as white on white.

***"Sokoban" works perfectly if loaded through the misc option in the menu.

Tested the Intervalometer, Ultra Intervalometer, HDR, and Sunset4 ubasic scripts. All work perfectly.

Nilinhim can you please tell us whether lua scripts are working for your 1.00B port?
« Last Edit: 15 / January / 2012, 01:35:30 by Nemesisforever »

Re: A2200 IS porting thread
« Reply #181 on: 15 / January / 2012, 03:59:40 »
First of congratulations and thanks to mk11174 for time and effort and Nemesisforever for testing it out.

Nilinhim can you please tell us whether lua scripts are working for your 1.00B port?

Lua scripting works fine on 1.00B (tried it with example and my own scripts (even calling firmware functions, when enabled in CHDK build, work)).

The pallet needed fixing for 1.00B too, so custom colors were implemented (referencing ixus310). If everything is the colors should show up in the color pallet on the eleventh line (if they do, try deleting the CHDK dir from the sd card to clear any settings which might have been left from before).

Re: A2200 IS porting thread
« Reply #182 on: 15 / January / 2012, 05:39:33 »
Ok, so I guess the LUA not working was a memory thing, I turned off a couple of chdk-shell compile options and now the lua scripts work for both the a2200 100d and my a3300 100a.

Specifically PTP when used as an option seems to shut cam off when loading LUA scripts.
« Last Edit: 15 / January / 2012, 06:06:11 by mk11174 »

Re: A2200 IS porting thread
« Reply #183 on: 15 / January / 2012, 06:45:08 »
Ok, so I guess the LUA not working was a memory thing, I turned off a couple of chdk-shell compile options and now the lua scripts work for both the a2200 100d and my a3300 100a.

Specifically PTP when used as an option seems to shut cam off when loading LUA scripts.

Could you tell me which options? I tried executing lua over ptp and got a couple of crashes (not always) when triggering the shutter.


Re: A2200 IS porting thread
« Reply #184 on: 15 / January / 2012, 07:09:32 »
Ok, so I guess the LUA not working was a memory thing, I turned off a couple of chdk-shell compile options and now the lua scripts work for both the a2200 100d and my a3300 100a.

Specifically PTP when used as an option seems to shut cam off when loading LUA scripts.

Could you tell me which options? I tried executing lua over ptp and got a couple of crashes (not always) when triggering the shutter.
In the chdk-shell after unchecking and rechecking all the compiling options, the only way that makes LUA crash is when I check OPT_PTP dont seem to have any issues with other checked after further tests.

Re: A2200 IS porting thread
« Reply #185 on: 15 / January / 2012, 08:53:10 »
Work fine in my a2200  1.00D
congratulations and thank you very much to mk11174 and all for time and effort

Re: A2200 IS porting thread
« Reply #186 on: 15 / January / 2012, 16:09:44 »
works fine too, here. thanks for this :)
« Last Edit: 15 / January / 2012, 16:42:40 by fokk »

Re: A2200 IS porting thread
« Reply #187 on: 16 / January / 2012, 17:37:06 »
Hey All,

First off, I am 100% new to this, so please bear with me. I have loaded the 1.00D firmware with mixed results. The CHDK loads (no splash screen appears with logo appears), but it tends to crash whenever I attempt to do anything. I am wondering if any one would be willing to take the time to troubleshoot with me. I can give more info if anyone is willing to assist me. I would really like to be able to use the firmware with success!


Re: A2200 IS porting thread
« Reply #188 on: 19 / January / 2012, 00:28:31 »
Been checking this 1.00D port and found that "Force Manual Flash" doesn't work.

Camera turns off when "Override Subject Distance" is on as stated by Nilinhim.


Re: A2200 IS porting thread
« Reply #189 on: 21 / January / 2012, 03:08:31 »
Can someone point me in the right direction?

If I try to take a picture with LUA over ptp (lua shoot() or lua press(shutter_half & full)), the camera (1.00B) sometimes crashes. Other stuff works fine (controlling modes, keys, file management, ...).

Quick glance at ROMLOG suggest it might be a memory issue (might be related to executing LUA on 1.00D if compiled with PTP enabled), but I need someone to confirm this and points me in the right direction how to deal with this.

 

Related Topics