A2200 IS porting thread - page 46 - DryOS Development - CHDK Forum

A2200 IS porting thread

  • 515 Replies
  • 154288 Views
Re: A2200 IS porting thread
« Reply #450 on: 29 / September / 2012, 11:47:59 »
Advertisements
"failed to load mdetect.flt. bad import symbol" then camera stops responding, no buttons work, then after 5-6 seconds its crashes. i also saw something about chdk mismatch with one of motion detection scripts.
You have to copy all the file from the CHDK distribution to your SD card every time you update anything.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline nafraf

  • *****
  • 1308
Re: A2200 IS porting thread
« Reply #451 on: 29 / September / 2012, 12:02:29 »
Awesome Work. Thanx for bringing CHDK to A2200. i have used chdk1.0 as well as 1.1.
I have encountered a problem on the latest build  CHDK-a2200-100d-1.1.0_BETA, motion detect scripts to not work
"failed to load mdetect.flt. bad import symbol" then camera stops responding, no buttons work, then after 5-6 seconds its crashes. i also saw something about chdk mismatch with one of motion detection scripts.
New patches were added to a2200 100d today, but it need to be tested before adding it to autobuild server. 

@bugmenot, if you want to help with test and report results, send me a PM with a real e-mail. I'll send you the link to the latest release.

*

Offline ahull

  • *****
  • 634
Re: A2200 IS porting thread
« Reply #452 on: 30 / October / 2012, 10:23:58 »
Any progress on testing and adding to the Autobuild server. I have an A2200 here if you need another tester.

*

Offline nafraf

  • *****
  • 1308
Re: A2200 IS porting thread
« Reply #453 on: 30 / October / 2012, 21:05:49 »
Any progress on testing and adding to the Autobuild server. I have an A2200 here if you need another tester.
I had not received feedback from testers. If you want to help with tests, and you can post the results, send me a PM (private message) with your e-mail address and the firmware version that you can test.


Re: A2200 IS porting thread
« Reply #454 on: 03 / November / 2012, 16:30:27 »
I've been helping to test the A2200 port and wanted to report on test results and also ask a question.

Optical zoom works as expected although it is a bit noisy. At this point there does not appear to be a MUTE MIC function.
 
Toggling RAW on and off works as expected.

I tested video quality with Video Mode = Quality. I first tried a video quality setting of 99 but the movie stopped recording after a about 3 seconds. A warning “!” appeared in the upper left portion of the screen indicating the data rate was too fast. I had success using a setting of 85 and followed that with a setting of 1. The file size for a one minute video at 85 was 290MB and for a setting of 1 13MB The bitrate was also much slower for when using the setting of 1 so this seems to be working as expected.

I tested the llibtst.lua, setmode.lua, and ubtest.bas tests and all passed. I can post the logs if that is of interest to anyone. I looked at the four photos acquired automatically with the ubtest.bas script and the Tv+2 and Sv-2 have the same exposure and both were darker than the photo acquired using “ND out”. Is that what is expected? The neutral density filter photos came out as expected with the “ND in” darker than “ND out”.

Re: A2200 IS porting thread
« Reply #455 on: 09 / November / 2012, 07:21:27 »
heyhey.
Ran libtest today looks like everything checks out and passes!

http://www.pastebin.ca/2249961

Im on firmware 100B.
Havent done much of my own practical testing. RAW works A-okay. countdown intervalometer script worked just fine. The 'face tracking' box likes to erase the menu as it runs across the screen couldn't really find a way to fix this except switch it off, except for some reason it keeps switching itself back on again not sure if im doing something wrong. g/l with the final build!

Re: A2200 IS porting thread
« Reply #456 on: 11 / November / 2012, 00:53:00 »
CHDK-a2200-100d-1.0.0_BETA works weired with ND filter. It hangs and even one time turned off the camera. Just makes 1 shot and then problems begin.

*

Offline nafraf

  • *****
  • 1308
Re: A2200 IS porting thread
« Reply #457 on: 11 / November / 2012, 05:34:05 »
CHDK-a2200-100d-1.0.0_BETA works weired with ND filter. It hangs and even one time turned off the camera. Just makes 1 shot and then problems begin.
Please test the version from autobuild server.


Re: A2200 IS porting thread
« Reply #458 on: 17 / November / 2012, 12:18:54 »
I tested out the build 2282 for 100B from the autobuild server and it works: lua & basic scripts worked, overrides worked (including sub. dist. if AFL was activated or ignored it if AFL was not active), also remote triggering trough USB cable worked.

Big THANK YOU to all chdk devs for advices during the porting process and everyone who helped test the port so it's finally on the autobuild server!

*

Offline ahull

  • *****
  • 634
Re: A2200 IS porting thread
« Reply #459 on: 17 / November / 2012, 14:17:21 »
Great news, I'll grab a copy from the autobuild later today and run through the tests again.

Thanks to everyone involved.  :D

 

Related Topics