A2200 IS porting thread - page 48 - DryOS Development - CHDK Forum

A2200 IS porting thread

  • 515 Replies
  • 138331 Views
*

Offline reyalp

  • ******
  • 13432
Re: A2200 IS porting thread
« Reply #470 on: 30 / December / 2012, 01:31:23 »
Advertisements
Im not sure if Im liking the 'ALT' button on the play button. I seem to use the play button a lot more than I did the face select button.
In the current autobuild, the alt button should be adjustable. Face is one of the options.
Quote
Heres an example of a couple of RAW photos I took on this camera. They are attached.
Awww :D
Don't forget what the H stands for.

Re: A2200 IS porting thread
« Reply #471 on: 08 / February / 2013, 15:52:27 »
Hey guys, is there any way the intervalometer scripting could get sped up? I set it to take a pic every three seconds, but then it ends up taking about 8 seconds to take each sequential picture. Setting it to 1 second still makes it take 5 seconds.

I have the 100d alpha build.

Re: A2200 IS porting thread
« Reply #472 on: 08 / February / 2013, 16:07:20 »
Hey guys, is there any way the intervalometer scripting could get sped up? I set it to take a pic every three seconds, but then it ends up taking about 8 seconds to take each sequential picture. Setting it to 1 second still makes it take 5 seconds.  I have the 100d alpha build.
Do you perhaps have RAW / DNG enabled ?
Ported :   A1200    SD940   G10    Powershot N    G16

Re: A2200 IS porting thread
« Reply #473 on: 09 / February / 2013, 00:10:36 »
Do you perhaps have RAW / DNG enabled ?

Oh. I do. Disabling both brings it down to 2.5 seconds when set to a 0 second delay, which is perfect! Thanks.
« Last Edit: 09 / February / 2013, 00:28:39 by Zedtwitz »


Re: A2200 IS porting thread
« Reply #474 on: 09 / February / 2013, 00:33:14 »
Oh. I do. Disabling both brings it down to 2.5 seconds when set to a 0 second delay, which is perfect! Thanks.
I'm not going to try and help with this in two threads.  Please reply here : chdk.setepontos.com/index.php?topic=5051.msg96779#msg96779
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline a1ex

  • *****
  • 671
  • ML dev
Re: A2200 IS porting thread
« Reply #475 on: 07 / April / 2013, 18:21:18 »
Hi,

I've just got an A2200 100D for a friend and played a bit with it. Here's a small contribution for the CHDK port, which fixes:

- edge overlay after you take a picture
- zebra and histogram when the AF zoom box is active

Code: [Select]
void *vid_get_viewport_live_fb() {

// DIGIC mirror at 0x380000, EDMAC channel #4, register 0xC0F04408
void* y411_buffer_being_updated_by_edmac = (void*)(*(volatile int*)0x384408);

// note: y422 buffer is at EDMAC #0 (0xC0F04008), but CHDK seems designed for y411 only

// the same EDMAC channel is used for the little "magic zoom" box, which screws up our plans a bit
int buffer_size_flags = (void*)(*(volatile int*)0x384410);
int is_magic_zoom = ((buffer_size_flags & 0xFF0000) == 0x770000);

// it's a good idea not to use the buffer that is being updated, but a previous one, which was fully updated
static void* bufA = 0;
static void* bufB = 0;

// internally it's triple buffered, but we don't really care about all 3 buffers
// static void* bufC = 0;

if (bufA != y411_buffer_being_updated_by_edmac && !is_magic_zoom)
{
// bufC = bufB;
bufB = bufA;
bufA = y411_buffer_being_updated_by_edmac;
}

return bufB;
}

void *vid_get_viewport_fb() {
return vid_get_viewport_live_fb();
}

Enjoy!

*

Offline poussin

  • *
  • 36
  • A2200
Re: A2200 IS porting thread
« Reply #476 on: 19 / October / 2013, 04:47:49 »
Hello
I am using A2200 1.0D using the latest version of chdk.
I just uploaded on example of a faulty image.
http://dl.free.fr/hDNyKFPFD
the lines are always the same at the same position in the images
the luminosity seems to be an aggravating factor.
I noticed that the lines are curved , ( lens distortion ? ) and the object contours are very unsharp ( smear ) .
I am using the latest version of chdk.
It seems that the images before chdk tests were not so unsharp.
Does anybody has a clue of what happened ?
Thanks

*

Offline srsa_4c

  • ******
  • 4426
Re: A2200 IS porting thread
« Reply #477 on: 19 / October / 2013, 08:40:28 »
http://dl.free.fr/hDNyKFPFD
the lines are always the same at the same position in the images
the luminosity seems to be an aggravating factor.
I noticed that the lines are curved , ( lens distortion ? ) and the object contours are very unsharp ( smear ) .
Looks like hardware fault to me. The lines are curved because the camera corrects its jpeg images at wide angle (they will be straight if you shoot in raw/dng).
It could be that the external power supply fried something in the camera (assuming you weren't using batteries for scanning pages), but that's just a guess.


*

Offline ahull

  • *****
  • 634
Re: A2200 IS porting thread
« Reply #478 on: 19 / October / 2013, 09:01:40 »
If you are using an external adapter, it could also be interference from a poorly regulated supply. Try the same test using batteries.

*

Offline poussin

  • *
  • 36
  • A2200
Re: A2200 IS porting thread
« Reply #479 on: 19 / October / 2013, 10:54:13 »
If you are using an external adapter, it could also be interference from a poorly regulated supply. Try the same test using batteries.
Thanks
I am using batteries.
Also happens when USB cable is not connected.

 

Related Topics