Did I just ruin my SD850IS?? - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum supplierdeeply

Did I just ruin my SD850IS??

  • 4 Replies
  • 3338 Views
Did I just ruin my SD850IS??
« on: 31 / March / 2011, 09:12:44 »
Advertisements
I did the following:
(a) retrieved firmware 1.00c
(b) d/ll the CHDK .zip file from the wiki
(c) ran CardTricks - format then Make Bootable, then CHDK-> Card then move protection tab to write protect on SD card, then insert into camera, and turn camera on.

The result was the camera won't even power on.  I thought perhaps that coincidentally the battery died, so I fully recharged the battery and then tried again, but same thing - the camera won't turn on .  I took out the SD card, and tried to turn on without the card- nada, ditto I put a new SD card in , and turned on - nada.
OF course the camera was working fine moments before doing step (c)

Any ideas??

thx

*

Offline whim

  • ******
  • 2046
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: Did I just ruin my SD850IS??
« Reply #1 on: 31 / March / 2011, 10:08:43 »
Hi, welcome to the forum !

It's extremely unlikely that CHDK caused your cam to stop working, because
CHDK does not contain or call any code that writes to the camera firmware.

Try the following:

1) Remove the card from your camera and remove write-protect (to prevent CHDK autostart)
2) Remove battery and wait -say - a minute
3) Re-insert battery and card and retry - your cam should now start as if CHDK was not there.

hope that helps,

wim
    
PS If you can't get it to start normally, and you're sure your battery is OK, check and maybe clean
battery and camera electrical connectors ?

 

« Last Edit: 31 / March / 2011, 11:12:50 by whim »

Re: Did I just ruin my SD850IS??
« Reply #2 on: 31 / March / 2011, 11:18:01 »
Yep that fixed it.
Now how do I get CHDK on the camera?
Don't know what I'd do differently
(I tried reinsertint the SD card after movign the tab to write select and it froze the camera again - no power)

*

Offline reyalp

  • ******
  • 14086
Re: Did I just ruin my SD850IS??
« Reply #3 on: 31 / March / 2011, 12:41:21 »
Yep that fixed it.
Now how do I get CHDK on the camera?
Don't know what I'd do differently
(I tried reinsertint the SD card after movign the tab to write select and it froze the camera again - no power)
Just FYI, the reason you need to remove the battery is that when the camera looks like it didn't start, it actually did start, but crashed right away, before turning the LEDs on.

This kind of crash is usually caused by using the wrong CHDK build for your camera.

What is the canon firmware version of your camera ?
Are you sure you are using the SD850 build, not the ixus850 build ? These are not the same camera!
Don't forget what the H stands for.


Re: Did I just ruin my SD850IS??
« Reply #4 on: 31 / March / 2011, 14:17:21 »
d'oh! you're right!

thx!

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal