A650IS - must be doing something wrong - General Help and Assistance on using CHDK stable releases - CHDK Forum supplierdeeply

A650IS - must be doing something wrong

  • 26 Replies
  • 6141 Views
A650IS - must be doing something wrong
« on: 24 / February / 2008, 15:44:49 »
Advertisements
I format the 2GB SD card in the camera using Low-Level format.

Move it to USB reader on Mac.

From malbe.nm.ru/chdk/ download allbest-a650-100d-34.zip

Use unzip in terminal window to unzip -- produces only a DISKBOOT.BIN file, no PS.* file.

Copy DISKBOOT.BIN to card, put in camera -- no menu item

On the mac, execute touch PS.FI2

Back in camera, now have menu item but it produces "Update File Error!!!"

Try again with DISKBOOT from allbest-a650-100d-16.zip   (mentioned in another forum message)
This package contains PS.FIR file, which I copy to the SD card and rename PS.FI2

Still get the Update File Error!!!"  :(

What am I doing wrong?

(p. s. checking with the OS X Disk Utility, it says that the SD card is formatted MS DOS FAT 16.)

« Last Edit: 24 / February / 2008, 15:51:11 by thorby »

*

Offline BB

  • ***
  • 164
Re: A650IS - must be doing something wrong
« Reply #1 on: 24 / February / 2008, 16:07:33 »
Here is the Mac FAQ for loading CHDK on the SD Card...

http://chdk.wikia.com/wiki/FAQ/Mac

I don't remember if the A650 is a "Dry OS" or not--but if it is, the *.FIR file and manual load (put camera in "Play Back", turn on, <MENU>, and scroll down to "Upgrade Firmware" will not work (names and menu items are approximate--I have a A720 with "Dry OS" and Windows XP).

The only way to make a Dry OS based camera boot is through the Format FAT16, Make Disk Bootable, put the DISKBOOT.BIN file in the root card directly, and slide the SD Card switch to write protect.

From the Mac FAQ, there may be another Mac only issue that you need to address too...

-Bill
« Last Edit: 24 / February / 2008, 16:20:26 by BB »

Re: A650IS - must be doing something wrong
« Reply #2 on: 24 / February / 2008, 16:11:58 »
Yeah!

Re: A650IS - must be doing something wrong
« Reply #3 on: 24 / February / 2008, 16:12:23 »
Listen to what BB said!!!


Re: A650IS - must be doing something wrong
« Reply #4 on: 24 / February / 2008, 20:07:07 »
OK the MAC FAQ is all about Leopard (10.5) which I am not using, still on Tiger (10.4); and it is about unpacking a zip using the system's built-in archiver. Having read it previously, I did not do that but unpacked the different zips using an open-source unzip program in a console window.

However what made the difference was making the SD card bootable. This I did in a virtual Windows XP system, following the dirction in Bootable SD card - CHDK Wiki (2nd version).

Now when switching from view mode to camera the Allbest splash appears for about 1/2 second, and a battery-level icon is visible. So, good to go.

Thanks.

Re: A650IS - must be doing something wrong
« Reply #5 on: 02 / March / 2008, 17:01:13 »
yeah your problem is that you need to make the card bootable, i had the same problem until i did that

Re: A650IS - must be doing something wrong
« Reply #6 on: 20 / March / 2008, 19:04:39 »
Can anyone help me make my card bootable? I didn't want to make a new topic, you guys get enough of these I figure, right? if you'd rather me start one though I'll do that. its just I have the same problem as thorby here up untill he found the solution

I tried using the bootable exe but no dice. the cmd window only pops up for like a millisecond and goes away before I can even read it.  Ive been wanting to use the CHDK on my A650 IS for a long time now but cant get it working yet.

Ive tried the other method as well, but I know nothing about hex editors so that was just too frustrating.
« Last Edit: 21 / March / 2008, 04:46:44 by Kyle »

*

Offline rchoi999

  • *
  • 17
  • A650is
Re: A650IS - must be doing something wrong
« Reply #7 on: 20 / March / 2008, 20:47:24 »


Re: A650IS - must be doing something wrong
« Reply #8 on: 20 / March / 2008, 23:27:39 »
I know that. when I attempt to switch drives by typing "I" (that's the card's drive's name for me) and hit enter it tells me its not recongnised as internal or external command operable program or batch file.  I never get to the prompt about the syntax.
« Last Edit: 20 / March / 2008, 23:32:35 by Kyle »

*

Offline GrAnd

  • ****
  • 916
  • [A610, S3IS]
    • CHDK
Re: A650IS - must be doing something wrong
« Reply #9 on: 21 / March / 2008, 02:27:15 »
CHDK Developer.

 

Related Topics