supplierdeeply

ptpcam gui

  • 95 Replies
  • 32166 Views
*

Offline msl

  • *****
  • 1237
  • A720 IS, SX220 HS 1.01a
    • CHDK inside
Re: ptpcam gui
« Reply #10 on: 30 / April / 2011, 15:57:10 »
Advertisements
Too bad that I can't download it. Server times out EVERY time.
Ok, it seems to be a local problem with your internet connection.

I've added an alternative source for download (box.net) in reply #6.

msl
German CHDK pages:  CHDK forum | CHDK inside | CHDK Twitter News by msl | Download CHDK-DE (Autobuild)
Note: SDM violates the GPL rules!

Re: ptpcam gui
« Reply #11 on: 30 / April / 2011, 21:11:48 »
It's actually a slow connection problem. I have 3 different ISPs that call out through 4 different networks (dialup number dependent). None of them are faster than 1.9k download speeds where I live. If a server says that file should get there in under 1 minute, and it takes 10 minutes, it assumes its a bad download and cuts it off. This happens lots of places on the net now. I can't even download the CHDK PDF manual from the CHDK Wiki because it times it out before its done downloading. Nobody cares about dialup users anymore. And they do everything in their power to make dialup users not able to access their sites or obtain any files. Don't bother telling me to get highspeed. I've already filed complaints with the Communications Commision for ten years now and nothing will be done to change anything. There aren't enough people living where I do to make it financially viable to get highspeed connections, so they never will. The next time that MSN or some other company demands that I download a 180 meg upgrade file for something, they know where they can shove it.  :lol

Thanks for the file. I hope this one works.

Re: ptpcam gui
« Reply #12 on: 30 / April / 2011, 21:36:37 »
Looks like I'll have to wait for V3. All I get is an error box that pops up saying:

ptpCamGui 2.0.97 - Error
Different Versions: Current (supported)
ptpcam: 1.0 (2.0)
camera: 1.0 (2.0)


[edit]
Nevermind, I see that the ptp protocol was updated in revsion 1155 on the trunk-log. Downloading a new CHDK now.... (if it gets here).

[edit2]
Well, that was no fun. Now all I get is:

ptpCamGui 2.0.97 - Error
Different Versions: Current (supported)
ptpcam: 1.0 (2.0)

[edit3]
After reading google translations of the German forum I find that this is caused by overwriting the old files with the new. You have to install v2x into a new folder.

Now I'm back at square one, all I get are continual strings of (ignore typos, typed these by hand from reading the little console box, it no longer allows you to copy from it):

>> luar get_model() << script:65
65:ret:false (Length: 23)
>> luar get_model() << script:66
66:ret:false (Length: 23)
>> luar get_model() << script:67
67:ret:false (Length: 23)
>> luar get_model() << script:68
68:ret:false (Length: 23)

Etc.

I think I'm done testing this, nothing's changed, nothing works, and there's too little information to get past all the problems with trying to get it to work.

« Last Edit: 30 / April / 2011, 22:22:51 by NewbieToobie »

*

Offline rudi

  • ***
  • 123
  • A590IS_101B, SX260HS_100B
Re: ptpcam gui
« Reply #13 on: 01 / May / 2011, 07:06:39 »
Hi NewbieToobie,

some questions:
- Which camara, CHDK-build and revision do you used for test?
- Get you "** init() successful" after startup camera?
- Which command do you start to get this message loop?

rudi


Re: ptpcam gui
« Reply #14 on: 01 / May / 2011, 13:53:38 »
Using: s3is-100a-0.9.9-1161-full.zip

I get a successful init sequence. Ending in: "** init() successful"

I can also download images from the camera, same as last time. I get those endless loops of errors if I click on either of the two red camera function buttons at the top of the GUI panel. I only get one line of error returned if I click on the blue or green button.

(annoying that I can't copy text from the console window, makes sharing error messages difficult)


*

Offline rudi

  • ***
  • 123
  • A590IS_101B, SX260HS_100B
Re: ptpcam gui
« Reply #15 on: 01 / May / 2011, 15:52:58 »
try this on ptpcam console:
Code: [Select]
luar get_mode()    // ret:false -> play mode
mode 1                // switch to rec mode
luar get_mode()   // ret:true -> rec mode
If returned "ret:false" on 3rd command, then you can't use the group "Camera Mode". I don't know if the play/record mode switching works on S3.

(annoying that I can't copy text from the console window, makes sharing error messages difficult)
Use the right mouse button on debug edit "select all" and "copy". You can't see any selection.

rudi

Re: ptpcam gui
« Reply #16 on: 01 / May / 2011, 16:15:18 »
Looks like it's broken then. And I presume, is also broken on all other VxWorks cameras.

Code: [Select]
** init() start ...
>> version << ptpcam: 2.0
camera: 2.0 (Length: 24)
>> script-support << script-support:0x1 lua=yes (Length: 26)
>> luar not(os.stat("A/CHDK/LUALIB/lptpgui.lua")==nil) << script:8
8:ret:true (Length: 20)
>> luar require("lptpgui").version << script:9
9:ret:97 (61) (Length: 23)
>> luar get_buildinfo() << script:10
10:ret:'platformid 12570
platform s3is
version CHDK
platsub 100a
build_number 0.9.9-1161
os vxworks
build_date Apr 30 2011
build_time 04:08:10
' (Length: 163)
is DryOS=False
CHDK-DE=False
>> luar get_raw() << script:11
11:ret:0 (0) (Length: 23)
>> help << q quit                         quit program
h help                         list commands
r reset                        reconnect to camera
  version                      get CHDK PTP version (ptpcam and camera)
  shutdown                     shutdown camera (soft)
  reboot                       reboot camera
  reboot <filename>            reboot camera using specified firmware update
  reboot-fi2                   reboot camera using default firmware update
m memory <address>             get byte at address
m memory <address>-<address>   get bytes at given range
m memory <address> <num>       get num bytes at given address
  set <address> <long>         set long value at address
c call <address> <arg1> ...    call function at address with given arguments
  upload <local> <remote>      upload local file to camera
  download <remote> <local>    download file from camera
  mode <val>                   set mode (0=playback,1=record)
  lua <code>                   execute lua code
  luar <code>                  execute "return <code>" and retreive result
  script-support               show supported script interfaces
  script-status                show script execution and message status
  getm                         get messages / return values from script
  putm <message>               send <message> to running script (Length: 1359)
** init() successful
>> luar get_mode() << script:12
12:ret:false (Length: 23)
>> mode 1 << script:13 (Length: 9)
>> script-status << script-status:0x0 run=no msg=no (Length: 31)
>> luar get_mode() << script:14
14:ret:false (Length: 23)

*

Online reyalp

  • ******
  • 11487
Re: ptpcam gui
« Reply #17 on: 01 / May / 2011, 16:17:29 »
Looks like it's broken then. And I presume, is also broken on all other VxWorks cameras.
Works fine on a540, more likely it's just broken on s3.
Don't forget what the H stands for.


Re: ptpcam gui
« Reply #18 on: 06 / May / 2011, 21:01:11 »
A new version of ptpCamGui is available....


Hi, where might I locate sources to compile ptpCam for Linux (Ubuntu)? I realise the GUI may not work but the console would be cool to test out. Thank you.

*

Online reyalp

  • ******
  • 11487
Re: ptpcam gui
« Reply #19 on: 06 / May / 2011, 23:27:13 »
A new version of ptpCamGui is available....


Hi, where might I locate sources to compile ptpCam for Linux (Ubuntu)? I realise the GUI may not work but the console would be cool to test out. Thank you.
You can get the sources from http://tools.assembla.com/chdkde/browser/trunk/tools/ptpcam

You might also be interested in http://chdk.setepontos.com/index.php?topic=6231.0 which has a marginal working gui on linux already, but is in a very early stage of development.
Don't forget what the H stands for.

 

Related Topics