CHDK on sd without write lock? - General Help and Assistance on using CHDK stable releases - CHDK Forum

CHDK on sd without write lock?

  • 1 Replies
CHDK on sd without write lock?
« on: 12 / April / 2011, 17:49:47 »

i have bought a Canon SX10 from Ebay. I'm very happy with it, but the write lock is defect- every card can be written no "Card lock" error like my old Powershot A560.

So I tried to install CHDK but it doesn't work because of the missing write lock. Is it possible to load CHDK without writelock when starting the camera?

If not- I tried the manual method mentioned in the tutorial. Only one time I saw the "firmware update" button- and CHDK loaded. But after that the button isn't available anymore- What I'm doing wrong?

Edit: I've read that its not possible without writelock to autoload. Does this camera have a lock which is activated when contact is shorten or open?

Thanks in advance,
« Last Edit: 12 / April / 2011, 17:51:39 by MyCanon99 »


Offline reyalp

  • ******
  • 13838
Re: CHDK on sd without write lock?
« Reply #1 on: 12 / April / 2011, 22:35:03 »
Some other people have had this problem (on the SX10 specifically), and fixed it by fiddling with the write lock switch in the camera:,3374.0.html

Regarding the firm update option:
- if you are using a multi-partition card, and have the PS.FI2 only on one partition, you won't see it after they are swapped
- if you don't start in play mode, you probably don't get the firm update option, even if you switch from record back to play.
Don't forget what the H stands for.


Related Topics