Intervelometer for SX200 questions... - page 2 - Script Writing - CHDK Forum supplierdeeply

Intervelometer for SX200 questions...

  • 18 Replies
  • 6204 Views
Re: Intervelometer for SX200 questions...
« Reply #10 on: 19 / April / 2011, 15:24:18 »
Advertisements
Adding the delay to the wait steps resolved my problem, thanks.

Re: Intervelometer for SX200 questions...
« Reply #11 on: 19 / April / 2011, 15:45:21 »
Interesting... I'm still using a CHDK build from January 2011 that I used when I created the script.
If it has changed, the change should be much older than that. There was a thread about this a while back, but I can't seem to find it. I'd be tempted to make wait_click without a number wait indefinitely, but some scripts would probably break...

if all the keys in your camera were known, then your script would "work" the loop would just run very quickly.
I didn't press any keys at all when the script stared, it began looping immediately and saying Invalid Key. 

Re: Intervelometer for SX200 questions...
« Reply #12 on: 19 / April / 2011, 17:04:03 »
Follow-up question:
Can chdk be tethered to a PC and save files on the PC?
Or can the canon's be remote controlled with files saved on the PC?

*

Offline SkyWalker9

  • ****
  • 301
  • SX20 IS (fw 1.02b)
Re: Intervelometer for SX200 questions...
« Reply #13 on: 19 / April / 2011, 17:05:57 »
Adding the delay to the wait steps resolved my problem, thanks.
Could you tell me the amount of delay you used that seemed to work the best? I'd like to pass along what is a good number to use when I add my update comments to other postings? Thanks for the feedback.

Quote from: reyalp
If it has changed, the change should be much older than that. There was a thread about this a while back, but I can't seem to find it.
I wonder if it might be more camera/FW dependent since I've never experienced the problem using it as coded.
Quote
I'd be tempted to make wait_click without a number wait indefinitely, but some scripts would probably break...
Probably not indefintely, but maybe use a default amount of maybe 1000 or 5000 millisecs. That probably wouldn't affect many scripts. Regardless, I'll code the wait_click statements with timeouts in the future just to avoid problems for other CHDK users. The CHDK Users Manual has some mention of the timeout, but probably should have a cautionary comment when no timeout specified.
« Last Edit: 19 / April / 2011, 17:08:32 by SkyWalker9 »


Re: Intervelometer for SX200 questions...
« Reply #14 on: 19 / April / 2011, 17:38:20 »
I used 10000 (10s) so that I could pause to think (enough time to think while drunk) though I imagine any reasonable number would work.

wait_click defaulting to 0 seems silly to me.  I can't imagine any scenario you would want to wait 0.000 seconds for human interaction.

If you cannot tether to a PC and have the files saved on a PC, my backup method was to buy an eye-fi pro card with unlimited storage mode.

Re: Intervelometer for SX200 questions...
« Reply #15 on: 19 / April / 2011, 17:44:07 »
Does anyone know what the default behavior is when the image counter hits 9999?  At one pic every other second that's after 5 hours of shooting.

*

Offline SkyWalker9

  • ****
  • 301
  • SX20 IS (fw 1.02b)
Re: Intervelometer for SX200 questions...
« Reply #16 on: 20 / April / 2011, 15:06:17 »

Re: Intervelometer for SX200 questions...
« Reply #17 on: 21 / April / 2011, 13:13:15 »
So I set the camera to record image size M3 (a tad bigger than HD) and after 142 images (300k each) or about 50 megs total the camera stops taking pictures and reports my card is full (2gb)

I assume it has something to do with the write protect tab enabled on the SD card?


*

Offline SkyWalker9

  • ****
  • 301
  • SX20 IS (fw 1.02b)
Re: Intervelometer for SX200 questions...
« Reply #18 on: 21 / April / 2011, 13:43:49 »
So I set the camera to record image size M3 (a tad bigger than HD) and after 142 images (300k each) or about 50 megs total the camera stops taking pictures and reports my card is full (2gb)

I assume it has something to do with the write protect tab enabled on the SD card?

Do you by chance have the RAW option set? I don't know the size of the DNG/CRW or CR2 files your camera creates, but on my SX20 they are around 18M each and CHDK creates both RAW & JPG photos for each shot. The RAW & JPGs are placed in different image folders on your SD card, both in the DCIM folder. For example, using the size of my RAW & JPG images, I could fit 87 shots on a 2G SD card. I'd check that first.

 

Related Topics