ELPH300HS aka IXUS220HS - Porting Thread - page 13 - DryOS Development - CHDK Forum  

ELPH300HS aka IXUS220HS - Porting Thread

  • 899 Replies
  • 389525 Views
*

Offline sush

  • *
  • 29
  • ixus220 300hs firmware 1.01c
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #120 on: 18 / November / 2011, 21:02:48 »
Advertisements
I was just about to edit my post above -

I see the reason why things went haywire after looking at the log:

>> Entering to platform/ixus220_elph300hs/sub/101c
-> stubs_entry.S
Segmentation fault
stubs_entry.S -> stubs_entry.o
stubs_entry_2.S -> stubs_entry_2.o

A seg fault occurred but it kept going.  Now, I need to figure out why it seg faulted!

Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #121 on: 18 / November / 2011, 21:31:09 »
- dumped the camera firmware.  I believe I have 1.01c since the exif in the jpgs says 1.01 revision 3.00
I don't think this version has been posted yet.  Can you post it here : Firmware dumps available
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline sush

  • *
  • 29
  • ixus220 300hs firmware 1.01c
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #122 on: 18 / November / 2011, 21:45:33 »
done! posted the firmware.

101c:

http://www.box.com/s/7prmv1zst2a3y3iizo5n
« Last Edit: 18 / November / 2011, 21:48:36 by sush »

Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #123 on: 18 / November / 2011, 22:04:24 »
done! posted the firmware.
What start address did the Canon BASIC script report ?  ( FFC00000, FF810000, FF000000) ?
Ported :   A1200    SD940   G10    Powershot N    G16


*

Offline sush

  • *
  • 29
  • ixus220 300hs firmware 1.01c
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #124 on: 18 / November / 2011, 22:11:39 »

Quote
What start address did the Canon BASIC script report ?  ( FFC00000, FF810000, FF000000) ?

is this something that is displayed on the screen?  Because due to the black screen I can't see anything.

*

Offline philmoz

  • *****
  • 3450
    • Photos
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #125 on: 18 / November / 2011, 22:22:30 »

A seg fault occurred but it kept going.  Now, I need to figure out why it seg faulted!


Most likely the ROMBASEADDR in makefile.inc is wrong.
If you copied the SX220HS it will be set to 0xFF000000; but your firmware dump is only 8MB so should be 0xFF810000.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

*

Offline sush

  • *
  • 29
  • ixus220 300hs firmware 1.01c
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #126 on: 18 / November / 2011, 22:31:02 »
You are correct about the base address.  I added some change colour code to extend.m and could see it.

I will try to modify the makefile and see what happens.

Thanks for your help!

Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #127 on: 18 / November / 2011, 22:31:36 »
is this something that is displayed on the screen?  Because due to the black screen I can't see anything.
Darn - I knew that would bite me at some point.  My version of the Canon Basic dumper script included a line to set the text color - for just this reason.  It varies from camera to camera so reyalp did not include something similiar in his version. 

Ported :   A1200    SD940   G10    Powershot N    G16


*

Offline sush

  • *
  • 29
  • ixus220 300hs firmware 1.01c
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #128 on: 19 / November / 2011, 01:46:30 »
The seg fault is gone but the stubs_entry.S is still blank.   

On another note, I find it curious that camera constants are hard-coded inside of core/kbd.c
If I change the define CAMERA_sx220hs in platform_camera.h, this of course causes compilation issues in kbd.c
I don't quite think it would be good practice for me to change kbd.c but what is the alternative for adding a new camera type?

thanks.
 
« Last Edit: 19 / November / 2011, 01:55:49 by sush »

*

Offline philmoz

  • *****
  • 3450
    • Photos
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #129 on: 19 / November / 2011, 01:57:42 »

The seg fault is gone but the stubs_entry.S is still blank.   

On another note, I find it curious that camera constants are hard-coded inside of core/kbd.c
If I change the define CAMERA_sx220hs in platform.h, this of course causes compilation issues in kbd.c
I don't quite think it would be good practice for me to change kbd.c but what is the alternative for adding a new camera type?

thanks.
 

Try deleting the empty stubs_entry.S file to force it to be recreated.

The CAMERA_??? define is created automatically from your PLATFORM - you need to use this in various files (e.g. core/kbd.c) to set up camera specific stuff. Ideally everything specific to the camera should be in the platform files; but there are a few things that are still sprinkled across the core source files.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

 

Related Topics