ELPH300HS aka IXUS220HS - Porting Thread

  • 836 Replies
  • 102920 Views
  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #670 on: 24 / February / 2012, 16:32:20 »
    Advertisements
    Hi,
    I was able to successfully create badpixel.bin and take raw files.  (See above for my unfortunate wasting of Phil's time).
    Jon


    Hi Jon,
    Not sure to understand, but in my case I also succedded to create the DNG. The issue I have is that I still have the bad pixels in the DNG when I open it in Lightroom and the same image in Jpeg is totally clean...
    Thanks again.


    Are you talking about bad pixels or noise?
    Post a 100% crop from a sample image showing the problem.

    Phil.

    Hi Phil,
    I am talking about bad pixels. Here is a crop of the DNG and JPEG. Photo was taken at 100 iso.

    *

    Offline philmoz

    • *****
    • 2936
      • Photos
  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #671 on: 24 / February / 2012, 17:04:04 »

    Hi Phil,
    I am talking about bad pixels. Here is a crop of the DNG and JPEG. Photo was taken at 100 iso.

    Set the camera to the highest ISO, zoom to the max optical telephoto position and try creating the badpixel file again.

    If that still doesn't work, upload the DNG and badpixel.bin file to a file share and post the link here.

    Phil.
    CHDK ports:
      sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
      g12 (1.00c, 1.00e, 1.00f & 1.00g)
      sx130is (1.01d & 1.01f)
      ixus310hs (1.00a & 1.01a)
      sx40hs (1.00d, 1.00g & 1.00i)
      g1x (1.00e, 1.00f & 1.00g)

    *

    Offline ray

    • *
    • 1
  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #672 on: 25 / February / 2012, 08:42:41 »
    "Minority bug report"

    Hi,
    first of all thank you for the great work you are doing. i`m using an older ixus with chdk for years now and it works fabulous, especially the autoiso-function. i recommended the elph300hs to a friend of mine and because his son can`t stand still for a 1/60th of a second i installed your alpha-version of chdk but enabling the auto-iso function will lead to a systemcrash (vers. 101a-1.0.0-1659-full_ALPHA).
    Just for the bug-collection... maybe someone of you is willing and has got the muse to have a look at it...

    thank you all..
    ray

  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #673 on: 25 / February / 2012, 09:04:51 »

    Hi Phil,
    I am talking about bad pixels. Here is a crop of the DNG and JPEG. Photo was taken at 100 iso.

    Set the camera to the highest ISO, zoom to the max optical telephoto position and try creating the badpixel file again.

    If that still doesn't work, upload the DNG and badpixel.bin file to a file share and post the link here.

    Phil.

    Hi Phil,
    Still same issue. I tried to create the badpixel.bin in the dark but also in normal conditions but still badpixels in DNG... I posted the badpixels file, the DNG and JPEG here:
    http://aesparza.free.fr/issue%20elph%20300%20chdk/
    Thank you for your help.
    David


    *

    Offline srsa_4c

    • ******
    • 3136
  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #674 on: 25 / February / 2012, 19:00:40 »
    out of curiosity did you inspect code visually
    :) /usr/bin/patch failed on boot.c, had to use a visual comparison tool
    Quote
    or you just did some regexp magic? if that's the case, i should really learn how to master them, oh well.. :)
    I usually use some regexp's when formatting code, but only in an editor :)

    Thanks for the feedback. You may hack on that kbd.c when you're bored.  :D

    *

    Offline philmoz

    • *****
    • 2936
      • Photos
  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #675 on: 25 / February / 2012, 19:06:56 »
    Still same issue. I tried to create the badpixel.bin in the dark but also in normal conditions but still badpixels in DNG... I posted the badpixels file, the DNG and JPEG here:
    http://aesparza.free.fr/issue%20elph%20300%20chdk/

    Thanks for the files.

    It looks like these bad pixels have a value > 0 - the current code assumes all bad pixels will have a value of 0 in the raw sensor data.

    Let me know which firmware version you have and I'll post a test version to try.

    Phil.
    CHDK ports:
      sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
      g12 (1.00c, 1.00e, 1.00f & 1.00g)
      sx130is (1.01d & 1.01f)
      ixus310hs (1.00a & 1.01a)
      sx40hs (1.00d, 1.00g & 1.00i)
      g1x (1.00e, 1.00f & 1.00g)

  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #676 on: 26 / February / 2012, 02:29:31 »
    Hi Phil,
    The firmware version is 101g (checked with your ExifTool).
    I can not use the Func/Disp option to get the real firmware like explained in the wiki....
    Thanks.
    David

    *

    Offline philmoz

    • *****
    • 2936
      • Photos
  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #677 on: 26 / February / 2012, 02:49:06 »
    Hi Phil,
    The firmware version is 101g (checked with your ExifTool).
    I can not use the Func/Disp option to get the real firmware like explained in the wiki....
    Thanks.
    David

    Try this version.

    Phil.
    CHDK ports:
      sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
      g12 (1.00c, 1.00e, 1.00f & 1.00g)
      sx130is (1.01d & 1.01f)
      ixus310hs (1.00a & 1.01a)
      sx40hs (1.00d, 1.00g & 1.00i)
      g1x (1.00e, 1.00f & 1.00g)


  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #678 on: 26 / February / 2012, 03:17:04 »
    Hi Phil,
    The firmware version is 101g (checked with your ExifTool).
    I can not use the Func/Disp option to get the real firmware like explained in the wiki....
    Thanks.
    David

    Try this version.

    Phil.

    Hi Phil,
    Just tried and now it is fine with the DNG.  :)
    Thanks.
    David

    *

    Offline philmoz

    • *****
    • 2936
      • Photos
  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #679 on: 26 / February / 2012, 04:21:07 »
    Hi Phil,
    Just tried and now it is fine with the DNG.  :)
    Thanks.
    David

    I've added the fix to the SVN repository. It should be in the autobuild version in a little while.

    Phil.
    CHDK ports:
      sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
      g12 (1.00c, 1.00e, 1.00f & 1.00g)
      sx130is (1.01d & 1.01f)
      ixus310hs (1.00a & 1.01a)
      sx40hs (1.00d, 1.00g & 1.00i)
      g1x (1.00e, 1.00f & 1.00g)

     

    Related Topics