ELPH300HS aka IXUS220HS - Porting Thread - page 85 - DryOS Development - CHDK Forum supplierdeeply

ELPH300HS aka IXUS220HS - Porting Thread

  • 898 Replies
  • 317020 Views
*

Offline nafraf

  • *****
  • 1308
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #840 on: 14 / September / 2017, 23:44:18 »
Advertisements
Hi,
A test version in attachments.

The capt_seq.c is based on ixus310 code.

*

Offline sush

  • *
  • 29
  • ixus220 300hs firmware 1.01c
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #841 on: 15 / September / 2017, 18:55:39 »
Thank you for the test file.    Not sure what I need to do with the patch file - I assume it is already incorporated into the test chdk code.


I am trying to get to DNG 1.1, but I need to create the bad pixel file first.   When I try to create that bad pixel file, it  fails every time.  Or, loops over and over. 


So I forget trying to set dng 1.1  and leave it at DNG 1.3  - that is unfortunate.


Then I tried long exposure without timer or intervalometer:


- dark frame off - no noise reduction occurs - good!
- dark frame on - noise reduction occurs  - good!


Then I tried long exposure with timer or intervalometer:


- dark frame off - no noise reduction occurs - good!
- dark frame on - noise reduction occurs! - ***very good!***


I will try again to see if I can generate a badpixel file so that I can use DNG 1.1


This is definitely good progress - Thanks!




note - tried again to create that badpixel file and failed.




 




*

Offline reyalp

  • ******
  • 13401
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #842 on: 15 / September / 2017, 23:12:00 »
Thank you for the test file.    Not sure what I need to do with the patch file - I assume it is already incorporated into the test chdk code.
Yes, the patch is for other developers to look at if they want.

I would be surprised if these changes made badpixel.bin generation fail, but you could try going back to the autobuild to test. badpixel.bin generation failing somewhat randomly on some cameras is an issue that has been around for a long time. It's possible you will have more luck if you take a few shots manually first to let the sensor temperature stabilize a bit.
Don't forget what the H stands for.

*

Offline sush

  • *
  • 29
  • ixus220 300hs firmware 1.01c
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #843 on: 15 / September / 2017, 23:37:14 »



Went back and loaded the autobuild - no problems creating the badpixel file.


Loaded the new test version again - can't build the badpixel file.   The script itself seems to behave differently (erroneously)





*

Offline reyalp

  • ******
  • 13401
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #844 on: 16 / September / 2017, 16:25:38 »
Went back and loaded the autobuild - no problems creating the badpixel file.
Interesting. Can you report the free memory value shown by "Miscellaneious->Show Memory Info" for both builds.

Quote
Loaded the new test version again - can't build the badpixel file.   The script itself seems to behave differently (erroneously)
Are you running a script, or using the built in badpixel.bin creation option in the raw menu? The script is obsolete and should not be used.

What is the output when you try to create badpixel.bin? If it disappears too quickly, you can see it in
"Miscellaneous->Console->Display last console"

When it succeeds, it should show the number of badpixels. It would be helpful to know that, as well as the output in the case it doesn't work.
Don't forget what the H stands for.

*

Offline sush

  • *
  • 29
  • ixus220 300hs firmware 1.01c
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #845 on: 17 / September / 2017, 18:52:58 »
Under the Raw menu, I am using 'Create badpixel.bin'


-----
For the test code:

Free Memory: 608824 bytes
CHDK size: 134404 bytes
loaded at: 0x1774ec

Under Console:
Wait please...
This takes a few seconds,
don't panic!
badpixel.bin failed
Please try again

------

For the autobuild:

Free Memory: 581040 bytes
CHDK size: 133748 bytes
loaded at: 0x1774ec

Under Console:
Wait please...
This takes a few seconds,
don't panic!
badpixel.bin created
Bad pixel count: 11417
-----


*

Offline nafraf

  • *****
  • 1308
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #846 on: 20 / September / 2017, 00:05:13 »
Hi, I forgot to patch boot.c, new patch and test version.
Please test and report.



*

Offline nafraf

  • *****
  • 1308
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #847 on: 20 / September / 2017, 00:38:14 »
Hi, a new test file (version 3), this time boot.c was rewritten using code_gen.c to use the patch in other firmware versions.
Please test and report.


*

Offline sush

  • *
  • 29
  • ixus220 300hs firmware 1.01c
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #848 on: 21 / September / 2017, 23:52:19 »
Thanks for the new version.   I tested version 3 - and there are some issues:


I can create the bad pixel file - which is good
However, once again dark frame noise reduction on long exposures fails when the timer is used - this is bad.


Correction - it fails when dfnr is set to 'auto' and timer is used.  (even though dfnr occurs when timer is not used)
So, I can force the dfnr to occur by setting the mode to 'on' but 'auto' doesn't do it.
Not a huge issue, just a little strange.




« Last Edit: 21 / September / 2017, 23:58:05 by sush »

*

Offline nafraf

  • *****
  • 1308
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #849 on: 22 / September / 2017, 23:39:58 »
Hi, new version. task_DvlpSeqTask removed.

 

Related Topics