supplierdeeply

ELPH300HS aka IXUS220HS - Porting Thread

  • 836 Replies
  • 101979 Views
  • Publish
    ELPH300HS aka IXUS220HS - Porting Thread
    « on: 28 / April / 2011, 16:33:23 »
    Advertisements
    Hi all,

    I would like to start  porting CHDK to ELP300HS also known as IXUS220HS in Europe.

    whim and fe50 dumped the firmware at

    http://www.box.net/chdk  ->  ixus220hs_elph300hs_100c.7z

    and created

    http://chdk.wikia.com/wiki/ELPH300

    My IXUS220HS has same Version

    "100C"

    and the camera identifier

    "0x3040000"

    which is displayed in CameraVersion1.3 as "Unknown".

    ...have fun...

    Michi

  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #1 on: 28 / April / 2011, 17:59:14 »
    I tried to verify the standard procedures of CHDK development on my IXUS220HS and failed completely!?

    1. I tried to format and use a "ver.req" FAT16 SD with 2GB.
        -> No success pressing SET & DISPLAY, which is even a pain on this little camera with huge fingers ;)

    2. I tried the same using CardTricks
        -> No success

    3. I tried to format a dump disk with CardTricks
        -> No success

    I've no idea where my error is...may the SET/DISPLAY keys are not the correct ones on my the 220HS?

    ...have fun...

    Michi

    *

    Offline whim

    • ******
    • 2013
    • A495/590/620/630 ixus70/115/220/230/300/870 S95
  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #2 on: 28 / April / 2011, 18:33:43 »
    Hi michi,

    Some newer cams simply won't react to ver.req, but why do you need that ?
    You already know your version, don't you ?

    Now you will need to dump your firmware, you must use the Canon Basic scripts (attached)

    How to use:

    1. Start by formatting your card in the camera (save your pictures first !)

    2. Copy the 2 tiny files to the ROOT of your card

    3. Write the special "SCRIPT" signature to the boot sector
        To do this, use Pelican's EOScard
      
    --- now put card back in camera

    4. Start the cam in review mode (with the 'triangle' button, not on/off !)

    5. A normal, short press of "Func/Set" starts the script: watch top left corner.

    hope that helps,

    wim

    PS About CameraVersion: update exiftool to 8.5.6 to see the real name

    [edited 30-04-11: it helps if instructions actually work ...]
    « Last Edit: 30 / April / 2011, 05:47:14 by whim »

  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #3 on: 28 / April / 2011, 20:28:18 »
    Hi wim,

    indeed I don't "need" it...
    ...I got the version from the JPEG with your tool...
    ...it was just a try to warm up the communication with the camera!

    Same for the dump...I will try your steps next evening...its too late for me tonight...

    Thx for your help, it is very welcome...

    Michi


    *

    Offline funnel

    • ****
    • 349
  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #4 on: 29 / April / 2011, 02:50:42 »
    For the sx220 this is what I needed to do see the version:
    -turn on camera in with PLAY button
    -hold FUNC/SET until the clock appears
    -hold FUNC/SET until the clock disappears, still hold and press DISP.

    To run scripts:
    -delete all photos from card
    -turn on camera in with PLAY button
    -press FUNC/SET


    « Last Edit: 29 / April / 2011, 02:53:30 by funnel »

  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #5 on: 29 / April / 2011, 18:10:14 »
    For the sx220 this is what I needed to do see the version:
    -turn on camera in with PLAY button
    -hold FUNC/SET until the clock appears
    -hold FUNC/SET until the clock disappears, still hold and press DISP.

    Hmmmh,,,,does not work in my IXUS220HS !?

    May be that Canon has choosen different hotkeys because it is very hard to press SET and DISP simultaneously on the IXUS220HS.

    ...have fun...

    Michi


  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #6 on: 29 / April / 2011, 18:15:06 »
    PS About CameraVersion: update exiftool to 8.5.6 to see the real name
    Great, that does the job.

    thx...

    Michi

  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #7 on: 30 / April / 2011, 04:26:41 »

    Now you will need to dump your firmware, you must use the Canon Basic scripts (attached)

    How to use:

    1. Copy the 2 tiny files to the ROOT of your card

    2. Write the special "SCRIPT" signature to the boot sector
        To do this, use Pelican's EOScard
      
    --- now put card back in camera

    3. Photograph something really white (this is optional, Canon Basic has a tendency to pick
       weird colours for text, white gives you probably the best chance to read any output ....)

    4. If you did take a picture, shut down the cam.

    5. Start the cam in review (not shooting mode); select (if necessary) the white pic.

    6. Press "Func/Set" to start the script.

    hope that helps,

    wim

    PS About CameraVersion: update exiftool to 8.5.6 to see the real name

    Hi wim,

    I am doing something wrong running the scripts!?

    Following your procedure, I can not get running the script on my cam!

    Pressing the FUNC./SET Button displays a cube-digit-clock, but I've no indication that a script is started!?

    No dump files on the card. no display indication...nothing.

    Except the dump files...should there be a notification of a started script (LED, Display whatever?).
    I looked into the basic script and saw that some text messages should be displayed!?


    Maybe the script itself does not work on my cam?

    You dumped the FW for the IXUS220HS already...how did you do that?

    ...have fun...

    Michi
    « Last Edit: 30 / April / 2011, 05:55:27 by michi1911 »


    *

    Offline whim

    • ******
    • 2013
    • A495/590/620/630 ixus70/115/220/230/300/870 S95
  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #8 on: 30 / April / 2011, 05:59:15 »
    Sorry Michi,

    I seem to have remembered wrongly how I dumped it, turns out there should be
    no pictures on the card, or it won't work ... Move the 'DCIM' folder (temporarily)
    somewhere else, and it should work, just tried.

    On start-up in Review/play mode the screen will be black with a white edge and it'll say 'No image',
    just give a short press on Func/set (i.e. no need to hold it) and watch the top left corner.
    Start address (8 characters) will be written there, but since it's in black, it's unreadable.
    Never mind though, when it's ready (a couple off seconds) it'll change to "done".
    You can tell because the string written now is shorter. When you now check your
    card, you should find your dump as "PRIMARY.BIN" .

    sorry for the confusion,

    wim

    PS edited my previous post so as not to confuse even more people
    « Last Edit: 30 / April / 2011, 06:03:15 by whim »

  • Publish
    Re: ELPH300HS aka IXUS220HS - Porting Thread
    « Reply #9 on: 30 / April / 2011, 06:16:14 »
    Aaaaaaaaaaaaaaaaah,

    that worked!

    Part of the trick is to push the SET button shortly...I always hold it for long!

    Additional Info, it works with:

    1. 32GB SDcard
    2. FAT32
    3. The lock switch can be in no-lock position


    Just for the case, that someone has doubts about  these parameters...like I did.

    ...have fun...

    Michi

     

    Related Topics