ELPH300HS aka IXUS220HS - Porting Thread

  • 836 Replies
  • 103921 Views
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #340 on: 27 / November / 2011, 23:05:29 »
Advertisements
Now I am very embarrassed.   CHDK-PT v1.04 is definitely dissassembling STRD instructions where there should be LDRD instructions.   It gets the STRD instructions right so its not a simple bit reversal.

This is bad - I can't believe we have not seen this before.  I guess I need to check v1.03 to make sure something did not slip the wrong way between versions.

My apology's to all.

UPDATE :   Bug was not there in v1.03.   It was fixed back at 1.01 so I have no idea (yet) how it slipped back in.  The change from 1.03 to 1.04 was just supposed to be a better addresses.txt file.

 Link to correctly working 1.05 version :  http://www.box.com/shared/38etrnb3yu
« Last Edit: 28 / November / 2011, 00:18:36 by waterwingz »

Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #341 on: 28 / November / 2011, 04:08:36 »
If you tried the latter, then you probably booted tommi's latest build instead of mine, because mine did not include PS.FI2 as mentioned a few posts ago.

You're 100% correct.  I just replaced tommi's DISKBOOT.BIN with yours.  Appologies.

Just tried your latest build and movie recording is working !!!

Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #342 on: 28 / November / 2011, 05:27:57 »
Hi all!

Stanley, just tried your build (1.01a) and video recording works!
But only if the video quality is set to 76 or higher  ::)

If the quality is reduced to 75 or below (either in the CHDK menu or by pressing "down" while recording), the camera shuts down, with the following message:
Code: [Select]
A camera error has been detected.
Will shut down automatically.
Please restart camera.
E10

Apart from that video recording seems to work perfectly, though :)

*

Offline tommi2water

  • ***
  • 157
  • IXUS 220 HS Firmware: 1.00c
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #343 on: 28 / November / 2011, 10:19:22 »
Alright, I got movie recording working on 1.01a.  :)

Well done, jstanley! :D

Update:
I integrated files from jstanley and created a SVN patch from my local trunk version and sent this patch to developers for first integration: http://chdk.setepontos.com/index.php?topic=650.msg76782#msg76782
« Last Edit: 28 / November / 2011, 10:40:49 by tommi2water »


*

Offline bluepic

  • *
  • 2
  • IXUS 220 HS Firmware: 1.01d
IXUS220HS 1.01d
« Reply #344 on: 28 / November / 2011, 11:50:10 »
Hi,
I'm new to CHDK. My IXUS 220HS has the firmware 1.01d, can someone help me running CHDK on my cam?

Dump from 1.01d: PRIMARY.BIN - 7.94MB
Dump Log: Started - FF810000 dry - done

Thank you!
For further information, please don't hesitate to ask me...

Re: IXUS220HS 1.01d
« Reply #345 on: 28 / November / 2011, 12:39:07 »
My IXUS 220HS has the firmware 1.01d, can someone help me running CHDK on my cam?

You defined the firmware version with the program "CameraVersion"?
Try CHDK_1.01c.
It works for me.
("CameraVersion" also shows 1.01d, vers.req does not work)
« Last Edit: 28 / November / 2011, 12:44:24 by Sinyak »

*

Offline philmoz

  • *****
  • 2936
    • Photos
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #346 on: 28 / November / 2011, 14:57:10 »
Hi all!

Stanley, just tried your build (1.01a) and video recording works!
But only if the video quality is set to 76 or higher  ::)

If the quality is reduced to 75 or below (either in the CHDK menu or by pressing "down" while recording), the camera shuts down, with the following message:
Code: [Select]
A camera error has been detected.
Will shut down automatically.
Please restart camera.
E10

Apart from that video recording seems to work perfectly, though :)

In movie_rec.c the lines:
Code: [Select]
"               LDR R0, =0x6E10 \n"
"               BL set_quality \n"

should be:
Code: [Select]
"               LDR R0, =0x6E10-4 \n"
"               BL set_quality \n"

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)

*

Offline tommi2water

  • ***
  • 157
  • IXUS 220 HS Firmware: 1.00c
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #347 on: 28 / November / 2011, 15:27:13 »
Changed 0x6E10 to 0x6E0C.

Binaries for 1.00c and 1.01a attached.



*

Offline tommi2water

  • ***
  • 157
  • IXUS 220 HS Firmware: 1.00c
Re: ELPH300HS aka IXUS220HS - Porting Thread
« Reply #348 on: 28 / November / 2011, 15:27:45 »
Binary for 1.01c attached.

*

Offline bluepic

  • *
  • 2
  • IXUS 220 HS Firmware: 1.01d
Re: IXUS220HS 1.01d
« Reply #349 on: 28 / November / 2011, 15:31:32 »
My IXUS 220HS has the firmware 1.01d, can someone help me running CHDK on my cam?

You defined the firmware version with the program "CameraVersion"?
Try CHDK_1.01c.
It works for me.
("CameraVersion" also shows 1.01d, vers.req does not work)

I used the program "Automatic Camera Identifier and Downloader (ACID)".
CHDK_1.01c works for me too, thank you.

 

Related Topics