supplierdeeply

PowerShot SX230 HS - Porting Thread

  • 683 Replies
  • 165058 Views
Re: PowerShot SX230 HS - Porting Thread
« Reply #20 on: 03 / June / 2011, 01:39:12 »
Advertisements
I got my camera on order, and once I get it I will attempt to port CHDK for it.

I have had a little experiance in reverse engineering, but nothing on the ARM architecture.

My camera should be here within the week,

If you guys are willing to combine efforts let me know.

Definitely, Taliesin.  Its good to have someone with prior reverse engineering experience working on this project, even if you are unfamiliar with the ARM architecture.  Let us know what progress you make.  For right now there are 2 firmware dumps (v1.00 and v1.01) available at the sx230hs wiki page for you to experiment with. 

You can read more about chdk and the porting process here. Let us know when your camera arrives and you can begin  :)

Take care,
Aquilla   

My camera arrived today the Cannon SX230HS in blue. :D

So I will have some dinner and start on the reversing, and see how far I can get. The good news is that where I am it is a 3 day weekend, so hopefully that is enough time to learn about CHDK and hopefully provide an alpha port.

If there is anyone avaibale around the forms over the next few days for testing and support will be welcome.

I will post my progress as I go ( If I make any ). My first challenge to "convert" the USA charger to fit NZ mains sockets. :D

Taliesin

Re: PowerShot SX230 HS - Porting Thread
« Reply #21 on: 03 / June / 2011, 02:30:28 »

So far it is not looking good.

Using a soldering iron and a large set of plyers I have managed to get the charger adapted. Got the camera powered on, however I have a 16GB SD card so cant get the firmware dumper to work using cardtools.

I am attempting to follow http://chdk.wikia.com/wiki/CHDK_and_SD_cards_greater_than_4GB_%288GB,_16GB,_32GB,_64GB%29 and see if it help.

*

Offline genie

  • *
  • 43
Re: PowerShot SX230 HS - Porting Thread
« Reply #22 on: 03 / June / 2011, 06:31:44 »
Hi aquilla,

i will have time for the next days for testing CHDK.
I am good in testing, but not good in programing.

I hope i can help you.

genie
Sorry for my bad English.I am a Bavarian and German is the only foreign language i speak.

Re: PowerShot SX230 HS - Porting Thread
« Reply #23 on: 03 / June / 2011, 06:39:09 »


Things are not going good. I cant manage to get a dump of the firmware. If anyone who has managed to get a firmware dump can help me out?

I cant get the Scripts to run, and right now the camera cant detect the memory card.


Re: PowerShot SX230 HS - Porting Thread
« Reply #24 on: 03 / June / 2011, 08:29:13 »
Ok. I am under way now. Have the firmware image, and loaded it onto IDA.

I am working from a skeleton taken from the sx220 port as they appear to be very simular cameras.

Also the firmware I am working on is 101a.

Still not sure if I can run new firmware from the camera, haven't been sucessfull yet.

Wish me luck

*

Offline aquilla

  • *
  • 21
  • sx230hs fw v1.01a
Re: PowerShot SX230 HS - Porting Thread
« Reply #25 on: 03 / June / 2011, 11:25:49 »
Hi aquilla,

i will have time for the next days for testing CHDK.
I am good in testing, but not good in programing.

I hope i can help you.

genie


I'm in much the same boat, genie.  I don't have that much prior experience in the programming and reverse engineering department but I'm willing to help in any way that I can.  I am sure someone will let you know when testing is needed.  So far you're one of the few running firmware 1.00 in this forum so you will definitely be of use. 

Ok. I am under way now. Have the firmware image, and loaded it onto IDA.

I am working from a skeleton taken from the sx220 port as they appear to be very simular cameras.

Also the firmware I am working on is 101a.

Still not sure if I can run new firmware from the camera, haven't been sucessfull yet.

Wish me luck

Its good to see that you've made progress, taliesin.  You used the udumper script to get the firmware image, correct?  I also had trouble with a firmware dump on a 4gb SDHC card while using cardtricks, but the Canon Basic script seemed to do the trick.

The sx220hs is nearly identical to the sx230hs as far as hardware goes, with the minor addition of a built in gps in the sx230hs.  However I was told by reyalp that this makes little or no difference with the porting process.  Either way, I would suggest searching the sx220hs thread if you run into a problem.  That group might have faced similar difficulties. 

I would be willing to help test and will help in any other way I can.  Good luck as you work towards an alpha build. 
-Aquilla

*

Offline sylikc

  • **
  • 66
  • SX230HS 1.00c, SD750 1.02a ;)
Re: PowerShot SX230 HS - Porting Thread
« Reply #26 on: 03 / June / 2011, 17:34:50 »
Ok. I am under way now. Have the firmware image, and loaded it onto IDA.

I am working from a skeleton taken from the sx220 port as they appear to be very simular cameras.

Also the firmware I am working on is 101a.

Still not sure if I can run new firmware from the camera, haven't been sucessfull yet.

Wish me luck

Congrats taliesin!!!  Good to hear you're making progress.  I have also started the SX230 port for version 1.00c .  Of course, I'm barely moving along.... getting stuck already.  If you could, please post somewhere (box.net, zshare, etc) your firmware dump so we can see if there's any difference to the one aquilla made a few days ago.

I'd love to do testing for you.  And as soon as you get some alpha port, I look forward to getting a copy of your source tree to see if I can duplicate the work for 100c ... or you could do that too ;)

/sylikc
props to TPC + PhyrePhox for SD750 work: IXUS75/SD750 1.01a | 1.00b | 1.02a Thread
props to quietschi for multipartition support + button fixes!
SD750 bracketing issues

Re: PowerShot SX230 HS - Porting Thread
« Reply #27 on: 03 / June / 2011, 18:21:53 »

Just a quick update at the end of day 1. Made good progress last night, Set up the structure for a lot of the base code taking from the sx220hs port and the sx200. Not really doing any confirming on the constants ( screen size, zoom, ..., etc ) but setting them to the sx220. I am mainly focusing on getting the firmware to compile and load up.

This is to see if I can run the firmware on my camera for testing. If not then someone else will have to report bugs.

I managed to port through most the bootstrap and initilization code, they wernt too bad once I got into it. Moving on to the tasks, hijacing parts and things have started to get interesting. Until then the sx220 was not too disimular from the 230. Now they branch quite  alot.

I uploaded the firmware I am working from to http://www.box.net/shared/kjp2uh4qlp. For comparacion. I got this camera from USA, so I guess it has a standard firmware.

I can have a look at the 100c version if I have time, if not I am willing to let you know what I was doing.

I am off to play Airsoft ( on 3 hours sleep ), and to rest my eyes, will start again this afternoon.

Wish me luck
Taliesin


*

Offline aquilla

  • *
  • 21
  • sx230hs fw v1.01a
Re: PowerShot SX230 HS - Porting Thread
« Reply #28 on: 03 / June / 2011, 18:39:07 »
Taliesin,

Sounds like you continue to make great progress.  Unfortunately, the file you uploaded was "not found" when I tried it.  Could you possibly try uploading your firmware again?
-Aquilla

Re: PowerShot SX230 HS - Porting Thread
« Reply #29 on: 03 / June / 2011, 19:04:30 »
Taliesin,

Sounds like you continue to make great progress.  Unfortunately, the file you uploaded was "not found" when I tried it.  Could you possibly try uploading your firmware again?

sorry It took a full stop as the end of the URL.

http://www.box.net/shared/kjp2uh4qlp

I will hopefully have a version of the bootstrap code ready for testing by tonight.

 

Related Topics