PowerShot SX230 HS - Porting Thread

  • 683 Replies
  • 165251 Views
Re: PowerShot SX230 HS - Porting Thread
« Reply #40 on: 04 / June / 2011, 09:34:38 »
Advertisements
It is not a good night for me, havent made any progress in the last 5 hours.

First had the wrong firmware size importing into IDA, so missing info. Then somehow managed to bust my build enviroment so that it wasn't genereating STUB files. Causing builds to fail..

Prehaps I should call it quites for the night

Taliesin

Re: PowerShot SX230 HS - Porting Thread
« Reply #41 on: 04 / June / 2011, 11:57:20 »
Hey Guys

Great news of the progress. I have managed to port the full bootstrap/initilization code across and compile a binary.

It is far from finished however if all is well should boot with the RotarySitch  and the FileSystem Tasks on CHDK. However I cant confirm this yet.

If anyone is willing to test it, can be downloaded form http://www.box.net/shared/hx8vuank4b at your own risk.

If you do end up trying it, let me know if your camera boots with this bootcode.

This is a good place to call it a night.

Taliesin

Re: PowerShot SX230 HS - Porting Thread
« Reply #42 on: 04 / June / 2011, 15:50:15 »
Does not work with my camera. It show's update error and stays black when I try to use the auto boot method. I have a US sx230 with Firmware version 1.00C.

Re: PowerShot SX230 HS - Porting Thread
« Reply #43 on: 04 / June / 2011, 18:20:11 »
Thats not good news..

Does not work with my camera. It show's update error and stays black when I try to use the auto boot method. I have a US sx230 with Firmware version 1.00C.

Thanks for the test. I will have a look see if made any obvious mistakes. If not I will look for the LED address so we can step through the boot sequence


*

Offline aquilla

  • *
  • 21
  • sx230hs fw v1.01a
Re: PowerShot SX230 HS - Porting Thread
« Reply #44 on: 04 / June / 2011, 19:02:23 »
Thats not good news..

Does not work with my camera. It show's update error and stays black when I try to use the auto boot method. I have a US sx230 with Firmware version 1.00C.

Thanks for the test. I will have a look see if made any obvious mistakes. If not I will look for the LED address so we can step through the boot sequence

Should it work if stone17 is using firmware version v1.00c?  I would think the two versions would not be compatible.  However, I did try to boot using your diskboot.bin file on my v1.01a camera.  I also ended up with a black screen, and was not able to boot the camera.  It may have been due to an error on my end, however, so don't automatically assume that it was your mistake.  Just thought I'd let you know.  I attempted to boot following the instructions at http://chdk.wikia.com/wiki/CHDK/Installing_with_Cardtricks.  I also tried the first method listed at http://chdk.wikia.com/wiki/FAQ#Q._How_do_I_manually_load_CHDK_so_I_can_use_it.3F with no success.  In that instance, the camera turned on but reported the memory card as locked.  The firmware update menu did not appear.  Please tell me if you are aware of a different method that may work. 

As a side note, is a ps.fir or ps.f12 file needed for the boot for any reason? 
-Aquilla

*

Offline sylikc

  • **
  • 66
  • SX230HS 1.00c, SD750 1.02a ;)
Re: PowerShot SX230 HS - Porting Thread
« Reply #45 on: 04 / June / 2011, 20:07:05 »
Does not work with my camera. It show's update error and stays black when I try to use the auto boot method. I have a US sx230 with Firmware version 1.00C.

for the time being, I don't think we can assume that a 1.01a firmware is going to be compatible with our 1.00c cameras.  I mean the code may be close, but just one address change and it wouldn't work.

Should it work if stone17 is using firmware version v1.00c?  I would think the two versions would not be compatible.  However, I did try to boot using your diskboot.bin file on my v1.01a camera.  I also ended up with a black screen, and was not able to boot the camera.  It may have been due to an error on my end, however, so don't automatically assume that it was your mistake.  Just thought I'd let you know.  I attempted to boot following the instructions at http://chdk.wikia.com/wiki/CHDK/Installing_with_Cardtricks.  I also tried the first method listed at http://chdk.wikia.com/wiki/FAQ#Q._How_do_I_manually_load_CHDK_so_I_can_use_it.3F with no success.  In that instance, the camera turned on but reported the memory card as locked.  The firmware update menu did not appear.  Please tell me if you are aware of a different method that may work. 

As a side note, is a ps.fir or ps.f12 file needed for the boot for any reason? 

Can someone comment whether it's better to use the playback-firmware-update method to test or the locked-card-autoload?  Is it safer to use one way or another?  Would one test code that the other wouldn't?

I would assume to try to get CHDK to load, we want to use the most reliable method .... which one is it?  I always manual load for the most part ;)

Also, my SX230 is having problems with its mode selection jogdial.  I'm gonna have to send it back, so I might get yet another version back.  (Stupid jogdial, i select Av and it'll be M sometimes, Av some other times... and I already put a screen protector on it :( )

/sylikc
props to TPC + PhyrePhox for SD750 work: IXUS75/SD750 1.01a | 1.00b | 1.02a Thread
props to quietschi for multipartition support + button fixes!
SD750 bracketing issues

*

Offline aquilla

  • *
  • 21
  • sx230hs fw v1.01a
Re: PowerShot SX230 HS - Porting Thread
« Reply #46 on: 04 / June / 2011, 20:17:40 »
The jogdial issue is unfortunate.  Hopefully they send back a v1.01a model and we are all (mostly) on the same page.  That should make the initial porting process a little easier.

 

Can someone comment whether it's better to use the playback-firmware-update method to test or the locked-card-autoload?  Is it safer to use one way or another?  Would one test code that the other wouldn't?

I would assume to try to get CHDK to load, we want to use the most reliable method .... which one is it?  I always manual load for the most part ;)

/sylikc

Is it possible to use the locked-card-autoload method without first using the playback-firmware-update method first?  I had thought that the locked-card-autoload method was simply an added convenience.  Up until fairly recently (a few months to a year ago) the autoload method did not exist.  I would first try testing with the playback-firmware-update method, as it seems to be the simplest. 
-Aquilla

Re: PowerShot SX230 HS - Porting Thread
« Reply #47 on: 04 / June / 2011, 20:25:23 »
Is it possible to use the locked-card-autoload method without first using the playback-firmware-update method first?

Yes.
Ported :   A1200    SD940   G10    Powershot N    G16


*

Offline aquilla

  • *
  • 21
  • sx230hs fw v1.01a
Re: PowerShot SX230 HS - Porting Thread
« Reply #48 on: 04 / June / 2011, 20:28:10 »
Could you kindly link me to the instructions or provide a brief overview?  I searched for a method earlier today but was unable to find anything.  Thanks for your help, waterwingz
.  

-Aquilla

Re: PowerShot SX230 HS - Porting Thread
« Reply #49 on: 04 / June / 2011, 20:31:24 »
Could you kindly link me to the instructions or provide a brief overview?  I searched for a method earlier today but was unable to find anything.  Thanks for your help, waterwingz

http://chdk.wikia.com/wiki/CHDK_for_Dummies#Load_CHDK_onto_the_card
http://chdk.wikia.com/wiki/CHDK/Installing_with_Cardtricks


Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics