PowerShot SX230 HS - Porting Thread - page 67 - General Discussion and Assistance - CHDK Forum supplierdeeply

PowerShot SX230 HS - Porting Thread

  • 686 Replies
  • 193912 Views
Re: PowerShot SX230 HS - Porting Thread
« Reply #660 on: 28 / April / 2015, 02:37:42 »
Advertisements
Sorry to bump an old thread, but I was wondering if anyone had an archive of older CHDK 1.3 builds

I tried the latest nightly today (latest update was nearly 2 months prior), and forgot to save the data on the card.

Everything works well, except the continuous shooting. If the shutter button is held down, it will take the first image, but will save no data,  on the second image that it attempts to take, the camera crashes (nothing responds, and the green light just keeps blinking. It is not much of an issue since I do not use it much, but there are some built in functions which use it, e.g., built in scripts such as the timer which can take multiple images (if you want to do mean stacking).

The same issue also happens with the development 1.4 build.

Camera is using firmware 1.01B



Re: PowerShot SX230 HS - Porting Thread
« Reply #661 on: 28 / April / 2015, 08:48:39 »
Sorry to bump an old thread, but I was wondering if anyone had an archive of older CHDK 1.3 builds
I think there are some archives on the google site where fe50 keeps the firmware dump files.

But it's probably just as easy to rebuild an older version from the svn repository.  Any idea what date range you would be looking for ?
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline srsa_4c

  • ******
  • 4107
Re: PowerShot SX230 HS - Porting Thread
« Reply #662 on: 28 / April / 2015, 13:12:52 »
The same issue also happens with the development 1.4 build.
Are you saying that the same issue happens with both 1.3 and 1.4 builds downloaded from the autobuild? Does this test build work (it's only 3 months old)?

Re: PowerShot SX230 HS - Porting Thread
« Reply #663 on: 28 / April / 2015, 15:07:37 »
Yes,  I tried both auto builds of 1.3 and 1.4, and they have the same issue.

Thanks, I forgot about that thread.

The continuous shooting works fine with the latest test build sx230hs-101b-1.3.0-3931-full-reyalp-test-1.zip

For future use, I will try to get the use the SVN

Will these instructions still work for the 1.3 and possibly 1.4 builds? http://chdk.wikia.com/wiki/Compiling_CHDK_under_Windows

Also interested in CHDK shell http://chdk.wikia.com/wiki/CHDK-Shell  but am having trouble downloading the files. they will not extract either with the self extractor, or winrar
http://i.imgur.com/OjW2O1E.jpg


*

Offline srsa_4c

  • ******
  • 4107
Re: PowerShot SX230 HS - Porting Thread
« Reply #664 on: 28 / April / 2015, 18:20:51 »
Yes,  I tried both auto builds of 1.3 and 1.4, and they have the same issue.
(...)
The continuous shooting works fine with the latest test build sx230hs-101b-1.3.0-3931-full-reyalp-test-1.zip
Strange as usual - I don't think there have been significant changes in the 1.3 code since then.
Quote
For future use, I will try to get the use the SVN

Will these instructions still work for the 1.3 and possibly 1.4 builds? http://chdk.wikia.com/wiki/Compiling_CHDK_under_Windows
Probably, if not, you can ask questions (not in this thread).
Quote
Also interested in CHDK shell http://chdk.wikia.com/wiki/CHDK-Shell  but am having trouble downloading the files. they will not extract either with the self extractor, or winrar
http://i.imgur.com/OjW2O1E.jpg
You need CHDK-Shell-v340-full-sfx.exe, CHDK-Shell-v345-sfx.exe and possibly gcc464-493env-forCHDK-sfx.exe .

*

Offline reyalp

  • ******
  • 12375
Re: PowerShot SX230 HS - Porting Thread
« Reply #665 on: 28 / April / 2015, 22:25:59 »
Strange as usual - I don't think there have been significant changes in the 1.3 code since then.
I did not check in the changes from that test build, it was only a test to verify the that the problem involves some kind of deadlock with the fsio semaphore.
Don't forget what the H stands for.

Re: PowerShot SX230 HS - Porting Thread
« Reply #666 on: 28 / April / 2015, 23:08:07 »
For a while I have been using 2 cards, a 4GB Sandisk Extreme, and a 64GB PNY "Elite Performance" SDXC card.

I checked the build on my 4GB card and it is still the 3931-full-reyalp-test-1 build. For the 64GBcard, I had been updating it periodically, mainly because I did not use it much for HDR, but I did use it for mean stacking in photoshop.

I use this setup because the SD card which does not need any special formatting to work with CHDK, has a higher write speed (roughly 50% faster than the SDXC card).

*

Offline reyalp

  • ******
  • 12375
Re: PowerShot SX230 HS - Porting Thread
« Reply #667 on: 08 / August / 2015, 19:08:58 »
Here are test builds of the current trunk (r4242) using the code-gen patch nafraf posted in http://chdk.setepontos.com/index.php?topic=6397.msg113208#msg113208

If sx230 users can verify that these work, it may eliminate some of the unresolved issues with this port (though unfortunately not Razor512's raw problem).

100c https://app.box.com/s/ohvfx1z3rwm8c90yuup9mjmshqjawz7w
101a https://app.box.com/s/misrpfiis3cyjbom9favykghwkvo255t
101b https://app.box.com/s/l5e4e5dtc9hean7g6ghn968h6slp8auj
Don't forget what the H stands for.


*

Offline reyalp

  • ******
  • 12375
Re: PowerShot SX230 HS - Porting Thread
« Reply #668 on: 26 / December / 2015, 15:41:07 »
If you own this camera, please test the builds posted in http://chdk.setepontos.com/index.php?topic=12711.msg126133#msg126133
Don't forget what the H stands for.

Re: PowerShot SX230 HS - Porting Thread
« Reply #669 on: 26 / December / 2015, 15:58:07 »
Yay,  updates, can't wait to try it today.

 

Related Topics