PowerShot SX230 HS - Porting Thread - page 8 - General Discussion and Assistance - CHDK Forum

PowerShot SX230 HS - Porting Thread

  • 686 Replies
  • 182925 Views
*

Offline sylikc

  • **
  • 66
  • SX230HS 1.00c, SD750 1.02a ;)
Re: PowerShot SX230 HS - Porting Thread
« Reply #70 on: 06 / June / 2011, 15:39:49 »
Advertisements
There wont be much for a non programmer to do until I get something working. Long weekend is over now, I didn't get as much done it as I hoped but I will continue to work on it. Progress will be slow for me though.


Are there any other programmers working on this?

I'm "trying" :D.  I can load the dump and all, but where exactly can a programmer help at this point?  I can grab your build environment, and then where do I jump in?

Plus, I need to get my stooooopid camera RMA'd cuz of that freggin jog dial.
props to TPC + PhyrePhox for SD750 work: IXUS75/SD750 1.01a | 1.00b | 1.02a Thread
props to quietschi for multipartition support + button fixes!
SD750 bracketing issues

Re: PowerShot SX230 HS - Porting Thread
« Reply #71 on: 06 / June / 2011, 18:10:18 »
I'm "trying" :D.  I can load the dump and all, but where exactly can a programmer help at this point?  I can grab your build environment, and then where do I jump in?

Plus, I need to get my stooooopid camera RMA'd cuz of that freggin jog dial.

I can send it to you if you want however I will like to get a bit more done before releasing it, as a lot of it is still only playing around/testing. And nit really in a format for people to understand.

Are you running the old 101a, or the 100c firmware?

One of the first things to do is to find the addresses of the library functions. That is what I am trying to work on at the moment. However it is slow going.

Download the firmware dump from a simular camera ( im using the sx220 alpha port ), and looks through the platform/sx220/sub/xxx/stubs_entry_2.c and teh stubs_min.c and try and find the equilivant functions in the new firmware and replace the addresses in the files.

So open the sx220 address in IDA, and then find a rare line of assembly, or try and back trace it to a known location in the firmware. Then find this in the new firmware.

I rename every function I match to make the job easier.

I did notice there is a tool to port between firmware, so if I get the 101a firmware correct, then that could work.

Good luck.
Taliesin

*

Offline sylikc

  • **
  • 66
  • SX230HS 1.00c, SD750 1.02a ;)
Re: PowerShot SX230 HS - Porting Thread
« Reply #72 on: 06 / June / 2011, 18:51:13 »
taliesin, I have been talking to funnel about the SX220 port.  In fact, funnel was able to provide me a copy of boot.c from daffy.d's earlier work that works with the 1.00c.  (I haven't compiled it yet though)

I have the alpha of funnel's dev environment and loaded it into IDA.  ... though I have to defer until I get a new camera back before doing additional development / testing.  For now, I'll look into repeating funnel's work to see if I can figure out howto trace through to the right addresses . . .
props to TPC + PhyrePhox for SD750 work: IXUS75/SD750 1.01a | 1.00b | 1.02a Thread
props to quietschi for multipartition support + button fixes!
SD750 bracketing issues

Re: PowerShot SX230 HS - Porting Thread
« Reply #73 on: 06 / June / 2011, 20:51:48 »
taliesin, I have been talking to funnel about the SX220 port.  In fact, funnel was able to provide me a copy of boot.c from daffy.d's earlier work that works with the 1.00c.  (I haven't compiled it yet though)

I have the alpha of funnel's dev environment and loaded it into IDA.  ... though I have to defer until I get a new camera back before doing additional development / testing.  For now, I'll look into repeating funnel's work to see if I can figure out howto trace through to the right addresses . . .

If the files you have are more recent than the latest posted on the sx220 topic, can you please send me a copy. There could be some updates which could help with a few things.

Good luck on your new camera.


*

Offline funnel

  • ****
  • 349
Re: PowerShot SX230 HS - Porting Thread
« Reply #74 on: 07 / June / 2011, 04:44:05 »
I would reccomend before doing any testing to point all the subs in stus_entry_2.S you didn't find to a nullsub location. Just to be safe in case something does point somewhere you don't want.

@sylikc You can start searching like taliesin said for the function locations in stus_entry_2.S stus_min.S. That is a time consuming job and you don't need the camera for that. If you have big problems finding some of them I can help you find them.

Re: PowerShot SX230 HS - Porting Thread
« Reply #75 on: 12 / June / 2011, 07:32:22 »
I did some more work on the port in the weekend. I managed to get most the stub addresses found ( at my best guess ), and ported the keyboard task.

So far it CHDK runs and shows a splash screen, but something is not right ( key codes?? ) which means the only button that works is the jog dial.

Also I think I have a wrong address or left some testing code in it somewhere because it crashes after about a minute.

Link: http://www.box.net/shared/6ogt98f6mkzzactz60nt

Can someone confirm it runs as described above for you? and if someone has autoboot working can you try and let me know what happens. I can ony run using firmware upgrade, and cant get into camera mode. :(

Thanks in advanced for feedback.

*

Offline Vitold

  • *
  • 3
  • Canon SX260 HS fw 1.00B
Re: PowerShot SX230 HS - Porting Thread
« Reply #76 on: 12 / June / 2011, 15:15:53 »
taliesin could you please alwayas note for which original firmware version your build is? Does the filename sx230hs_101a.zip stand for 1.01A firmware?
So fare no luck for me to load any of your builds (I have a 1.00C firmware)
« Last Edit: 12 / June / 2011, 15:18:04 by Vitold »

*

Offline aquilla

  • *
  • 21
  • sx230hs fw v1.01a
Re: PowerShot SX230 HS - Porting Thread
« Reply #77 on: 12 / June / 2011, 15:18:43 »
Yup.  The v1.01a builds are not compatible with v1.00c: taliesin is using v1.01a I believe.  Hope that helps:  you might be able to talk to sylikc about v1.00c.
-Aquilla


Re: PowerShot SX230 HS - Porting Thread
« Reply #78 on: 12 / June / 2011, 15:19:11 »
taliesin could you please alwayas note for which original firmware version your build is? Does the filename sx230hs_101a.zip stands for 1.01A firmware?
So fare no luck for me to load any of your builds (I have a 1.00C firmware)

I have 1.01A version so that is the one I am working on. Might get a chance to back port at some stage. Or I will post source code for someone who can port it on the older firmware.

Re: PowerShot SX230 HS - Porting Thread
« Reply #79 on: 14 / June / 2011, 10:21:18 »
I am following this thread for some time and I have too, the 1.00C firmware. Unfortunately, I don't have any programming skills. :(

 

Related Topics