PowerShot SX230 HS - Porting Thread - page 64 - General Discussion and Assistance - CHDK Forum supplierdeeply

PowerShot SX230 HS - Porting Thread

  • 706 Replies
  • 240356 Views
Re: PowerShot SX230 HS - Porting Thread
« Reply #630 on: 17 / November / 2013, 05:52:31 »
Advertisements
I tried it out for a while and it seems to be stable, (no new issues at least for me)  (my camera uses firmware 101b )

though it requires either an old version of CHDk to make the card bootable, or an application such as stick to make the card bootable.
« Last Edit: 17 / November / 2013, 05:55:21 by Razor512 »

*

Offline srsa_4c

  • ******
  • 4426
Re: PowerShot SX230 HS - Porting Thread
« Reply #631 on: 26 / November / 2013, 11:50:20 »
If the latest test builds on the previous page are stable, perhaps the changes should go official? Thoughts, objections?

Re: PowerShot SX230 HS - Porting Thread
« Reply #632 on: 03 / December / 2013, 05:50:29 »
I'm using this version without problems on 101b FW.

So i vote yes to go official

Re: PowerShot SX230 HS - Porting Thread
« Reply #633 on: 06 / December / 2013, 06:17:50 »
Not related to the memory improvement, but there is one weird bug with CHDK, if in manual mode, you set the ND filter state as in, then take a few pictures, then set it to off, the camera crashes with the lens still extended)


*

Offline srsa_4c

  • ******
  • 4426
Re: PowerShot SX230 HS - Porting Thread
« Reply #634 on: 06 / December / 2013, 11:48:28 »
Not related to the memory improvement, but there is one weird bug with CHDK, if in manual mode, you set the ND filter state as in, then take a few pictures, then set it to off, the camera crashes with the lens still extended)
Can you post a romlog and check whether the bug is present in the official build?


About the test build: can you (or somebody else with this camera) execute the attached script a few times while using the camera (don't do that while shooting a movie), in playback and record mode? It will create a file named UARTLOG.TXT in the root of the card. The file will hold some details about the available and used memory (RAM). Please post the file here, and note CHDK settings that consume larger amounts of RAM (zebra/edge overlay/badpixel.bin for DNG 1.1), if you used any. The script needs files from a complete CHDK distribution archive, and it needs enabled 'native calls' in the misc menu.

Re: PowerShot SX230 HS - Porting Thread
« Reply #635 on: 06 / December / 2013, 15:34:25 »
issue is on both the standard builds and the test build

Not really sure where to get the rom log for when the camera crashes,

The log folder is also empty.

I also attached the uartlog

The camera was in manual mode while running the script. The camera had RAW enabled and set to save to dng 1.1

I did not take any pictures before running the script. I will add another reply (2 attachment limit) with a new log file of the script run a few times after taking a few pictures
« Last Edit: 06 / December / 2013, 15:53:47 by Razor512 »

Re: PowerShot SX230 HS - Porting Thread
« Reply #636 on: 06 / December / 2013, 15:59:22 »
more uartlog files

this time I took a few pictures, then ran the script, and then I began switching picture modes, and then running the script. (non video modes only)

*

Offline srsa_4c

  • ******
  • 4426
Re: PowerShot SX230 HS - Porting Thread
« Reply #637 on: 06 / December / 2013, 18:20:07 »
Not really sure where to get the rom log for when the camera crashes
Miscellaneous Stuff --> Debug Parameters --> Save ROM crash log, it will create a file named romlog.log in the root of the card. Note that the camera stores this crash log internally, so you don't need to make it crash again if the most recent crash reason was the ND filter.

According to your logs, free memory is still desperately low, despite the CHDK core no longer occupying space there.
How big is your badpixel.bin file currently?


New test builds, these introduce improved badpixel.bin compression (you need to recreate the badpixel file to take advantage of that), and CHDK should have a bit more memory.
Please re-test with the above script, and note the new size of badpixel.bin.

Quote
Warning: the download site that hosts the builds may show strong advertising activity, ad-blocking recommended...
sx230 100c: http://www.sendspace.com/file/teiina
sx230 101a: http://www.sendspace.com/file/autvpf
sx230 101b: http://www.sendspace.com/file/wt9xip
« Last Edit: 06 / December / 2013, 18:53:58 by srsa_4c »


Re: PowerShot SX230 HS - Porting Thread
« Reply #638 on: 06 / December / 2013, 23:54:48 »
Sorry for the late reply, the bad pixel file is currently 92KB in size under the old firmware

Under the new firmware, the bad pixel file is 40KB

though there seems to be an issue, it detects fewer bad pixels, on the old firmware, it detects a little over 36000  while the new one only detects a little over 34000 bad pixels (the raw files don't seem to have more bad pixels though, I will have to examine them more closely)

I attached the new uartlog and also the romlog

« Last Edit: 06 / December / 2013, 23:56:38 by Razor512 »

Re: PowerShot SX230 HS - Porting Thread
« Reply #639 on: 07 / December / 2013, 00:44:24 »
reproduced the crash again and did another romlog


Also in testing the badpixel file  more closely, I cant really notice more noise

I am going to do an ISO comparison with the old firmware. (can only go up to ISO 1600 as the bad pixel file remains the same up until you go past ISO 1600 then creating a badpixel file results in a significant increase that crashes the camera)

For anyone else wanting to compare, I did some test shots ranging from ISO 100 to ISO 3200  (the bad pixel file only covers ISO 100-1600 on both  image sets.


Images taken with the old bad pixel file: http://www.mediafire.com/download/nbc9hdc8yz620gh/old%20firmware%20iso.7z

Images taken with the new  badpixel file: http://www.mediafire.com/download/0e88gffcd2898ts/new%20firmware%20iso.7z


edit weird: the first log was 0KB I reattached it
« Last Edit: 07 / December / 2013, 01:46:47 by Razor512 »

 

Related Topics