PowerShot SX230 HS - Porting Thread - page 32 - General Discussion and Assistance - CHDK Forum supplierdeeply

PowerShot SX230 HS - Porting Thread

  • 706 Replies
  • 251417 Views
Re: PowerShot SX230 HS - Porting Thread
« Reply #310 on: 09 / September / 2011, 20:43:16 »
Advertisements

Is there a firmware dump avaibable?

http://www.box.net/chdk/1/55272271


If i get this weekend I might try and look into it.

For now,

sx230hs 101a - Beta6
Now with some basic GPS info on DNG's thanks to genie.

DISKBOOT.BIN - http://www.box.net/shared/ikud70g65u0mrk3updpo
PS.FI2 - http://www.box.net/shared/t25akhg01aqb11huic61

Taliesin

Re: PowerShot SX230 HS - Porting Thread
« Reply #311 on: 09 / September / 2011, 22:54:43 »
Hiya,

I finally got a free evening to look at the ISO400 bug. I think I managed to crack it, not sure what else I have broken in the meantime ( I kind of wish I have made a backup copy of the source at Beta04, as I cant remember what changes I have made since then )

Sorry for taking so long I have been quite busy and I was origionally only going to spend a four day weekend on this project..

As always use at your own risk
CHDK sx230 firmware version 1.01A
Diskboot.bin   -   http://www.box.net/shared/upb0772a7o5evde4cghx
PS.FI2   -  http://www.box.net/shared/dms1thh7r325pry8d8fo

Is it me or on this version the keyboard feel a lot less responsive?

I would offer to help with the 1.01B but am too busy. If anyone wants any pointers feel free to PM me.

Let me know how it fares,

Taliesin

Taliesin,

You're my hero!  Thanks for taking all this free time to work on CHDK for us who are less skilled ;).  We've missed you here~

Well, I've had quite a time with the ISO400 bug, having to constantly remember to set it when indoors, or unlock my card.

I've ran into another possible bug (I'll do more testing tonight to see if it actually happens consistently, and/or if it still appears in the latest build) but it has something to with recording video.  In certain cases, when CHDK is running on v1.01a when I do a zoom the camera will just freeze.  It's happened at least once in afternoon lighting and once indoors.  Once again, I'll see if i can nail down how to reproduce it.

Thanks!
/sylikc


Sylikc

Let me know if you can reproduce the bug. If so post the steps and I will look into it. gmail tends to not receive the emails to say a new post has been meade here :(.. so I missed a lot.

Also  I cant take all the credit, Genie has put a lot of time into it too. If not more than myself.

Taliesin

Re: PowerShot SX230 HS - Porting Thread
« Reply #312 on: 09 / September / 2011, 23:07:22 »
The sx230hs ports for 100c and 101a is now in the CHDK trunk version 1326.. 

Note: the 100c version may be slightly behind the version on the german forums

Taliesin

Re: PowerShot SX230 HS - Porting Thread
« Reply #313 on: 10 / September / 2011, 08:00:31 »

Is there a firmware dump avaibable?

http://www.box.net/chdk/1/55272271


Hey

Here is a alpha01 version of CHDK for the sx230hs firmware 101b
PS.FI2 - http://www.box.net/shared/42ai6h8dnimy77hx0o3e

I dont have the camera so this is currently untested. Let me know what happens.

Taliesin


*

Offline Peter_A720

  • *
  • 7
  • XMPP-Adress: peter_j@jabber.de
Re: PowerShot SX230 HS - Porting Thread
« Reply #314 on: 10 / September / 2011, 11:38:32 »
Hallo Taliesin,

Thanks and respect for your work!!

I test your last Version fore the sx230 firmware version 1.01A. Sad to say that the Problem, I described before still exist. I have a Version from genie from the 1.9.2011 (with oter Problems) were this Problem is solved and the JPG-file sizes reaches 8MB.

If I use CHDK, the JPG-files are all the time very small (2-3MB) with 12M-Pixel!!! So the JPG-compression-quality must be always "Normal"

I tried every quality override and Extra Photo Operations setting, the only changes are the Exif information of the JPEG images.

With JPG-compression-quality "Fine" (works only without CHDK) the JPG-file sizes are 3.5 to 5MB, so I expect with JPG-compression-quality "superfine" JPG-file sizes up to 8MB
« Last Edit: 10 / September / 2011, 11:40:39 by Peter_A720 »
Cameras:
A720 IS Fw.: 1.00c
SX230 HS Fw.: 1.01a
S100 Fw.: 1.02a
SX270 HS Fw.: 1.02c
A4000 IS Fw.: 1.01a
Ixus 230 HS Fw.: 1.00a
G7x Mark II

Greetings from Germany

Re: PowerShot SX230 HS - Porting Thread
« Reply #315 on: 10 / September / 2011, 13:20:28 »
Hey

Here is a alpha01 version of CHDK for the sx230hs firmware 101b
PS.FI2 - http://www.box.net/shared/42ai6h8dnimy77hx0o3e

I dont have the camera so this is currently untested. Let me know what happens.

Taliesin

I ran the standard test scripts, logs are here: https://www.box.net/shared/hb7az3eqm2ahs3tr1ds8. Power outage today zapped dsl modem,so my connectivity is limited to android phone, but let me know if there are more specific tests I can run for you.

And THANK YOU!
« Last Edit: 10 / September / 2011, 14:30:02 by andyroo »
A720 1.00c | D10 1.00b |SX220 1.01a | SX230 ? | SX30 1.00p CHDK ver. 1.1.0-r1727

Re: PowerShot SX230 HS - Porting Thread
« Reply #316 on: 10 / September / 2011, 13:28:36 »
Edited previous msg to add link to box.net
« Last Edit: 10 / September / 2011, 14:33:32 by andyroo »
A720 1.00c | D10 1.00b |SX220 1.01a | SX230 ? | SX30 1.00p CHDK ver. 1.1.0-r1727

Re: PowerShot SX230 HS - Porting Thread
« Reply #317 on: 10 / September / 2011, 19:10:38 »
Hi! I wanna try the firmware 101b, I install it in the camera, and run it.. but I don't know how to open the chdk menu, I turn it on with play button, and make the firm update, but how can i open the menu to change the options? In my SX200 I can access with the print button, but now, i don't know how

P.S: Sorry for my bad english


*

Offline sylikc

  • **
  • 66
  • SX230HS 1.00c, SD750 1.02a ;)
Re: PowerShot SX230 HS - Porting Thread
« Reply #318 on: 10 / September / 2011, 19:30:05 »
Hi! I wanna try the firmware 101b, I install it in the camera, and run it.. but I don't know how to open the chdk menu, I turn it on with play button, and make the firm update, but how can i open the menu to change the options? In my SX200 I can access with the print button, but now, i don't know how

P.S: Sorry for my bad english

sebastc09, hold down the DISP+SET button at the same time to get the CHDK menu
props to TPC + PhyrePhox for SD750 work: IXUS75/SD750 1.01a | 1.00b | 1.02a Thread
props to quietschi for multipartition support + button fixes!
SD750 bracketing issues

*

Offline sylikc

  • **
  • 66
  • SX230HS 1.00c, SD750 1.02a ;)
Re: PowerShot SX230 HS - Porting Thread
« Reply #319 on: 11 / September / 2011, 02:06:31 »
Let me know if you can reproduce the bug. If so post the steps and I will look into it. gmail tends to not receive the emails to say a new post has been meade here :(.. so I missed a lot.

Also  I cant take all the credit, Genie has put a lot of time into it too. If not more than myself.

Taliesin,

So far so good.  I had suspected at one point that the video crashing had to do with something along the lines of the ISO400 bug because it happened particularly when zooming onto something relatively dark (like a sudden bright to dark transition)....  If it ever comes up again, I'll report back. 

Just curious, what was the reason the ISO400 bug manifested to begin with?  Thank YOU and Genie for fixing that... seriously difficult to work with ;).  So was it a bad address?  And what bad address would cause just everything above the certain ISO to kill the camera?

/sylikc
props to TPC + PhyrePhox for SD750 work: IXUS75/SD750 1.01a | 1.00b | 1.02a Thread
props to quietschi for multipartition support + button fixes!
SD750 bracketing issues

 

Related Topics