supplierdeeply

PowerShot SX230 HS - Porting Thread

  • 671 Replies
  • 111470 Views
*

Offline nafraf

  • *****
  • 1256
  • Publish
    Re: PowerShot SX230 HS - Porting Thread
    « Reply #600 on: 05 / February / 2013, 13:12:06 »
    Advertisements
    msl collected some lens profiles and posted here.  sx230 is included in his list.

    *

    Offline jno

    • *
    • 6
      • FSW.su
  • Publish
    Re: PowerShot SX230 HS - Porting Thread
    « Reply #601 on: 05 / February / 2013, 13:17:26 »
    http://www.mediafire.com/?oz7y0ibptb6q3tr
    TNX!

    Well, it's Adobe's too... But it has some numbers.
    As I have no other products of Adobe apart from Acrobat Reader, I'll try to figure out how to move things to LensFun format.
    SX230HS

  • Publish
    Re: PowerShot SX230 HS - Porting Thread
    « Reply #602 on: 06 / February / 2013, 15:59:51 »
    not sure if there is a windows version of lens fun but if needed, here are some sample images taken with the SX 230 HS for use in making your own lens profile manually.


    I uploaded a zip file containing a unedited raw file from the camera (of a grid filling the frame)

    I also included a jpeg output that the camera generates automatically (showing the camera's internal lens correction)

    as well as an output of a raw corrected image in photoshop

    http://www.mediafire.com/?qdmct2l5cobv7cs



    *

    Offline jno

    • *
    • 6
      • FSW.su
  • Publish
    Re: PowerShot SX230 HS - Porting Thread
    « Reply #603 on: 06 / February / 2013, 17:26:45 »
    not sure if there is a windows version of lens fun
    It is. In windows version of UFRaw, for instance.

    TNX, for the pack - will check it out.
    SX230HS


  • Publish
    Re: PowerShot SX230 HS - Porting Thread
    « Reply #604 on: 10 / March / 2013, 16:52:56 »
    Does anyone know if it is possible to force manual focus while recording video?, or at least lock the focus but still refocus on demand by pressing a button?

    Edit: was also wondering about what seems to be an IR sensor in front of the camera. Is there a way to use it to make the camera take a picture?
    « Last Edit: 14 / March / 2013, 17:37:54 by Razor512 »

  • Publish
    Re: PowerShot SX230 HS - Porting Thread
    « Reply #605 on: 15 / March / 2013, 04:02:35 »
    Hi
    I am a newcomer to CHDK and so far i got it working fine on my SX230HS but i do have a question.
    Is it possible to press the rec button (the one with the red dot) from a script?
    It looks like the camera can be in photo mode and still be able to record a movie if i press the rec button.
    What i am trying to do is to be able to take pictures and videos from a remote control script but so far i didn't found any way to change modes thus the "rec" button seems like a viable solution.
    Thanks
    Chris

  • Publish
    Re: PowerShot SX230 HS - Porting Thread
    « Reply #606 on: 15 / March / 2013, 07:12:50 »
    Is it possible to press the rec button (the one with the red dot) from a script?
    It looks like the camera can be in photo mode and still be able to record a movie if i press the rec button.
    What i am trying to do is to be able to take pictures and videos from a remote control script but so far i didn't found any way to change modes thus the "rec" button seems like a viable solution.
    Should be possible like this :

    Code: [Select]
       press "video"
       sleep 2000
       release "video"

    Take a look at the scripts on this page : http://chdk.wikia.com/wiki/Continuous_Video_Scripts

  • Publish
    Re: PowerShot SX230 HS - Porting Thread
    « Reply #607 on: 15 / March / 2013, 09:41:32 »
    Excellent!!!
    I will try all methods  :)
    Thank you very much for the help.
    Chris


  • Publish
    Re: PowerShot SX230 HS - Porting Thread
    « Reply #608 on: 17 / March / 2013, 02:07:05 »
    Video problem with latest 1.1 build as of 3/17/2013 (did not happen with the older version from about 1.5 months ago.

    currently when running chdk on the 230HS, after a few seconds I get a exclamation point next to the record time then the video begins to distort. If I have it not boot into chdk, then it records just fine.

    (I have the CHDK UI set to disabled as part of a workaround to an older issue where the OSD would cause the camera to crash when recording video)

    Sometimes it will also stop recording with an E09 error

    I am using a Sandisk Extreme 8GB SD card

    I recorded a video of the issue

    https://www.youtube.com/watch?v=3_FMqEpR8XY
    « Last Edit: 17 / March / 2013, 02:21:38 by Razor512 »

    *

    Offline srsa_4c

    • ******
    • 3118
  • Publish
    Re: PowerShot SX230 HS - Porting Thread
    « Reply #609 on: 17 / March / 2013, 12:40:45 »
    currently when running chdk on the 230HS, after a few seconds I get a exclamation point next to the record time then the video begins to distort.
    That seems to be tearing, pretty weird.
    As I can't see any change in the 1.1 code base which could have an effect like this, I suspect that
    Quote
    (I have the CHDK UI set to disabled as part of a workaround to an older issue where the OSD would cause the camera to crash when recording video)
    this problem has escalated. There's something in this CHDK port that corrupts memory.

    Quote
    Sometimes it will also stop recording with an E09 error
    That's "JPEGTimeOut" aka the video encoder failed to compress a frame.

    You could try to build CHDK yourself: http://chdk.wikia.com/wiki/CHDK-Shell, http://chdk.setepontos.com/index.php?topic=845.0, and see whether you get the same issues (memory corruption may depend on the compiler). You can also build older CHDK versions with that program.

     

    Related Topics