Adding new cameras, applying patches into trunk (with source code prepared) - page 73 - General Discussion and Assistance - CHDK Forum supplierdeeply

Adding new cameras, applying patches into trunk (with source code prepared)

  • 1664 Replies
  • 672454 Views
*

Offline philmoz

  • *****
  • 3407
    • Photos
Advertisements
Correction of the module inspector closing (added draw_restore()).
Added "_" and "£" to the textbox.
Patch is here here

Both added in revision 1865 (trunk).

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

*

Offline philmoz

  • *****
  • 3407
    • Photos
sx260 100b 100c stable version to be applyed into trunk please

There are a couple of problems with this patch as it currently is:
- The definition and code for the 'mkdir' function in generic/wrappers.c has been changed. This will affect every other camera. If you need a different definition and code make it camera specific or add a new #define the camera.h & platform_camera.h to control it.
- The patch contains unrelated changes to the GPS code.
- The patch contains white space changes to files which make it hard to determine the exact code changes being made.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

*

Offline asm1989

  • *****
  • 527
  • SX720, SX260, SX210 & SX200
Phil, the mkdir maybe is best to use a define for this cam,

Gps stuff can be ignored since not tested or worked yet

spaces no clue, will check out

*

Offline ADamb

  • **
  • 65
  • sx200is
sx200is_100c
1. vid_bitmap_refresh() from ixus870_sd880, gives less flicker than original one.
2. custom palette (philmoz), so CAM_BITMAP_PALETTE changed from 3 to 13.
Now all missing colors are in place.
SX200 IS-100C


*

Offline reyalp

  • ******
  • 13673
sx200is_100c
1. vid_bitmap_refresh() from ixus870_sd880, gives less flicker than original one.
2. custom palette (philmoz), so CAM_BITMAP_PALETTE changed from 3 to 13.
Now all missing colors are in place.
Added in trunk changeset 1886 release changeset 1888

As phil noted here http://chdk.setepontos.com/index.php?topic=6231.msg85982#msg85982 we don't have a full firmware dump from this camera. If you can get one using the canon basic dumper http://chdk.wikia.com/wiki/Canon_Basic/Scripts/Dumper that would be helpful.
Don't forget what the H stands for.

*

Offline ADamb

  • **
  • 65
  • sx200is
I copied my sx200is_100c dump here:
https://skydrive.live.com/redir?resid=67C21A0ED1F7A310!161&authkey=!ACChwRvupSTR7Uo

Here comes last change - I switched from palette_buffer to palette_buffer_ptr, which can be found in disassembly.
For example, here are defs for d10_100a:
DEF(palette_buffer_ptr,               0x8494) // links to 0xxxxxxx, sub_FF9B4804
DEF(active_palette_buffer,            0x8D8C) // sub_FF9B4A20
DEF(palette_control,                  0x8D88) // sub_FF9B4A20
SX200 IS-100C

*

Offline fe50

  • ******
  • 3139
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
I copied my sx200is_100c dump here:
https://skydrive.live.com/redir?resid=67C21A0ED1F7A310!161&authkey=!ACChwRvupSTR7Uo
Thanks.
Added the
  • SX200 1.00C
full 8MB dump (dumped with cBasic udumper) by ADamb from this forum post to the box.net/chdk repository.
Note: this 8MB full dump replaces the old 4MB one.

v1888 does not seem to work on my SX200. It shows only wellcome screen without CHDK, and after that black screen and does nothing. v1825 does work!
(A 410), SX 200, (SX 280), SX 700


*

Offline srsa_4c

  • ******
  • 4447
v1888 does not seem to work on my SX200. It shows only wellcome screen without CHDK, and after that black screen and does nothing. v1825 does work!
I'd suspect
Code: [Select]
DEF(palette_buffer, 0x15B5A0)as MEMISOSTART is 0x12351C .
It's probably corrected in the above patch.

*

Offline ADamb

  • **
  • 65
  • sx200is
Quote
v1888 does not seem to work on my SX200. It shows only wellcome screen without CHDK, and after that black screen and does nothing. v1825 does work!
I have these on my sx200is:
OPT_EXMEM_MALLOC=1
OPT_CHDK_IN_EXMEM=1
You should wait till last changes are committed to trunk (palette_buffer_ptr).
SX200 IS-100C

 

Related Topics