Struggling with G12 Install - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum supplierdeeply

Struggling with G12 Install

  • 4 Replies
  • 3904 Views
Struggling with G12 Install
« on: 20 / July / 2011, 17:20:44 »
Advertisements
I have determined my G12 uses the 1.00E version, and I have downloaded the files to my computer. I have used Cardtricks to format a 256MB card as FAT16 for testing. I have locked the card.

But when I insert the card, and turn on the camera, nothing happens. What am I missing?

I was NOT able to make the card bootable in Cardtricks (The Make Bootable button was grayed out.)

*

Offline fe50

  • ******
  • 3147
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Struggling with G12 Install
« Reply #1 on: 20 / July / 2011, 17:33:12 »
Hello & welcome, skipdidit !

But when I insert the card, and turn on the camera, nothing happens. What am I missing?
I was NOT able to make the card bootable in Cardtricks (The Make Bootable button was grayed out.)
The CHDK autoload will only work with a CHDK-bootable SD card.
You could either use another method/tool to make the card CHDK-bootable (read more here) or start CHDK manually with "Firm Update" from the Canon menu like described here in the CHDK user manual...

Re: Struggling with G12 Install
« Reply #2 on: 20 / July / 2011, 18:39:29 »
The manual "firm update" on my G12 worked and I see the CHDK splash screen. But that's all.

I've printed the manual and followed the instructions, so I know what I'm supposed to be seeing, but I still can't see the <ALT> mode.

Maybe it's my 256MB card. I'll try the steps to create a bootable card using another card.

*

Offline philmoz

  • *****
  • 3450
    • Photos
Re: Struggling with G12 Install
« Reply #3 on: 20 / July / 2011, 18:44:47 »
The manual "firm update" on my G12 worked and I see the CHDK splash screen. But that's all.

I've printed the manual and followed the instructions, so I know what I'm supposed to be seeing, but I still can't see the <ALT> mode.

Maybe it's my 256MB card. I'll try the steps to create a bootable card using another card.

The shortcut button (top left of camera) activates Alt mode on the G12.
Once you've booted CHDK using the firmware update method select 'Make card bootable' from the 'Miscellaneous stuff' menu. You won't see any on screen messages; but this should make the card bootable. After using this option power off, lock the SD card and it should now autoboot CHDK.

This only works for cards up to 4GB. Larger cards need to be partitioned (which is a whole other topic).

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)


Re: Struggling with G12 Install
« Reply #4 on: 20 / July / 2011, 21:02:34 »
Hmmm. I know I pressed the shortcut button several times. Maybe too quickly or not long enough.

Anyway, I am now able to see the menu! I'll get back to the manual and hopefully be able to figure this all out.

My main interest in CHDK is getting longer exposure times-- beyond 15 seconds.

Thanks for your help and quick response!

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal