CHDK for the G10 : Beta Testing : - page 3 - CHDK Releases - CHDK Forum

CHDK for the G10 : Beta Testing :

  • 126 Replies
  • 39894 Views
Re: CHDK for the G10 : Beta Release Testing
« Reply #20 on: 31 / July / 2011, 10:09:06 »
Advertisements
time lapse for the camera for CHDK firmware 1.02A G10?.
This will be possible using scripts once the porting process is complete.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: CHDK for the G10 : Beta Release Testing
« Reply #21 on: 31 / July / 2011, 11:37:45 »
Beta 1 works as expected with version 1.04A!

re: 1.04A Beta 2c

everything seem to work although..
-can not start in "playback" mode ( blue light -> on/off light-> powershot screen-> green light-> shutdown)
-can not switch from "shoot" mode to "playback" mode (camera shuts down + lens does not retract)
-lens does not retract on shutdown (when pressing on/off)
-lens subsequently retracts by pressing either "playback" or "on/off" (then promptly shuts down)

@matto :  did you experience the same behavior with beta1 as with beta 2 ?
Ported :   A1200    SD940   G10    Powershot N    G16

Re: CHDK for the G10 : Beta Release Testing
« Reply #22 on: 31 / July / 2011, 12:55:29 »
time lapse for the camera for CHDK firmware 1.02A G10?.
This will be possible using scripts once the porting process is complete.

thank you very much

Re: CHDK for the G10 : Beta Release Testing
« Reply #23 on: 31 / July / 2011, 17:11:02 »
Hi All,

I've performed the same tests as Matto with my G10 (1.03B with CHDK Beta2b).
-Starting in playback mode is working
-I'm able to swtich from playback to shooting mode and back to playback with no problem at all
-Lens retract correctly if I shut down or when I switch to playback mode.

I've found a different problem in my version. When I swtich on the camera in shooting mode (pressing the on/off switch) it start in playback mode. I've to half-press my the shutter button to switch it to shooting mode.
P.s. Waterwings, with Beta2B have you removed the function to start the camera without CHDK by holding for 2-3 sec the on-off button ?

I'm also trying the same configuration with 2 different SD card:
1) 4 gbyte SD card formatted in FAT16 and made bootable
1) 16 gbyte SD card partitioned wth sdminste.exe program (as CHDK faq) with a 2mb chdk partion (fat2?!?) and one fat32 partition for the rest of the card (I found this restriction AWFUL because it's not very practical to download the photo)

When I use the 16gb card I cant' see the chdk logo during startup (but that is only a nuisance)

Thanks,
Riccardo


Re: CHDK for the G10 : Beta Release Testing
« Reply #24 on: 31 / July / 2011, 17:18:00 »
I've found a different problem in my version. When I swtich on the camera in shooting mode (pressing the on/off switch) it start in playback mode. I've to half-press my the shutter button to switch it to shooting mode.
Try holding the On/Off button down for 2-3 seconds.  When you press it quickly,  it goes into Playback mode - if you hold it down to start the camera is should go into shooting mode.

Quote
P.s. Waterwings, with Beta2B have you removed the function to start the camera without CHDK by holding for 2-3 sec the on-off button ?
As far as I know,  there never was such a function or mode.  So I'm pretty sure that I did not remove it.

Quote
When I use the 16gb card I cant' see the chdk logo during startup (but that is only a nuisance)
Which partition did you copy the CHDK files to ?  I think they basically need to be in both - the logo is read from a file and when the partitions swap,  it can't find the right file.

Ported :   A1200    SD940   G10    Powershot N    G16

Re: CHDK for the G10 : Beta Release Testing
« Reply #25 on: 31 / July / 2011, 17:25:04 »
-can not start in "playback" mode ( blue light -> on/off light-> powershot screen-> green light-> shutdown)
-can not switch from "shoot" mode to "playback" mode (camera shuts down + lens does not retract)
-lens does not retract on shutdown (when pressing on/off)
I've built a special version of beta 2 for firmware 1.04A.    In this version, when you press the playback [>] button the camera should start in playback.  If you press the On/Off button quickly, the camera also starts in playback.  Holding the On/Off button down will not start the camera at all.   If you want to enter shooting mode,  half press the shutter when the camera is in playback mode.  To shutdown the camera in payback mode,   press either the playback button [>] or the On/Off switch.  To shutdown the camera if the lens is extended,   you can only use the On/Off button.

download link :  G10 Beta 2c special for firmware 1.04a

Let me know how that works out ?



Ported :   A1200    SD940   G10    Powershot N    G16

Re: CHDK for the G10 : Beta Release Testing
« Reply #26 on: 31 / July / 2011, 22:52:49 »

@matto :  did you experience the same behavior with beta1 as with beta 2 ?


No problem with Beta1, behaving as expected..

Quote
G10 Beta 2c special for firmware 1.04a

Let me know how that works out ?

..not much luck i'm afraid:
-on/off  (blue light->on/off light ->powershot screen -> shut down)
-[>]      (blue light->on/off light ->powershot screen -> shut down)

cheers



Re: CHDK for the G10 : Beta Release Testing
« Reply #27 on: 31 / July / 2011, 23:04:42 »
No problem with Beta1, behaving as expected..
Quote
G10 Beta 2c special for firmware 1.04a
..not much luck i'm afraid:
-on/off  (blue light->on/off light ->powershot screen -> shut down)
-[>]      (blue light->on/off light ->powershot screen -> shut down)

So beta 2c special does not allow you to startup at all in CHDK mode?  Strange,  as it basically the same as beta 1 but with the movie_record task enabled.

And if I re-read your earlier comment about beta 2c,  the only CHDK mode you can use is shooting mode ?

UPDATE : Please excuse my asking this, but is there any chance you are using the wrong firmware version ?

« Last Edit: 31 / July / 2011, 23:08:59 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16


Re: CHDK for the G10 : Beta Release Testing
« Reply #28 on: 01 / August / 2011, 03:48:44 »

And if I re-read your earlier comment about beta 2c,  the only CHDK mode you can use is shooting mode ?

UPDATE : Please excuse my asking this, but is there any chance you are using the wrong firmware version ?

no problem at all, thou defiantly version GM1.04A..

The problem seems to be something to do with partitions on the SD card?

Have been using a 16GB partitioned Card ( fat16 / fat32) (diskboot.bin in fat16 and CHDK folder in both)..

But.. with another 2GB SD card (fat16) and NO partition.. ALL 1.04A versions work as expected!

sorry i didn't try this before.. must be missing a step with the partitioning?

Cheers






« Last Edit: 01 / August / 2011, 07:08:05 by matto »

Re: CHDK for the G10 : Beta Release Testing
« Reply #29 on: 01 / August / 2011, 20:15:43 »
The problem seems to be something to do with partitions on the SD card?

Have been using a 16GB partitioned Card ( fat16 / fat32) (diskboot.bin in fat16 and CHDK folder in both)..

But.. with another 2GB SD card (fat16) and NO partition.. ALL 1.04A versions work as expected!

@matto :  this could be an important clue.  I have an 8G card that I will setup with dual partitions and experiment with my 1.02A camera.   Has anyone else tried these beta's on a dual partition card ?


Update :    dual partitions seem to be fine with 1.02A.  Any feedback on other versions ?


« Last Edit: 01 / August / 2011, 20:31:00 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics