IXUS 115 HS / ELPH 100 HS request - page 26 - DryOS Development - CHDK Forum supplierdeeply

IXUS 115 HS / ELPH 100 HS request

  • 538 Replies
  • 218452 Views
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #250 on: 26 / June / 2012, 16:03:46 »
Advertisements
@waterwingz:
firmw.1.01b
It seems, that your new build is loaded, as something, what could be the boot logo, is on the screen: two bars of pixels horizontally across the screen - none being a picture, and after a second or so they disappear. Switching to alt mode seems to be possible, but the menus consist of two bars of pixels, seemingly a menus, as in each bar a line of another color can be moved up and down. Battery: I cannot say, as there is no CHDK-OSD (or it is distorted to  pixels).
Ruedi
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe

*

Offline dnw

  • *
  • 22
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #251 on: 26 / June / 2012, 18:11:40 »
I've rebuild the code for the IXUS115 from the last source I could find on this thread and converted for the new development trunk. 
Camera firmware 1.01C.

I get same results as  RueLue. It would seem the display parameters are incorrect.

I am keen to get the raw-DNG processing working properly so will help with testing.

regards
David
A530 & IXUS 115 HS Firmware version, 1.01C, CHDK status:   user

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #252 on: 27 / June / 2012, 13:46:12 »
I also get the same results as RueLue. My firmware version is 100c.

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #253 on: 27 / June / 2012, 23:39:43 »
and I cannot see the CHDK menu displayed correctly, the menu seems to be splited into two menus.
It seems, that your new build is loaded, as something, what could be the boot logo, is on the screen: two bars of pixels horizontally across the screen - none being a picture, and after a second or so they disappear. Switching to alt mode seems to be possible, but the menus consist of two bars of pixels, seemingly a menus, as in each bar a line of another color can be moved up and down.
I get same results as  RueLue. It would seem the display parameters are incorrect.
I also get the same results as RueLue. My firmware version is 100c.

Okay - it looks like the old code I found was from before the CAM_USES_ASPECT_CORRECTION changes were made.

I've rolled those in and rebuilt.   Let's try this again ?

1.00c >https://www.box.com/s/636d9fa2e401663580b7
1.01a >https://www.box.com/s/0d994079a6778560e736
1.01b >https://www.box.com/s/dd829f4a7ccb3d2f16e2
Ported :   A1200    SD940   G10    Powershot N    G16


Re: IXUS 115 HS / ELPH 100 HS request
« Reply #254 on: 28 / June / 2012, 00:33:17 »
Tried and still the same as what described by ruelue

the CHDK logo is not displayed correctly, showing two blocks of color, and the CHDK menu is also not shown correctly.

and still sometimes shows "please change battery pack" when starting, even if my battery is more than 80%

*

Offline dnw

  • *
  • 22
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #255 on: 28 / June / 2012, 02:25:12 »
Tried and still the same as what described by ruelue

Same as Larrycafe reported. Logo hardly noticeable, the menu still two bands of distorted colour but different from last time.

Firmware version 1.01C
A530 & IXUS 115 HS Firmware version, 1.01C, CHDK status:   user

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #256 on: 28 / June / 2012, 04:51:34 »

waterwingz wrote:
Quote
Let's try this again ?

1.01b:
no changes observed

dnw wrote:
Quote
two bands of distorted colour but different from last time.
I didn't examine this deep, but right: still distorted.

Ruedi
« Last Edit: 28 / June / 2012, 04:53:33 by RueLue »
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #257 on: 28 / June / 2012, 05:27:53 »
Okay - last try for now.  Lifted the display values from IXUS220 as it appears from the specs to be indentical although physically larger.
1.00c >https://www.box.com/s/5c0d244376c57cfdffd8
1.01a >https://www.box.com/s/a65ca812b127165562c6
1.01b >https://www.box.com/s/6b65692a43ba2efbff3c
Sorry - this is really hard to do when you don't have the camera.
Ported :   A1200    SD940   G10    Powershot N    G16


Re: IXUS 115 HS / ELPH 100 HS request
« Reply #258 on: 28 / June / 2012, 06:02:26 »
Okay - last try for now.  Lifted the display values from IXUS220 as it appears from the specs to be indentical although physically larger.
1.00c >https://www.box.com/s/5c0d244376c57cfdffd8
1.01a >https://www.box.com/s/a65ca812b127165562c6
1.01b >https://www.box.com/s/6b65692a43ba2efbff3c
Sorry - this is really hard to do when you don't have the camera.

thank you very much, I will try later tonight when I get home.

what is your up time actually? I am in the Asia region.

and is there any programming things we can help? I am new to CHDK but I studied computer in university, wrote a lots of program.

*

Offline dnw

  • *
  • 22
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #259 on: 28 / June / 2012, 07:19:46 »
Okay - last try for now.

Not really any different from the previous ones. The Logo produces a distorted flash on the screen. The menu is in two horizontal distorted bars taking up about 40% for the screen space. When CHDK is active there is no trace of the <ALT> at the bottom of the screen.

 
A530 & IXUS 115 HS Firmware version, 1.01C, CHDK status:   user

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal