IXUS 115 HS / ELPH 100 HS request - page 6 - DryOS Development - CHDK Forum

IXUS 115 HS / ELPH 100 HS request

  • 538 Replies
  • 150857 Views
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #50 on: 12 / October / 2011, 07:04:57 »
Advertisements
Thanks waterwingz for your reply.
CHDK is now working on my camera, but still have few problems.
The biggest problem is that  button combination FUNC SET + ZOOM IN works only sometimes and I have problem to get to CHDK menu. Strange...

Also Zebra mode is working bad, it produces just blinking of red lines in bottom half of screen, not on places it should be.

I was also playing with RAW.
Camera was able to produce CRW images but I didn't find any program to convert them and give up with CRW. Then I tried to set up shooting to DNG. Generatin of badpixel.bin is not working so I created blank badpixel.bin.
Then camera was then able to save DNG, but file seems to be bad, just geen and purple colors, strange stripes, ...

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #51 on: 12 / October / 2011, 07:26:15 »
Typical problems with a new port when the values in platform_camera.h and lib.c have not been set correctly.  The developers have a little more "clean-up" work to do. 

As far as CRW files though,  you need to search the wiki and forum to learn what they are and how to use them.  New users tend to make the wrong assumptions about them.

Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #52 on: 12 / October / 2011, 07:43:19 »
Okay there have been many bugfix posts, mingled in with support posts.

Remember there's only Just.J working on this, so keep making sure you have the latest alpha installed, and make short dot-point lists if you are reporting bugs

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #53 on: 12 / October / 2011, 09:32:40 »
Hi everyone!
I reuploaded 101b_alpha5 version. Hope it'll start correctly.

I'll make list of bugs on the first page of this thread (in my first message)

But unfortunately for a few weaks I'll have no time to develop this port because of my university exams... If someone want to help me in making code "clean up" - you're welcome, I'll share sources with you.

John.


Re: IXUS 115 HS / ELPH 100 HS request
« Reply #54 on: 12 / October / 2011, 09:46:06 »
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline 2face

  • *
  • 11
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #55 on: 12 / October / 2011, 15:29:54 »
hi there and thanks for all your work!

i tried to use chdk to get pictures with different EV-values (for HDR),  but the camera is not changing them.
i used the "Bracketing in Continuous Mode" settings in chdk with the "+/-" setting with "EV 1" steps and started the custom timer with 5 pics - all of them look the same.
(Ixus 115HS 101a)

thanks!

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #56 on: 12 / October / 2011, 21:04:49 »
i tried to use chdk to get pictures with different EV-values (for HDR),  but the camera is not changing them.
i used the "Bracketing in Continuous Mode" settings in chdk with the "+/-" setting with "EV 1" steps and started the custom timer with 5 pics - all of them look the same.
From memory, I think you are doing that right.  The ELPH100 is a new camera so its possible that it does not work correctly though.

If you want to try a simple scripting version, the recent builds have a script called hdr.lua in /CHDK/SCRIPTS/4PACK/LUA that will give you three images at +2EV, 0EV, -2EV image.  You could easily extend for +2, +1, 0, -1, -2 if it works for you.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline 2face

  • *
  • 11
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #57 on: 13 / October / 2011, 10:01:23 »
hi again,
i tried the hdr.lua script - it started, but the cam only takes one picture.
it seems to me that the script stops for some reason, because  it says "aborted" if i´m trying to start the script again.
i compared the hdr.lua scripts of different full packages, but they are always the same, so my theory that there is another variable than "tv96" necessary with different cams seems to be wrong...


Re: IXUS 115 HS / ELPH 100 HS request
« Reply #58 on: 16 / October / 2011, 12:59:59 »
Hi, John!
* My 1.01b now loads alpha5.2 - thankyou!
* Video starts, as it should be. Thankyou!
* Scripts: the problem with them is, seemingly, connected to function calls, so
        as "IS_...", "GET_..." etc. ; 'easy' scripts, as e.g. shoot, lotto don't
        show problems, while hdr and interval stop halfway through (and cause
        further problems with starting of scripts).

Ruediger
+++ sorry, eieruhr aka eggtimer doesn't function, but countdown, input, metronom, stopwatch do it. Rue.
« Last Edit: 16 / October / 2011, 23:54:10 by RueLue »
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe

*

Offline siak

  • *
  • 26
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #59 on: 17 / October / 2011, 06:29:20 »
CHDK alpha 5 101a
Optical zoom in/out and auto focus work perfectly on my camera. but there is still a 10 minutes restriction on vid capturing and there is no manual focus. but I'm so glad that there chdk for 100 hs has appeared! thanks a lot! I hope this project will develop. good luck!

 

Related Topics